Weblinks in TB werden im FF doppelt geöffnet

  • Nach den Updates von den 13ern auf die aktuellen 14er-Versionen von Thunderbird und Firefox verhält es sich bei mir so, dass beim Klicken auf einen Link in einer TB-Mail-Nachricht der FF-Browser doppelt (2 Tabs oder 2 Instanzen) mit den entsprechenden Link-Seiten geöffnet wird, jedenfalls dann, wenn der Browser vorher noch nicht gestartet war.
    Das ist bei meinem PC so, bei dem meiner Frau und dem unserer Tochter.


    Habe mal TB 13 zurück-/drüberinstalliert, Problem bleibt, muss demnach am Update auf FF 14 liegen.


    Habe zudem mal Hyperlink in WORD angeklickt. Auch dann öffnet sich der FF doppelt.


    Habe ferner mal den FF auf die Vers. 13 gedowngraded, da besteht das Problem nicht!


    Alle WinXP Pro 32bit

  • Zitat von CompMan

    - Nach den Updates von den 13ern auf die aktuellen 14er-Versionen von Thunderbird und Firefox - [...]
    Das ist bei meinem PC so, bei dem meiner Frau und dem unserer Tochter.


    Was habe die 3 Profile (einstellungs-, erweiterungs- + klingeldrahtmäßig gesehen :wink: ) gemeinsam?

  • Die Einstellungen sind identisch. Erweiterungen teils auf allen Systemen vorhanden, teils nur bei mir.
    FF 13 macht keine Probleme mit diesen Erweiterungen.
    Habe mal alle AKTIVEN Erweiterungen deaktiviert und neu gestartet.
    Das Problem ist geblieben.
    An den AddOns kann's dann wohl nicht liegen.
    Habe im Net mal von einem solchen Bug bei FF 0.9 gelesen, das dürfte sich aber wohl zwischenzeitlich erledigt haben, zumindest bis zur Version 13.

  • CompMan,
    da ich hier anders zwischen Tb + Fx arbeite, kann ich nicht vergleichbar zu deiner Vorgehensweise reproduzieren. Deshalb möchte ich zunächst auch einen neuen od. aufgebrochenen Bug nicht ausschließen!


    Hier - also mit meiner Arbeitsweise - öffnet Fx (egal welche Version!) immer nur (optional) einen Tab je Tb-Link!


    Ich wäre an dem Ergebnis interessiert, welches aus der Reproduktion mit deinem zunächst normalen Tb (Profil) und einem cleanen Fx- Profil auftritt. Deine Frau + Tochter lass bitte dabei außen vor!

  • Neues Profil TEST im FF angelegt, "beim Starten fragen" gewählt, FF geschlossen.
    Web-Link in einer Mail angeklickt - FF öffnet "nur" einmal, wie es sein soll.

  • Falls du die Version v14 genommen hast, ist es also kein neuer und auch kein aufgebrochener Bug!


    Dann gebe es jetzt 2 generelle Möglichkeiten.


    Zum einen könntest du versuchen das Fehlverhalten im Altprofil zu lokalisieren und die Ursache zu beseitigen (Profil-Reparatur). Die Verdächtigen (in der Reihenfolge) sind eingebundene Extension, Scripts und ggf. vorgenommenen Einstellungen im Config-Tableau oder mit einer user.js. Zu Extension ist Safe Mode ein unschlagbares Instrument. Extension, welche einzeln ein solches Verhalten hervorrufen, sind mir mom. nicht bekannt. Jedoch würde ich auf irgend eine Tab-Extension (deren Einstellung) tippen wollen.


    Sollte dir das zu umständlich sein, baue dir aus diesen Test-Profil (oder einem Firefox-Rest-Profil) ein neues Profil auf, welchen ggf. zum entsprechenden Zeitpunkt und Frau + Tochter zur individuellen Fertigstellung (PLACES, Login-Daten u.ä.m.) kopiert werden kann. Oder wenn du sicher bist lass deren neue Profile über das Firefox-Reset vorbereiten.


    Mit einem gewissen Aufwand sind beide Wege verbunden! :wink:


    PS. Arbeitet mit Sicherungen!

  • In der Tat zwei sehr aufwendige Wege. Hab's daher erst einmal wie folgt versucht:


    1) Download Vollversion FF 13 (Vorversion)
    2) Über die vorhandene 14er drüberinstalliert
    3) Aus FF heraus nun nach Updates gesucht, die 14er gefunden, heruntergeladen (diesmal 19,7 MB, war kürzlich definitiv weniger, egal) und installiert (14.0.1).
    4) FF gestartet, Seite "Whatsnew" erscheint wie immer nach Update, FF wieder geschlossen
    5) Weblink aus einer Mail angeklickt - FF 14 öffnet nur einmal, wie es sein soll


    ABER:


    6) Systemneustart - und das Problem ist wieder da. Komisch: Seite "Whatsnew" erscheint ein weiteres Mal.


    Bleibe ich hingegen beim FF 13.0, habe ich das Ausgangsproblem auch nach einem Systemneustart nicht! Und das werde ich wohl machen müssen, bis das Problem erledigt ist. An den Profilen/Erweiterungen dürfte es demzufolge nicht liegen.


    Anschließend testweise mal FF 14.0.1 drüberinstalliert, allerdings nicht per Update, sondern per *.exe.
    Erstes Öffnen bringt "Whatsnew", danach nicht wieder.
    Erster Klick auf Weblink öffnet FF nur einmal. FF schließen. Erneuter Klick auf Weblink öffnet FF wieder doppelt (2 Instanzen).


    Wohl ganz klar ein Problem vom FF 14.

  • Anknüpfend an die Beiträge #5 + #6.
    Bezüglich Profilreparatur (Extension) od. -neuaufbau hast du also nichts unternommen? Ja?


    v14.
    Unter Beachtung des von mir weiter oben Gesagten ist mir mom. kein Bug + keine Veränderung mit dieser Auswirkung bekannt. Für die v14 gibt es außerdem 14 harte Gründe [1]!


    Klar, dein Problem sollte gelöst werden!
    Aber du gestattest mir eine private Meinung? Ich bin persönlich beim Klicken auf Links (vor allem auch in einer Mail) sehr, sehr konservativ. :wink:


    [1] http://www.mozilla.org/securit…es/firefox.html#firefox14

  • Nein, am Profil habe ich nichts zu reparieren versucht (weiß auch nicht, wie das geht). Da es hier drei PCs betrifft, glaube ich nach wie vor nicht an diese Ursache. Neues Profil erstellen scheidet aus, weil ich die vielen Einstellungen, die ich über Jahre z. B. in der about:config gemacht hatte, nie wieder hinbekommen werde.
    Ich stimme Dir zu, dass ein Update auf die V. 14 unbedingt zu empfehlen ist, aber momentan stelle ich es zurück. Vielleicht wird mein Problem später mal behoben, wenn weitere Anwender das gleiche Problem haben sollten.


    Beim Klicken auf Weblinks in einer Mail bin ich ebenfalls mehr als zurückhaltend; bei etwaigen Zweifeln mache ich das vorab in einer VM.

  • Hi,


    ist das Problem eigentlich gelöst?


    Ich habe seit dem Update auf FX14.0.1 das selbe Problem aus TB. :-??

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Hi,


    also doch noch nicht gelöst. :cry:


    Das Problem ist seit dem Update auf 14.0.1. Und dann auch nur wenn der Link den FX öffnen muß.

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Ein Rückgang auf eine alte, mittlerweile unsichere Browserversion ist fahrlässig, gefährlich und keine Lösung!
    Ich nutze Thunderbird und Firefox und habe diese Probleme nicht. Es liegt also an den jeweiligen Systemen, installierter Software oder gewählten Einstellungen.
    Bereits empfohlen wurde ein neues Profil für Firefox. Dies würde ich euch beiden empfehlen. Vorher könnte man zunächst die Rücksetzung des derzeitigen Profils testen.
    Klickt auf Hilfe :arrow: Informationen zur Fehlerbehebung :arrow: Firefox zurücksetzen
    Dies wird Firefox auf die Standardeinstellungen zurücksetzen. Deine Lesezeichen und Passwörter gehen dabei nicht verloren. Die Erweiterungen müssen allerdings neu installiert werden.

  • Obwohl's schon eigenartig ist, dass es bei FF 13 keine Probleme gibt, sondern erst beim 14er, würde ich das gern mal versuchen, Boersenfeger.
    Müssen die PlugIns ebenfalls neu installiert werden?
    Bleiben beim Rücksetzen die Einstellungen in der about:config erhalten?
    Formulardaten auch?

  • Die Plugins werden von Firefox aus dem System eingelesen.
    Die Einstellungen via about:config werden gelöscht. Hier empfiehlt sich die Verwendung einer User.js
    http://www.camp-firefox.de/for…opic.php?p=812442#p812442
    Die Formulardaten werden nicht gelöscht...

  • Hi,


    hat funktioniert. :D ...... So eine "Reset-taste" wirkt manchmal Wunder :wink: .


    Und die 3-4 Erweiterungen waren ja schnell wieder installiert, auch die Oberfläche schnell wieder angepasst. :lol:


    [Zusatz]
    Ich hatte bloß etwas Angst um meine Lesezeichen-Leiste.... ;) Aber wurde ohne Probleme übernommen.
    Besten Dank noch einmal!
    [/Zusatz]

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Das hört sich ja vielversprechend an.
    Die Anleitung zur User.js, Boersenfeger, ist leider nur in englisch, aber wenn ich das richtig verstanden habe, sollen die gewünschten Einträge in eine leere Datei geschrieben werden.
    Ich weiß aber heute nicht mehr, was ich im Laufe der Jahre alles in der about:config geändert hatte, auch wenn es insgesamt max. 5 Einträge waren.
    Kann man nicht die vorhandene about:config-Datei, wie auch immer sie genau heißen mag, vor der FF-Reparatur auf einem Stick sichern und anschließend wieder zurückspielen?

  • tippe about:support in die Adresszeile, scrolle bis Wichtige modifizierte Einstellungen, dort tauchen alle wichtigen Änderungen auf. Allerdings auch die, die durch Erweiterungen gesetzt wurden.
    Genauer gehts via about:config, klicke hier auf Status und schaue dir die Einträge vom Benutzer festgelegt an. Auch hier sind die Änderungen, die durch deine installierten Erweiterungen erzeugt wurden, enthalten. Ggf. findest du die 5 eigenen ja heraus.
    Wenn du die Änderungen (prefs.js) kopierst und in das neue Profil einfügst, hast du u.U. den Fehler mit kopiert. Von früheren Änderungen, die nicht mehr aktiv sind ganz zu schweigen...