JSON-Viewer Plugin im Notepad++

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Es sieht so aus, dass ich anscheinend zu doof bin, das JSON-Viewer Plugin im Notepad++ zum Laufen zu bringen, so dass ich eine bessere Formatierung als diese hier erhalte:



    Wenn ich in der Plugin-Verwaltung den JSON-Viewer auswähle, dann kann ich zwar das Plugin installieren, aber nachdem er mit Adminrechten anscheinend irgendwas installiert hat und ein Neustart durchgeführt hat, kann ich keine Änderung oder neue Formatierungsmöglichkeiten feststellen. Im Plugin-Ordner befinden sich auch keine neuen DLLs.:/



    Wer kann mir auf die Sprünge helfen und mir sagen, was ich falsch gemacht oder übersehen habe?


    Vielen Dank im Voraus :)

  • Wer kann mir auf die Sprünge helfen und mir sagen, was ich falsch gemacht oder übersehen habe?

    Wahrscheinlich nichts. Es gibt nämlich einen Bugreport:


    Notepad++ 8.3.2 doesn't work with JSON Viewer plugin 1.4.0 · Issue #11380 · notepad-plus-plus/notepad-plus-plus
    Description of the Issue Notepad++ 8.3.2 (32 bit or 64 bit) doesn't work with JSON Viewer plugin 1.4.0. Notepad++ doesn't start. Steps to Reproduce the…
    github.com

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Wahrscheinlich nichts. Es gibt nämlich einen Bugreport:

    Danke für deine Antwort. Ich habe die 8.3.3 installiert und außer dem Bugreport-Ersteller scheint ja niemand das gleiche Problem zu haben. Außerdem startet ja nach der Installation des JSON-Viewers sein Notepad++ gar nicht mehr:

    Zitat

    Notepad++ 8.3.2 (32 bit or 64 bit) doesn't work with JSON Viewer plugin 1.4.0. Notepad++ doesn't start.

    Das ist bei mir nicht der Fall! Notepad++ funktioniert danach ganz normal. Es wird anscheinend kein Viewer-Plugin bei mir installiert. :/

  • Ich habe noch NPP 8.3.2. Da funktioniert JSON Viewer, habe z. B. die addons.json im Firefox-Profil getestet. Das wird mir schön formatiert. Ohne Farbe, aber immerhin nicht alles aneinandergeklatscht.


    Mit NPP 8.3.3 auch kein Problem.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

    Einmal editiert, zuletzt von milupo () aus folgendem Grund: Ein Beitrag von milupo mit diesem Beitrag zusammengefügt.

  • Ok, Problem gelöst! :)


    Es war meine Firewall. Ich habe immer alphabetisch nach Applikationen sortiert gehabt, der Update-Prozess heißt aber "WinGup for...".

    Nur merkwürdig, dass mich meine Firewall nicht gefragt hat, ob ich eine Verbindung erlauben möchte. :/ . Aber egal, jetzt läuft's ...:P

  • Diese verfluchte Sicherheit immer. ;) :D

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Diese verfluchte Sicherheit immer. ;)

    :thumbup:


    Freiwillig und anlasslos erlaube ich bei meinen selbst installierten Anwendungen erst mal gar nichts :evil: .

    Da muss die Anwendung erst bei meiner Firewall anklopfen, welche mir dann Bescheid gibt und dann wird von Fall zu Fall entschieden.

    Ich liebe meine Paranoia und das Tool 'Windows10 Firewall Control'...;)

  • Tut mir leid für die sehr späte Meldung.

    Hier NPP 8.3.3 x86 (wegen TextFX, der Ersatz unter x64 funktioniert nicht richtig), JSON Viewer 1.4.0, funktioniert von Anfang an korrekt, seit es hier im Forum genannt wurde.


    Genannte Firewall erlaubt hier NPP für "WebBrowserZone", du darfst NPP gerne zu den (wenigen) vertrauenswürdigen Anwendungen zählen. Im Zweifelsfall kann ich dir den Nirsoft Sniffer für Verbindungen ohne SSL/TLS empfehlen, ansonsten WireShark (agiert ähnlich wie ein MITM).

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?