Firefox EXTREM Laggy wenn das Fenster maximiert ist

  • Hallo Leute,

    habe seit einiger Zeit massive Probleme mit Firefox und weiß mir nicht mehr wirklich zu helfen. Der Browser läuft relativ gut, wenn das Fenster NICHT maximiert ist (z.B. rechtsbündig über die halbe Bildschirmbreite)

    Ist das Firefox Fenster jedoch maximiert wird der Browser ab ca 3-4 offenen Tabs gänzlich unbenutzbar, da es oft zu SEKUNDENLANGEN hängern kommt, die sich selbst auf den Mauszeiger auswirken. Das Problem tritt ausschließlich auf, wenn Firefox geöffnet und maximiert ist. Jegliche Tests des PCs (Stabilität, Festplatte usw.) sind erfolgreich, ich habe mit nichts anderem Probleme außer eben mit dem maximierten Firefox. Die üblichen Dinge wie Addons abgeschaltet, firefox aufgefrischt usw. habe ich bereits ohne Erfolg probiert.

    Ich habe unter https://support.mozilla.org/bm/questions/1157360?&mobile=0 eine ziemlich ähnliche Fehlerbeschreibung gefunden, die dort offerierte Lösung hat das ganze jedoch nur gefühlt ein klein wenig verbessert.

    Zu meinem Setup:
    AMD Ryzen 7 2700X
    32GB Ram
    Samsung M2 Pro SSD
    GTX 1060 6GB
    4 Monitore (evtl. hat es damit was zu tun?):
    1x 3840x2160
    2x 1920x1080 (einmal 180grad gedreht)
    1x 1200x1920 (um 90 grad gedreht)

    Ich hoffe ihr habt einen Ansatzpunkt - mir bleibt sonst nur der (nicht gewollte) Wechsel zu Chrome. So kann ich aber nicht mehr arbeiten wenn jeder zweite Klick oder Tab-Wechsel sekundenlages Einfrieren zur folge hat.

    Danke & Grüße
    DR

  • Du könntest mal testen, ob sich das Problem auch im abgesicherten Modus zeigt.

    Ansonsten mal folgende Infos liefern:

    :arrow: Unter Hilfe => Informationen zur Fehlerbehebung kopierst du den Inhalt des Feldes durch Drücken der Schaltfläche Text in Zwischenablage kopieren und fügst den Inhalt in Klammer Code in deinen nächsten Beitrag ein.

    Anleitung (Seite ist zeitweise nicht erreichbar)


  • Du könntest mal testen, ob sich das Problem auch im abgesicherten Modus zeigt.

    Ansonsten mal folgende Infos liefern:

    :arrow: Unter Hilfe => Informationen zur Fehlerbehebung kopierst du den Inhalt des Feldes durch Drücken der Schaltfläche Text in Zwischenablage kopieren und fügst den Inhalt in Klammer Code in deinen nächsten Beitrag ein.

    Anleitung (Seite ist zeitweise nicht erreichbar)

    Danke für die Info! Ich bin nun einen knappen Tag im abgesicherten Modus unterwegs. Das massive Ruckeln und generelles lagging der Maus tritt nun nicht mehr auf.
    Der Seitenaufbau ist allerdings im abgesicherten Modus alles andere als schnell - erinnert ein wenig als hätte ich wieder DSL 6000 statt 300mbit.

    Wie gehts nun weiter? :)

    hier noch die diagnosedaten:

  • Bereinige mal dein Profil: https://support.mozilla.org/de/kb/firefox-bereinigen
    Dann entscheide dich nur für einen Werbeblocker. Auch wenn der zweite inaktiv war, kann es zu ungewollten Nebeneffekten kommen. Zudem erneuere mal ggf. die Treiber deiner Grafikkarte: https://www.nvidia.de/Download/driverResults.aspx/145411/de

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 120 (Stable Channel) - Linux Debian Bookworm: Firefox ESR 115.6.0 und Firefox Nightly und Beta (Mozilla PPA), Android 13: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)


  • Bereinige mal dein Profil: https://support.mozilla.org/de/kb/firefox-bereinigen
    Dann entscheide dich nur für einen Werbeblocker. Auch wenn der zweite inaktiv war, kann es zu ungewollten Nebeneffekten kommen. Zudem erneuere mal ggf. die Treiber deiner Grafikkarte: https://www.nvidia.de/Download/driverResults.aspx/145411/de

    Bereinigung hab ich bereits probiert, hat nichts verändern.
    Adblocker hatte ich bis vor ein paar Tagen in der Tat nur einen aktiv, habe den anderen nur kurz reingepackt um hier zu testen.

    Grafikkartentreiber habe ich aktualisiert.

    Wie wäre nun vorzugehen? Der reihe nach die Addons wieder mit dazu nehmen bis es Probleme gibt?

  • Also laut deinen Informationen zur Fehlerbehebung hast du kein bereinigtes Profil. Dies ist ein Profil mit unnötigen und doppelten Erweiterungen sowie deaktivierten.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 120 (Stable Channel) - Linux Debian Bookworm: Firefox ESR 115.6.0 und Firefox Nightly und Beta (Mozilla PPA), Android 13: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)


  • Also laut deinen Informationen zur Fehlerbehebung hast du kein bereinigtes Profil. Dies ist ein Profil mit unnötigen und doppelten Erweiterungen sowie deaktivierten.

    Öh... die Funktion "Firefox bereinigen" habe ich vor vier Tagen durchgeführt. Im Anschluss daran wurden halt Lesezeichen, Addons usw. wiederhergestellt. Oder sprichst du von etwas anderem?

    Ich mache gerade übrigends folgende Beobachtung:

    Firefox im abgesicherten Modus: keine Lags aber Seitenaufbau halt recht träge
    Firefox im normalen Modus aber alle Addons abgeschaltet: Tabs brauchen teils wieder 1-2 Sekunden beim hin und her wechseln

    Gibts technisch da noch einen Unterschied im Abgesicherten Modus abgesehen von den ausgeschalteten Addons?

  • Lässt du per Sync deine Lesezeichen sowie Addons synchronisieren? Wenn ja, dann deaktiviere dort mal die Funktion Addons. Melde dich bei Sync mit dem Rechner ab und bereinige dann deiin Profil erneut. Melde dich vorerst bei Sync nicht an, sondern probiere es so eine Weile. Und ja es gibt zwischen abgeschalteten Addons und dem abgesicherten Modus einen Unterschied, kann man aber aus dem genannten Links zum abgesicherten Modus erlesen.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 120 (Stable Channel) - Linux Debian Bookworm: Firefox ESR 115.6.0 und Firefox Nightly und Beta (Mozilla PPA), Android 13: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)


  • Lässt du per Sync deine Lesezeichen sowie Addons synchronisieren? Wenn ja, dann deaktiviere dort mal die Funktion Addons. Melde dich bei Sync mit dem Rechner ab und bereinige dann deiin Profil erneut. Melde dich vorerst bei Sync nicht an, sondern probiere es so eine Weile. Und ja es gibt zwischen abgeschalteten Addons und dem abgesicherten Modus einen Unterschied, kann man aber aus dem genannten Links zum abgesicherten Modus erlesen.

    Ja, ich synce alles - habe dies nun deaktiviert. Leider dennoch nach Bereinigung des selbe Problem.

    Das Wechseln zwischen Tabs dauert teils 1-2 Sekunden. Auch wenn ich mit der Maus in der Tab leiste nur auf und ab fahre hängt selbst das leichte Highlighten der Tabs wenn man mit der Maus drüber fährt immer wieder für 1-2 Sekunden. Auch das Tippen hier in der Textbox des Forums ist immer wieder durch Verzögerungen durchbrochen, wo das getippte nicht sofort erscheint.
    CPU Load hierbei 0% in den Firefox Prozessen, auch Datenträger bei 0%.

    Themes sind nun auch alle rausgefolgen, hat aber leider nichts verbessert. :(

    Hier nochmal die Support-Infos nach der neuen Bereinigung:

    Gibt es irgendwie mittlerweile eine art Obergrenze an geöffneten Tabs die der Browser mitmacht? Bis 4-5 Tabs habe ich keine Probleme. Üblich bei meiner Arbeitsweise sind aber 20-30 Stück. War bis vor ca. 4-5 Monaten kein Problem.


  • Deinstalliere testweise ESET damit:
    https://support.eset.com/kb146/?page=co…iewlocale=de_DE

    Wenn du Windows 10 benutzt, dann ist ein Schutz von Drittanbietern auch nicht notwendig, denn Windows 10 bringt einen eigenen Schutzt mit, der völlig ausrechend ist.

    Habe nun weiterin getestet - Virenscanner oder nicht macht leider auch keinen Unterschied.
    Auch ohne Addons kommt es immer wieder zu hängern, sobald Firefox länger als sagen wir mal 30 Minuten läuft und/oder viele Tabs offen sind. Im abgesicherten Modus nach wie vor ohne die massiven Hänger aber halt insgesamt sehr lahm.
    Auch nach wie vor reproduzierbar: Fenster etwas kleiner machen auf ~ 70% Monitorgröße: Alles OK
    Fenster größer oder maximiert: übelste Hänger.

    Hat noch jemand eine Idee?

  • Ja ich habe noch eine Idee.
    Kannst du mal den Arbeitspeicher prüfen? Einmal den Firefox komplett beenden. Dann zu beginn deiner Sitzung den Arbeitsspeicher prüfen und dann nach ca. 30 min. wenn deine Probleme beginnen. Wie ist der Arbeitsspeicher aller Firefoxprozesse? Wieviel Arbeitsspeicher steht dir zur Verfügung?

    Was hast du in den Webseiten geöffnet? Irgendwas CPU lastiges? Flash, Java, moderne HTML5 Elemente, irgendwelche Scripte die was Berechnen,... oder ähnliches?

    Die Partition auf der Firefox liegt, ist dort noch Speicherplatz frei?


  • Ja ich habe noch eine Idee.
    Kannst du mal den Arbeitspeicher prüfen? Einmal den Firefox komplett beenden. Dann zu beginn deiner Sitzung den Arbeitsspeicher prüfen und dann nach ca. 30 min. wenn deine Probleme beginnen. Wie ist der Arbeitsspeicher aller Firefoxprozesse? Wieviel Arbeitsspeicher steht dir zur Verfügung?

    Was hast du in den Webseiten geöffnet? Irgendwas CPU lastiges? Flash, Java, moderne HTML5 Elemente, irgendwelche Scripte die was Berechnen,... oder ähnliches?

    Die Partition auf der Firefox liegt, ist dort noch Speicherplatz frei?

    Es sind Tabs mit sehr gemischten Dingen offen - aktuell 5x booking.com, 6x die login seite von einem Großhandel, 5x geizhals, einmal DHL Tracking, 4x google, 1x strato und noch ein paar weitere einzelseiten. Alles nichts besonderes. Und es ist ja auch so, dass wenn ich das Firefox fenster etwas kleiner mache alles butterweich läuft.

    Direkt nach dem Neustart von Firefox gibt es 7 Firefox Prozesse die insgesamt 420 MB ram benötigen.
    Wenn ich dann alle Tabs einmal durchklicke (aktuell hab ich davon 26 Stück offen), werden es 11 Firefox Prozesse die sich 1606 MB RAM gönnen.

    Wenn ich dann anfange, zwischen den Tabs zu wechseln hängt es oft schon nach dem dritten vierten Tab - selbst wenn ich zwischen zwei Tabs hin und her wechsel (z.B. zwei Tabs von booking.com)

    Im Taskmanager sehe ich dazu parallel, dass die 11 Firefox prozesse in Summe auf 13-30% CPU load ansteigen - ein einzelner Prozess erreicht ~6% Load.

    Festplatten- und GPU aktivität pendelt zwischen 1 und 5% übers gesamte System verteilt, Datenträgeraktivität ist bei dauerhaft 0-2% übers gesamte System, auf der Systempartition sind aktuell 50,2 GB frei.

    Beim Schreiben dieser Zeilen hängt selbst zwischendrin die Eingabe der Buchstaben in das Textfeld immer wieder. Ich sehe parallel dazu im Taskmanager, dass der Prozess "System" (PID 4) während es hängt auf 10-13% CPU Load steigt. Dies bleibt auch konstant so: immer wenn es laggt, habe ich am Prozess "System" mit PID4 für die Dauer des Hängens ~10-13% CPU Last.

    All dies wie gesagt nur dann, wenn das Firefox Fenster auf dem 4K Monitor maximiert ist.


  • Und es ist ja auch so, dass wenn ich das Firefox fenster etwas kleiner mache alles butterweich läuft.

    Das verwundert mich eigentlich am meisten. Meine Idee war, das RAM oder CPU sehr ausgelastet sind. Aber deine Werte sehen eigentlich ganz gut aus. Und ob das Fenster maximiert ist oder nicht, sollte keinen Unterschied auf RAM oder CPU ausmachen.
    Ist das Verhalten bei anderen Anwendungen genauso? Verhält sich Chrome ähnlich?

    Vielleicht ist es irgendwo noch Einstellungssache? Einstellungen-Allgemein-Leistungen:
    "Empfohlene Leistungseinstellungen verwenden" Aktivieren/Deaktivieren mit diesen Einstellungen mal etwas experementieren. Spricht dich hier eine Einstellung an? Kommt dir dort etwas komisch vor? Verändert sich das Surfverhalten zum besseren?

    Experementell würde ich auch alles was Leistung ziehen könnte vorrübergehend, deaktivieren: Einstellungen-Allgemein- "Tab Vorschauen in der Windows Taskleiste anzeigen" deaktiviert, Rechtschreibung während der Eingabe überprüfen deaktivieren, Updates nur noch aufforderung installieren. "Datenschutz & Sicherheit" "Standard". Vielleicht ist hier irgendwo etwas dabei, was übereifrig ist?!


    Hast du vielleicht nebenbei einen Virenscanner oder ähnliches der anspringt und beginnt zu Scannen, wenn Firefox maximiert wird (evtl. testweise deaktivieren)?



    All dies wie gesagt nur dann, wenn das Firefox Fenster auf dem 4K Monitor maximiert ist.


    Bei anderen kleineren Monitoren ist es besser?? Vielleicht ist Firefox für 4K noch nicht ausgelegt?
    Gutes Stichwort, vielleicht ist es sinnvoll in dieser Richtung zu recherchieren. Eine kurze google Suche brachte hier wohl Probleme mit 4K Videos (https://support.mozilla.org/de/kb/4k-youtu…refox-abspielen). Aber ob das auch deine Probleme betrifft kann ich nicht sagen.

  • Das verwundert mich eigentlich am meisten. Meine Idee war, das RAM oder CPU sehr ausgelastet sind. Aber deine Werte sehen eigentlich ganz gut aus. Und ob das Fenster maximiert ist oder nicht, sollte keinen Unterschied auf RAM oder CPU ausmachen.
    Ist das Verhalten bei anderen Anwendungen genauso? Verhält sich Chrome ähnlich?


    Das ist es auch, was mich total irritiert. Ich habe diese Probleme ausschließlich mit Firefox. Und auch erst seit kurzem (ca 3-4 Monate). 4K Monitor habe ich seit fast 2 Jahren - war nie ein Problem.
    Windows auch neu installiert usw - ist immer sofort reproduzierbar.

    Zitat

    Vielleicht ist es irgendwo noch Einstellungssache? Einstellungen-Allgemein-Leistungen:
    "Empfohlene Leistungseinstellungen verwenden" Aktivieren/Deaktivieren mit diesen Einstellungen mal etwas experementieren. Spricht dich hier eine Einstellung an? Kommt dir dort etwas komisch vor? Verändert sich das Surfverhalten zum besseren?


    Nein, da tut sich leider nichts was ich nachhaltig reproduzieren könnte. Das Einzige was hilft ist ein Browser-Neustart, dann läuft es so lange gut, bis ich etwas mehr als 4-6 Tabs verwendet habe - dann fängt es wieder an.

    Zitat

    Experementell würde ich auch alles was Leistung ziehen könnte vorrübergehend, deaktivieren: Einstellungen-Allgemein- "Tab Vorschauen in der Windows Taskleiste anzeigen" deaktiviert, Rechtschreibung während der Eingabe überprüfen deaktivieren, Updates nur noch aufforderung installieren. "Datenschutz & Sicherheit" "Standard". Vielleicht ist hier irgendwo etwas dabei, was übereifrig ist?!


    Tab Vorschau habe ich generell abgeschaltet, Rechtschreibprüfung ebenfalls - das sollte aber ja ohnehin keine auswirkung haben wenn ich zwischcen zwei Tabs mit z.B. Amazon hin und her wechsle. Datenschutz steht ebenfalls auf Standard.

    Zitat

    Hast du vielleicht nebenbei einen Virenscanner oder ähnliches der anspringt und beginnt zu Scannen, wenn Firefox maximiert wird (evtl. testweise deaktivieren)?


    Alles längst durch... :(

  • Ist das Verhalten auch so, wenn du das Fenster verkleinerst, aber dann auf nahezu die volle Größe ziehst (nicht auf "Fenster maximieren" klickst)?
    (so bist du wahrscheinlich schon jetzt unterwegs, oder?)


  • Ist das Verhalten auch so, wenn du das Fenster verkleinerst, aber dann auf nahezu die volle Größe ziehst (nicht auf "Fenster maximieren" klickst)?
    (so bist du wahrscheinlich schon jetzt unterwegs, oder?)

    Das Verhalten tritt ab ca. 80% der Monitorfläche auf. Alles darunter, z.B. auch rechts oder links angedockt (50% Breite, 100% Höhe) funktionieren ohne Probleme

  • :arrow: Führe einen Test mit Firefox portable durch:

    • Portable Firefox (32 bit oder 64 bit) hier downloaden.
    • zip-Datei in beliebigen Ordner entpacken, am besten auf einen externen Datenträger. Falls dieser nicht verfügbar und nur die C-Partition vorhanden ist: Den portablen Firefox (Ordner) aber NIEMALS nach C:\Programme oder C:\Program Files (x86) kopieren/entpacken. Daraus ergeben sich Rechte-Probleme. Dann am besten auf den Desktop entpacken.
    • Keine Erweiterungen hinzufügen!
    • Portable Fx ausschließlich mittels FirefoxStarter.exe starten.
    • Gegebenenfalls ein Firefox-Update auf die aktuelle Programmversion durchführen
    • Teste ...

    1. Portable Fx läuft einwandfrei: Fehler im lokalen Fx (Profil, Erweiterungen etc.).
    2. Portable Fx hat Probleme: Fehler im System (AV-Software, Filter, Malware etc.).
  • Gleiches Problem mit FF Portable.
    System Prozess (PID4) im Taskmanager mit hoher Auslastung.
    Fenster kleiner: alles OK.

    Hab Windows vorhin testweise auf eine andere Festplatte neu installiert - ist auch bei frischem System sofort wieder.
    Kein Virenscanner, nacktes Win10.

    Jegliche Hardware-Tests mit Prime95, Furmark, HDD Tests usw. sind OK, ALLES läuft problemlos (Videoschnitt, Office Anwendungen, Spiele)

    Kann jemand von Euch das ggfs. mit einer Konstellation mit 4 Monitoren nachstellen?

  • Habe nun auch mit weniger Monitoren getestet - gleiches Problem solange der 4K Monitor verwendet wird. :(

    Ich kann nun auch ausschließen, dass es sich um ein Problem meines PCs handelt. Wenn ich mittels Remote-Desktopverbindung mich auf einen anderen PC einwähle und hier ebenfalls einen Monitor mit UHD Auflösung verwende passiert genau das gleiche: Massive Hänger mit Prozess "System" (PID4) mit hoher CPU-Auslastung.

    Fazit: Es scheint einen ziemlich massiven Bug in Firefox zu geben. Da dies nun schon seit Monaten so geht muss ich mich wohl schweren Herzens nach über einem Jahrzehnt vom Feuerfuchs verabschieden :(