HTML5 Gamees relativ langsam in Firefox

  • Hallo zusammen,


    Obwohl Firefox zumindest gefühlt, auf normalen Webseiten schneller ist als Chrome, scheinen Seiten mit HTML5 Spielen nur sehr zäh in Firefox zu laufen. Es gibt spürbare Verzögerungen bei nahezu jedem Click, auch wenn die Daten bereits im Cache sind. In Chrome hingegen wird nahezu sofort reagiert. Alles wirkt bedeutend flüssiger. Das Problem habe ich ausschließlich bei Spielen. bei normalen Seiten merke ich keinen Unterschied bzw. ist Firefox sogar schneller als Chrome. Habe es auch schon mit einem neuen Profil versucht, ohne Addons usw. aber das bringt keine Änderung. Habt ihr irgendwelche Ideen?

  • Der Grafiktreiber ist auf dem neuesten stabilen Stand. Es macht keinen Unterschied, ob ich die Hardwarebeschleunigung aktiviere oder deaktiviere. Den abgesicherten Modus habe ich auch getestet. Bisher alles ohne Erfolg.

  • Beispiele in Form von Links wären mal was feines. Ansonsten kann man es ja nicht selber mal verifizieren.

  • Nunja speziell kann ich das bei Games wie Elvenar und Forge of Empires beobachten. Die Entwickler dort sind keine Hilfe. Deren Ratschlag ist halt Chrome zu verwenden. Das ist aber keine Alternative für mich. Ist ja auch kein Megaunterschied aber leider dennoch spürbar. Ich hatte hier auf den ein oder anderen Tipp gehofft eventuell Settings zu finden abseits der normalen Firefox GUI.

  • Wenn du dir ein spezielles Profil OHNE jedwe Erweiterung und Firefox in der Auslieferungsvariante dafür zulegst.... klappt es dann?
    Dies wäre das 1. Mal, das hier darüber geklagt würde, soweit ich das erinnere...

  • Nein leider macht das keinen Unterschied. Auch ein neues, leeres Profil ohne AddOns und dem PrivateMode, bringt keine Verbesserung im Vergleich zum normalen Profil. Es ist ja nicht gerade so das es unbenutzbar wäre aber Firefox reagiert halt langsamer auf die Klicks im Spiel. In Chrome ist die Reaktion nahezu instant da.


    Ich kann ja mal versuchen Zeiten in der Dev Konsole in beiden Browsern zu vergleichen. Evtl sehe ich dann ja greifbare Zahlen

  • Hab grad mal geschaut und verglichen. Die gleiche Aktion benötigt für die Übertragung in Firefox 252ms, in Chrome sogar 300ms. Übertragen wird die gleichen Datenmenge. Bei anderen Objekten ist das Verhältnis ähnlich. Sprich Firefox ist sogar schneller. Aber es dauert länger vom Klick bis der Browser anfängt den Request zu senden. Obige Zahlen sind nur mal ein Beispiel. Die paar Millisekunden Unterschied machen das Kraut nicht wirklich fett im normalen Gebrauch. Die Verzögerung zwischen Klick und Request spürt man aber leider. Ich wüsste auch nicht, wie ich das auf die Schnelle mit messbaren Daten belegen und messen könnte. Eine Stoppuhr ist dafür zu ungenau, ich kann leider nur ab dem Request messbare Daten liefern.

  • .. ich würde dann vermuten, das dein System einfach "zu schwach auf der Brust" ist...
    Eine Sicherheitssoftware oder eine andere, im Hintergrund laufende und Arbeitsspeicher fressende, Software sollte dir ja wohl nicht in die Suppe spucken?

  • Naja... daran kann ich nicht glauben. Wenn es in beiden Browser in etwa gleich wäre, könnte ich da zustimmen. Aber ich habe das mittlerweile sowohl auf einem sogenannten HighEnd Office Laptop nachvollziehen können, als auch auf einem Gaming Laptop. Bei beiden würde ich nun nicht sagen das diese schwach auf der Brust sind. Meist sind noch 20 bis 25GB freier Arbeitsspeicher vorhanden, wenn ich obiges getestet habe. Das sollte ja eigentlich reichen. AV Software war das erste was ich deaktiviert hatte. Immerhin konnte ich das nun auf den Delay zwischen Click und Request eingrenzen. Der Rest scheint ja zu funktionieren.

  • Im Router? Ich wüsste nicht was der Router mit einer Verzögerung vom Klick zum Senden des Requests zu tun hat und ein doch, würde das vermutlich auch Chrome betreffen. Außerdem tritt das sowohl im Büro auf, als auch zu Hause.