Settings des Configfiles werden nicht angenommen - seit Firefox 62

  • Hallo zusammen,


    seit der Version 62 werden zwei Settings des Config-Files nicht mehr angenommen.


    Diese sind:


    Cookies deaktivieren:
    defaultPref("network.cookie.cookieBehavior", 2);
    lockPref("network.cookie.cookieBehavior", 2);


    Eingegebene Suchbegriffe und Formulardaten speichern deaktivieren
    lockPref("browser.formfill.enable", false);


    Andere Settings (Proxy, Passwörter nicht speichern, etc) werden noch gezogen.


    Ich hoffe ihr könnt mir weiterhelfen.


    Vielen Dank und Grüße


    Chris

  • Hallo aborix,


    ein neues Profil hilft leider nicht weiter. Hatte den Rechner auch komplett von Firefox "befreit".
    Settings aus der mozilla.cfg werden ja übernommen, nur die zu den Cookies und die Suchbegriffe nicht...

  • Also gerade Cookies und das Speichern von Suchausdrücken und Formulardaten lassen sich nicht deaktivieren. Da kommt bei mir der Gedanke an Malware, insbes. Adware auf. Welches Programm in diesem Fall zum Untersuchen des Rechners gut geeignet ist, können andere besser beurteilen als ich. Welches Betriebssystem hast du?

  • Für Windows, lade dir den Adwcleaner von hier herunter: https://toolslib.net/downloads/viewdownload/1-adwcleaner/
    Lass ihn laufen und bevor du etwas löschest, kopiere sein Protokoll folgendermassen ins Forum:


    - Vergrössere den Editor "Schnellantwort" über den Button zu "Vollständiger Editor & Vorschau"
    - Wähle dort oben den Button "</>" und kopiere das Protokoll in den Editor.

    Firefox 68.0.2 (64-Bit)
    1x Standard, 1x Portabel. (Beide mit Tabs unten, danke Aris!)
    Windows 10/64 Pro 1903 18362.267
    Malwarebytes Premium, Adwcleaner, Windows Firewall
    BACKUP machen, jetzt!

  • Werden die beiden Einstellungen mit anderen Werten übernommen?
    Also:
    lockPref("network.cookie.cookieBehavior", 0);
    lockPref("network.cookie.cookieBehavior", 1);
    lockPref("browser.formfill.enable", true);


    Noch ein Vorschlag für einen Test:


    Installiere Firefox nochmal neu von dieser Seite:
    https://www.mozilla.org/firefox/all/


    Wir testen jetzt eine Einstellung allein mit dieser mozilla.cfg:

    Code
    1. //
    2. lockPref("network.cookie.cookieBehavior", 2);


    Erstelle ein neues Profil und verändere daran nichts. Starte Firefox mit dem neuen Profil und öffne mit Strg+Umschalt+J die Browserkonsole. Was steht dort und wird die Einstellung übernommen?

  • Die Einstellung
    Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;
    war das Problem. Habe diese Auskommentiert und nun wird der Rest komplett gezogen.
    Danke für eure Zeit und Hilfe


  • Die Einstellung
    Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;


    Kannst Du bitte deutlicher werden, wo diese Einstellung existiert? Das sieht für mich nicht nach einem Configfile aus.

  • Doch, diese war im Configfile und hat bis zur Version 62 auch keine Probleme gemacht gehabt.


    // Deaktiviert den 'crash reporter'
    lockPref("toolkit.crashreporter.enabled", false);
    Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;