Erweiterung gegen manuelles Update sperren?

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Ich habe in meinem Firefox (v23.0.1) eine Erweiterung, die mit der letzten Version verschlimmbessert wurde und nun offenbar nicht mehr weiterentwickelt wird (Autofill Forms).


    Ich habe im AddOn-Manager schon eingestellt, daß kein eigenständiges Updaten der Erweiterungen erfolgt. Wenn ich nach Updates suchen will, gehe ich dort immer manuell über "Auf Updates überprüfen".
    Nun wird mir aber immer Autofill Forms als Update angezeigt und ich muß darauf achten, es manuell auszuklammern, um das Update nicht versehentlich zu installieren.


    Dinge, die ich schon getan habe, die aber nicht zum erwünschten Erfolg geführt haben:


    • Im AddOn-Manager bei diesem AddOn mit Rechtsklick auf "Weitere Informationen anzeigen" gegangen und dort "Automatische Updates auf "Aus" gestellt
    • In about:config einen neuen Eintrag erstellt (bool) mit dem Namen "extensions.autofillForms@blueimp.net.update.enabled" und dem Wert "false" (so wie es in der MozillaZine Knowledge Base beschrieben steht)


    Diese beiden Dinge haben nichts gebracht. Sobald ich manuell auf Updates überprüfe, wird das besagte Update angezeigt.
    Ich habe es auch schon mit einem Schreibschutz auf Windows-Ebene auf die Erweiterungsdatei versucht, in der Hoffnung, daß sie dann nicht vom Update überschrieben wird. Wird aber trotzdem überschrieben.


    Hat noch irgendwer eine Idee?

  • Hallo caveman
    Verwendest Du da zufällig die Version 0.9.9.0?


    Wenn ja, teste mal diese hier von mir, die läuft hier einwandfrei.
    siehe hier Nr=1 http://www.camp-firefox.de/forum/viewtopic.php?f=4&t=91768


    Ich hab da neben der zum Teil fehlenden Übersetzung auch ein Problem mit der Fenstergröße
    bei den Einstellungen behoben.
    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0.1
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • loshombre: guter Tipp, den kannte ich noch gar nicht, allerdings hat diese Erweiterung gar keine updateURL; die geht dann wohl automatisch auf AMO-Updates los.


    Endor: w00t :D Ist ja Wahnsinn. Tatsächlich habe ich bisher die Version 0.9.8.4 verwendet, das war die einzige, die bei mir noch nicht den Fenstergrößen-Bug zeigte (Übersetzung ist mir nicht so wichtig, weil ich den Firefox mit englischer Oberfläche nutze). Ich habe mir gerade mal Deine 0.9.9.0 geladen, da sieht alles prima aus. Danke schön! :klasse:[Blockierte Grafik: http://img372.imageshack.us/img372/9199/thumbsup2ei.gif] [Blockierte Grafik: http://img527.imageshack.us/img527/6488/thumbsupxa3.gif]
    Nebenbei: kannst Du Dich erinnern, wo das Problem lag? Es kam mir seit Monaten so vor, als ob diese Fenster-Verwurstung nur bei mir auftrat, ansonsten wären die Kommentare bei AMO doch noch deutlich vernichtender (die Erweiterung war so bei mir komplett unbedienbar).

  • Hallo caveman
    Freut mich das es passt. Da ist ein Fehler in einer css Datei gewesen.
    Da hat der Autor etwas versucht, was leider daneben gegangen ist und er hat das
    auch nach Information nicht behoben. Da mich das tierisch geärgert hat habe ich das
    eben selber versucht zu reparieren. Wie Du schon geschrieben hast, man konnte sie
    mit dem Fehler gar nicht mehr verwenden.


    Die Datei heißt übrigens: autofillFormsOptions.css
    die ist im Ordner skin in der Erweiterung. Ich weiß nur im Moment nicht mehr was ich da geändert habe.



    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0.1
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Gern geschehen. :wink:
    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0.1
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!