Beiträge von cubefox

    Oft werden auf Websites schon besuchte Links anders dargestellt als noch nicht besuchte. Die Information dazu wird aus der Chronik genommen. Wenn man einen besuchten Link als nicht-besucht darstellen will (z.B. als Markierung dass man etwas noch nicht gelesen hat obwohl man die Seite schon aus irgendeinem Grund aufgerufen hat), muss man die Adresse also aus der Chronik löschen. Dazu muss man die Link-Adresse kopieren, die "Bibliothek" aufrufen, die Adresse suchen und dann löschen.


    Kennt ihr eine Erweiterung die den Weg abkürzt? Am liebsten hätte ich einen Eintrag zum Löschen im Kontextmenü, wenn ich auf einen besuchten Link rechtsklicke.

    Die Erweiterungen sind schon aktuell. :) Die Angaben in der Signatur beziehen sich nur momentan auf einen alten Rechner.


    Zur Hardwarebeschleunigung: Ich habe eine integrierte Intel HD Graphics 4000, die in den neuen Ivy-Bridge-CPUs (dritte Generation) von Intel integriert ist. Der Test von hacks.mozilla.org ergibt mit Beschleunigung 60+ FPS, also scheint es mit der Unterstützung keine Probleme zu geben. Auch ein Treiberupate brachte keine Unterschiede. Hat hier evtl. noch jemand diese GPU?

    Strg+T hat die gleiche Verzögerung. Aber die Hardware-Beschleunigung war es tatsächlich! Wenn man sie ausschaltet öffnen sich die Tabs wieder sehr schnell. Wenn man sie wieder einschaltet und dann den Browser neu startet, öffnen sie sich wieder verzögert. Das riecht doch nach einem Bug... Habt ihr das Problem auch?

    Hallo mal wieder. :)


    Problem: In meinem Firefox 13.01 (Win 7) öffnen sich neue Tabs nur mit einer leichten Verzögerung, geschätzt ca. 0,5 oder 0,25 Sekunden. Klingt vernachlässigbar, aber es nervt leider. Die Verzögerung tritt nur beim Neuer-Tab-Button in der Tableiste auf, nicht aber wenn man neue Tabs über Hyperlinks (Mittelklick) öffnet.


    Im Safe Mode tritt das Problem nicht auf, bzw. die Verzögerung ist hier deutlich geringer. Also muss wohl eine Erweiterung schuld sein, dachte ich. Doch nachdem ich alle Erweiterungen (derzeit: Adblock Plus, Firebug, Flashblock, Image Zoom, NoSquint, Restartless Restart, Stylish, Tab Mix Plus) und außerdem alle Plugins deaktiviert und Fx neugestartet hatte, war die Verzögerung immer noch da.


    Woran kann das liegen? Irgendeine Browsereinstellung? Wäre cool wenn jemand einen Tipp hätte, bevor ich es mit einem neuen Fx-Profil versuche.


    Die Thumbnails in den neuen Tabs habe ich übrigens standardmäßig ausgeblendet, sie sind über den Button oben rechts im neuen Tab wieder aktivierbar. Wenn ich mit TMP diese Standard-Seite für neue Tabs (about:newtab) durch about:blank ersetze, fällt die Verzögerung beim Öffnen der Tabs zwar etwas geringer aus, aber immer noch nicht so gering wie im Safe Mode (wo ja about:newtab auch verwendet wird).

    das mit der registry habe ich nicht getestet, einen workarround (mit mozex) kannte ich ja schon. mir gings eher ums prinzip, denn den meisten usern sind solche verrenkungen nicht zuzumuten. in opera etwa ist das ganze schon lange möglich. ich bin selber eigentlich erst auf das problem aufmerksam geworden als mich ein freund um rat fragte (es ging um das irc(?)-protokoll xdcc).


    das registrieren des protokolls im betriebssystem scheint nicht gerade die regel zu sein. ich habe hier mehrere mehrere medienplayer und downloadmanager, die mit rtsp umgehen können, aber offensichtlich hat sich keines der programme in windows dafür registriert. da es keine offizielle möglichkeit gibt ein programm in windows (zumindest vista) manuell mit einem programm zu verknüpfen, ist es umso wichtiger dass das im browser funktioniert. eingeschränkt geht es ja schon: für programme die bereits in der liste unter "anwendungen" verzeichnet sind.

    natürlich, lange sucherei gehört dazu. ;) mach ich deswegen wahrscheinlich erst am wochenende. hab auch noch zwei andere bugs die offensichtlich noch nicht vorhanden sind (page-info / medien / speichern ignoriert anscheinend content-type und content-disposition).
    wenn ich mehr weiß schreib ichs hier rein.

    richtig geraten. die datei ist aber ein ziemliches durcheinander, das man erstmal durchschaut haben muss um an den vermutlich vielen stellen das richtige zu ändern - um ein neues protokoll zu erstellen. ich habs nicht durchschaut.
    werde in nächster zeit mal einen bug aufmachen und das hinzufügen von protokollen über die UI (button in den einstellungen oder zumindest das durch das ersetzen) fordern. ohne mir natürlich viele aussichten auf erfolg zu erhoffen.

    das funktioniert nicht - es bewirkt nichts. anscheinend (laut mozillazine kb) funktioniert die einstellung "network.protocol-handler.app" nur in linux/mac, nicht aber in windows. in windows werden die protokoll- und dateityp-verknüpfungen anscheinend überhaupt nicht in der config gespeichert, denn eine suche nach strings die in entsprechenden programmpfaden entahlten sind (und daher gefunden werden müssten), lieferte kein ergebnis. irgendwo müssen sie aber gespeichert sein: wenn man in firefox ein anderes programm verknüpft, als der OS-standard ist, muss der pfad dazu ja irgendwo abgelegt werden.

    *threadaufwärm*


    Zitat von boardraider

    Mit CSS kannst du es nicht vertikal zentrieren und GM greift nicht bei Bildern. Mir ist da abgesehen von einer Erweiterung nichts bekannt.


    es geht anscheinend doch:


    Code
    1. html > body > img:only-child {
    2. position: absolute;
    3. top: 0;
    4. left: 0;
    5. right: 0;
    6. bottom: 0;
    7. margin: auto;
    8. padding: 3px;
    9. }


    in die usercontent.css / stylish. die erweiterung image tweak macht zwar das selbe (wenn man sie mal so konfiguriert hat...), aber leider ist sie bei mir fehlerhaft. auf manchen seiten fällt damit nämlich autoscroll aus.
    quelle: k. austers via bugzilla

    Unter Extras / Einstellungen / Anwendungen kann man nicht nur die Aktion beim öffnen verschiedener Dateitypen einstellen, sondern auch bei verschiedenen Protokollen. Zum Beispiel mailto (für E-Mail). Aber auch andere Prokolle werden in der Liste aufgeführt, wenn...

      1. das Protokoll im Betriebssystem mit einem Programm verknüpft ist (zumindest in Win ist das so),
      2. das ein Link mit diesem Protokoll mindestens einmal mit Firefox geöffnet wurde.


    Bei mir befindet sich beispielsweise aus diesen Gründen auch mms: in der Liste.


    Jetzt die Frage: Wie kann man neue Protokolle in die Liste unter Einstellungen / Anwendungen hinzufügen?


    Denn wenn Punkt 1 nicht erfüllt ist (Protokoll nicht im OS verknüpft; das kann man in Win Vista afaik nicht ändern), kann man auch nicht Punkt 2 ausführen, da Firefox (aus mirunbekannten Gründen) in diesem Fall statt einem Dialog-Fenster lieber die lapidare und nutzlose Meldung auswirft, dass mit dem Protokoll kein Programm verknüpft ist - ändern wie bei ersterem Dialog (bzw. unter Einstellungen / Anwendungen, wo es ja auch nicht steht) kann man es aber nicht.

    ein kleiner bug:



    das ist der auswahldialog der erscheint wenn man links mit externen protokollen (etwa rtsp:, ed2k:, mms: oder irc:) anklickt. erscheint nur, wenn mindestens ein programm im betriebssystem für dieses protokoll verknüpft wurde - in diesem fall windows media player. wenn das nicht der fall ist, erscheint nur die meldung
    "Firefox weiß nicht, wie diese Adresse geöffnet werden soll, da das Protokoll (protokollname) mit keinem Programm verknüpft ist."
    warum das so ist, weiß ich auch nicht. der dialog erscheint ebenfalls nicht, wenn man den haken bei "auswahl für xyz-links speichern" gesetzt hatte.
    hier kannst du testen ob das fenster erscheint:
    irc://bla.bla
    mms://bla.bla
    ed2k://jkae.de


    worauf ich hinaus will: in silvermel fehlen, wie oben zu sehen, die markierungen für selektierte einträge.


    ps: weiß jemand hierauf eine antwort?