OS X Firefox speichert Dateien anstatt sie nur zu öffnen

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hallo,


    oft kommt es vor, dass ich Dateien nicht auf meiner Festplatte speichern, sondern nur ansehen möchte. Entsprechend klicke ich dannaa im Download-Fenster von Firefox immer auf "Öffnen mit" anstatt "Datei speichern". Unter Windows hatte Firefox die Datei dann immer geöffnet, ohne sie in meinem Standard-Download-Ordner zu speichern. Er hat sie wohl im Temp-Ordner o.ä. gespeichert, aber dann eben auch wieder automatisch gelöscht, sodass ich mich nicht mehr darum kümmern musste. Sehr praktisch also, wenn man von vornherein weiß, dass man die Datei nicht dauerhaft auf seiner Festplatte haben möchte.


    Mittlerweile benutze ich Firefox 3.6.9 unter Mac OS X und da sieht es anders aus: Auch wenn ich lediglich auf "Öffnen mit" klicke (und nicht auf "Datei speichern"), speichert Firefox die Datei im von mir als Standard gesetzten Download-Ordner, in meinem Fall der Desktop. Das ist insofern störend, als dass ich nach Ansicht mehrerer Dateien diese im Download-Ordner (sprich auf dem Desktop) habe und dann manuell löschen muss. Weiß jemand, wie ich Firefox zu dem mir unter Windows bekannten Verhalten bringen kann?


    Bin für jeden Hinweis dankbar!


    A.

    Einmal editiert, zuletzt von Ansellmus ()

  • Willkommen im Forum!
    Mache zunächst ein UpDate auf Firefox 3.6.10 und teste erneut. Teste ggf. danach im abgesicherten Modus.
    Liste mal deine Erweiterungen per
    Hilfe :arrow: Informationen zur Fehlerbehebung :arrow: Erweiterungen mit Versionsangabe und mit der Klammer Code auf.
    Kontrolliere selber, ob eine der hier aufgeführten dabei ist.

  • Hallo Boersenfeger,


    vielen Dank für deine Hinweise. Habe versucht sie zu befolgen mit folgendem Ergebnis: Auch im abgesicherten Modus lädt Firefox Dateien nach Wahl der Option "Öffnen" in den Downloadordner. Meine Addons habe ich mit denen in der von dir verlinkten Liste abgeglichen, aber keines der dort erwähnten habe ich installiert (s. Liste meiner Erweiterungen unten). Was meinst du "mit der Klammer Code"? Muss ich dazu HijackThis installieren und laufen lassen?

    Einmal editiert, zuletzt von Ansellmus ()

  • Moin,
    ergänze deinen Eingangstitel um "OS X", damit sich MacUser angesprochen fühlen.
    Die könnten dir dann ev. besser helfen.

  • Zitat von Boersenfeger

    Mache zunächst ein UpDate auf Firefox 3.6.10 und teste erneut.

    Auch gemacht? Die Klammer Code kannst du setzen, indem du deinen Beitrag editierst, die Auflistung der Erweiterungen markierst und dann auf Code klickst, das du am oberen Rand des Texteingabefeldes sehen kannst.

  • Sorry für die späte Antwort!


    Das Update hatte ich gleich gemacht, hat aber auch nichts geholfen.


    Ich habe meinen Beitrag (den dritten hier) wie von euch beschrieben mit "Code" bearbeitet. Was kann ich nun tun? Es ist wirklich sehr störend, das jede Datei, die ich online öffne, sofort heruntergeladen wird...

  • Das ist so und daran kannst Du auch nix ändern (allein bei PDF-Dateien kannst Du mit einer Erweiterung - pdf download - temporäres Speichern bewirken, weil nach Beenden automatisch gelöscht wird, hat aber teilweise andere Nachteile). Du kannst aber in den Einstellung (cmd + ,) definieren, wo gespeichert werden soll.


    Im Übrigen: Unter Windows ist es auch nicht anders - da landet zwar der "normale" Download im Temp-Verzeichnis, wird aber auch nicht automatisch gelöscht, sondern bleibt dort bis zum (manuellen) Löschen. Fällt den meisten nur nicht auf …


    Insofern ist das "kein bug, sondern ein feature" des FX ;)

    FX 3.6.28/Mac OS X (10.4.11)
    FX 24.0/Mac OS X (10.6.8 )
    FX 24.0/Mac OS X (10.8.3)

  • Hallo,
    ich grabe mal den alten Thread hier aus.
    Kann man denn den Downloadordner ändern, in die die Dokumente gelangen, wenn man sie eigentlich nur öffnen will?
    Dann könnte ich im Doenload-Ordner einen TEMP-Ordner erstellen und den dann ohne groß zu überlegen in regelmäßigen Abständen löschen


    Vielen Dank und einen guten Rutsch (:


    PS: Das mit cmd +, habe ich gelesen, aber habe dort nichts gefunden, dass beim KLick auf "Öffnen mit Vorschau" man die Datei in einen seperaten Ordner schieben kann...ich hoffe ich habe nichts übersehen (;

  • Moin!
    Falls Du 'Dich auf mein Post beziehen solltest: cmd + "," ;)
    Oder im Menü Firefox>Einstellungen, dann unter "Allgemein" kannst Du den Speicherordner festlegen

    FX 3.6.28/Mac OS X (10.4.11)
    FX 24.0/Mac OS X (10.6.8 )
    FX 24.0/Mac OS X (10.8.3)

  • Hey, ja das ist mir bekannt, aber da kannst du nur den Ordner auswählen, in den alles gespeichert wird.
    Momentan fragt er mich jedes mal vor dem Download nach dem Speicherort - So will ich das
    Aber wenn ich eine Datei nicht speichern sondern nur öffnen will, dann speichert er die im Download-Ordner
    Da war die Frage, ob man das verstellen kann - wie gesagt das soll nur für die Dateien gelten, die man nur öffnet