Entwicklung Fx 3.6 Namoroka (branch)

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Da steht nur, dass es bis zur nächsten beta abgeschaltet wird, nur nicht wie und warum.
    Sollte die aktuelle offizielle Beta das nicht mehr bieten, wäre das ein guter KO-Schlag für Firefox,
    dann muss ich bei der pre-beta bleiben.


    Um auf deine Antwort hier einzugehen
    http://www.camp-firefox.de/forum/viewtopic.php?f=7&t=76104


    Ich empfinde es als angenehm, wenn ich schon beim Taskwechsel den richtigen Tab anwählen kann.
    Parallel dazu nutze ich neben Tabs noch Tab-Preview (permanent, linker Rand).
    Funktioniert für phpBB-Foren zB nur nicht richtig auf der Startseite, zB dieses Forum, da klebt
    dann die Eieruhr statt Inhalt.

  • Zitat von Brummelchen

    wäre das ein guter KO-Schlag für Firefox,

    Kann hier absolut nicht nachvollzogen werden.


    Einem beschränkten Anwenderkreis werden von einem Programm nicht alle Möglichkeiten eines neu geschaffenen UI geboten. Sollte bei den auf diesem Planeten im Umlauf befindlichen Programmen keine Novität darstellen.


    Wenn nun die Absicht eines Unterfangen den beschränkten Anwenderkreis mit dem neuen UI zu beglücken, von der Qualitätskontrolle gestoppt wird, sollte man es, so man kein Abenteurer ist, einfach nur positiv begrüßen.

  • Zitat von Leviticus

    Soll Aero Peek wirklich wieder entfernt werden?
    https://bugzilla.mozilla.org/show_bug.cgi?id=525475


    Ich verstehe das nicht so ganz, war funktioniert denn da nicht?


    Folgende Bugs sind noch offen: https://bugzilla.mozilla.org/s…id=474056&hide_resolved=1 und bis zum angepeilten Release nicht mehr behebbar. Unter der Voraussetzung, dass das Release von Firefox *keinesfalls* noch mehr nach hinten verschoben werden soll **und** der Anzahl der noch offenen "Blocker" (~100+) durchaus nachvollziehbar.
    Ist ja nicht schlimm und die Welt geht davon nicht unter (es ist eine neue Funktion und keine Regression) und wer jetzt mit "schlechte PR bla sülz" ankommen möchte, hat den Schuss nicht mehr gehört :P

  • Aero Peek ist das für mich einzige Argument, auf 3.6 zu schalten,
    alles andere ist mir wurscht, das benötige ich bei einem Browser nicht!

  • Zitat von Brummelchen

    Aero Peek ist das für mich einzige Argument,

    Ich kenne Aero Peak nicht und kann darum auch nicht zwischen Notwendigkeit und Firlefanz unterscheiden.

    Zitat von Brummelchen

    auf 3.6 zu schalten,

    Du wirst Fx 3.6 als ganz normalen Update erhalten. D.h. ein vorhandener Fx 3.5.(x) wird nicht auf einen Fx 3.5.(x+1) 'upgedated' sondern auf einen Fx 3.6.(0).

  • Unter Linux müsste es auch sowas wie Aero Peek geben, wurde hier im Forum
    schon mal als Bild verlinkt: AP-> http://www.abload.de/image.php?img=bild016v6en.png
    Du hast unter Win7 die Möglichkeit, per Taskleiste direkt den richtigen Tab anzuwählen,
    ohne dabei erst Firefox, dann den Tab anzuklicken. Beim 3.5er bekommt man
    nur den aktuellen Tab als Vorschau.
    Ob und wie ich 3.6 bekomme, kannst du mir überlassen ;), hier liegt ein
    2-21, 3-15 (inzwischen entsorgt), 3.5.4 und 3.6beta rum mit getrennten Profilen.
    Ich arbeite zu 99.9% mit 3.5.x, der 3.0er war Kontrolle und der 2.x hat nur einen
    einzigen Zweck für Webseiten. Der 3.6er wächst so langsam, bin grad damit am
    schreiben, suche passenden Ersatz für Erweiterungen.

  • Hallo,
    habe heute ein Update vom 02.11.09 installiert und bekomme folgenden Fehler, dass sich nach dem Wiederstart des Namorakas nichts tut.


    [Blockierte Grafik: http://s6.directupload.net/images/091103/temp/shy7899q.jpg]


    Die Meldung bleibt bestehen, dass Nomoraka neu gestartet werden soll (obwohl neu gestartet!). Klick darauf ergibt immer wieder das gleiche Bild.


    Die gleichen Schwierigkeiten habe ich auch nach dem Update des Minefield 3.7 (v. 02.11.09).


    Ist da irgendwie der Wurm drin?


    Edit: Habe in meiner Not wieder mal neue Profile erstellt (3.6 u. 3.7) und auch Erfolg gehabt!


    Gruß,
    D. Büssen

    Gruß,
    D. Büssen

    Firefox 102.0.1 + Nightly 104 (WIN 10 - 64 bit)

  • Zitat von .Ulli

    Ich kenne Aero Peak nicht und kann darum auch nicht zwischen Notwendigkeit und Firlefanz unterscheiden.


    Ach komm, was der Bauer nicht kennt ...
    "Linux" ist halt von einer brauchbaren GUI noch weit entfernt. :wink:


    Zitat

    Einem beschränkten Anwenderkreis werden von einem Programm nicht alle Möglichkeiten eines neu geschaffenen UI geboten.


    Ja natürlich, ich "verlange" dass die von mir eingesetzte Software auch alle Features meines Betriebssystem unterstützt!
    Ob andere das für Firlefanz halten, ist mir völlig egal.

    Wenn du denkst, dass du denkst, dann denkst du nur, dass du denkst.

  • Zitat von Leviticus

    Ach komm, was der Bauer nicht kennt ...

    Darum wollte der zitierte Bauer auch seine Bildungslücke schließen und entschloss sich zur höflichen Nachfrage.

    Zitat von Leviticus

    "Linux" ist halt von einer brauchbaren GUI noch weit entfernt. :wink:

    Auch wenn es den Seitenhieb nicht benötigte, es sei dir versichert, was ich unter GUI verstehe wird zufriedenstellend abgedeckt.

    Zitat von Leviticus

    Ja natürlich, ich "verlange" dass die von mir eingesetzte Software auch alle Features meines Betriebssystem unterstützt!

    Hast ja recht, wenn du etwas für dein Wohlbefinden haben möchtest. Andere Hersteller ohne Startvorteil und entsprechenden Ressourcen werden auch noch nachziehen.
    Ganz nebenbei, ein GUI benötigt ein Betriebssystem - ist es aber nicht.

    Zitat von Leviticus

    Ob andere das für Firlefanz halten, ist mir völlig egal.

    Eine Frage ist ja keine Bewertung.
    Aber es sei dir gleich gesagt, hier tippt eine äußerst fauler Mausschubser. Die Maus aus dem Fx auf die Taskleiste zu ziehen um mich dann der Tabs zu erfreuen - das würde mir auch im Traum nicht einfallen.

  • Quelle: Leviticus

    Zitat von Leviticus

    Ach komm, was der Bauer nicht kennt ...
    "Linux" ist halt von einer brauchbaren GUI noch weit entfernt.

    Irgendwie passen die Aussagen zusammen. An welcher Stelle ist denn "Linux" für dich keine brauchbare GUI ( :twisted: )? Und an welcher Stelle erfüllen die Desktop-Umgebungen für Linux wie bspw. Gnome oder KDE nicht deine Kriterien? Die Fragen kannst du auch gerne in einem getrennten Thread beantworten.

  • Zitat von boardraider

    Quelle: Leviticus

    Irgendwie passen die Aussagen zusammen. An welcher Stelle ist denn "Linux" für dich keine brauchbare GUI ( :twisted: )? Und an welcher Stelle erfüllen die Desktop-Umgebungen für Linux wie bspw. Gnome oder KDE nicht deine Kriterien? Die Fragen kannst du auch gerne in einem getrennten Thread beantworten.


    Meine Güte das war doch nur Spaß und ironisch gemeint.
    Dennoch will ich auf Aero Peek und Jumplists nicht mehr verzichten.


    Zitat

    Aber es sei dir gleich gesagt, hier tippt eine äußerst fauler Mausschubser. Die Maus aus dem Fx auf die Taskleiste zu ziehen um mich dann der Tabs zu erfreuen - das würde mir auch im Traum nicht einfallen.


    Nein, kein Mausschubser. Es geht einfach nur darum das ich oft mehrere Fenster mit vielen Tabs offen habe. Mir fehlt in diesem Fall einfach eine "gesamte gesamt Übersicht" über alle geöffneten Tabs. Aero Peek bietet das, ohne das ich ein extra Add-on installieren muss, seht praktisch das ganze.


    Zitat

    Ach komm, was der Bauer nicht kennt ...


    Wenn man sich erstmal daran gewähnt und es kennen gelernt hat, will man es nicht mehr missen. Probiere es einfach mal aus...


    Zitat

    Andere Hersteller ohne Startvorteil und entsprechenden Ressourcen werden auch noch nachziehen.


    Jetzt wollen wir mal nicht so tun, als ob Windows 7 erst seit 14 Tagen zu Verfügung steht und die Firefoxentwickler es erst am 22. Oktober zu ersten mal gesehen haben.

    Wenn du denkst, dass du denkst, dann denkst du nur, dass du denkst.

  • Zitat von Leviticus

    - ich "verlange" dass die von mir eingesetzte Software auch alle Features meines Betriebssystem unterstützt! [...]


    Das ist legitim!
    Aber du weißt sicher auch, was mal auf dem Mozillenfahnen stand?


    Zu dem Zitat - prinzipielle Zustimmung. *Software* kann beim gegenwärtigen Verteilungsstand dieses OS aber auch von einem Drittanbieter kommen. [/priv. Meinung]

  • Vlt. einige ausgewählte Hinweise zu Neuheiten im kommenden Fx 3.6 - Warnung bei nicht aktuellen Plug-In [1] - Full Screen Videos [2] - css- Entwicklerhinweise [3]. Bugfixes (seit Beta 1, darunter auch einige Top-Crasher :wink: ) - [4].


    PS. Eine offizielle Bestätigung der Auslieferung liegt seitens Mozilla momentan noch nicht vor!


    Edit - Bestätigung [5].
    Für die Beta 1- User läuft der Beta 2 auch über AUS.


    [Blockierte Grafik: http://www.IMG-Teufel.de/thumbs/BS2128b9b1f12png.png]


    Auch künftige Updates bis hin zur filialen Version werden über AUS möglich sein [5]. Die Beta 2- Version liegt, wie schon die Beta 1, lokalisiert vor.


    UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2 ID:20091108181924


    [1] http://theunfocused.net/2009/1…-plugins-are-out-of-date/
    [2] http://design-noir.de/log/2009…html5-videos-full-screen/
    [3] https://developer.mozilla.org/En/Firefox_3.6_for_developers
    [4] https://bugzilla.mozilla.org/b…20status1.9.2:beta2-fixed
    [5] https://developer.mozilla.org/…ision-2-update-published/

    2 Mal editiert, zuletzt von pcinfarkt ()

  • Hier (Minefield) [1] wurde schon etwas zu dem neuen (und für Beta- Leute wichtigen Schalter!) extensions.checkCompatibility.version gesagt.


    Für Namoroka sollte der im Betreff genannte Wert ausreichen (offizielle Quelle - [2]). Hier steht dieser Schalter seit den gestrigen Builds bei Trunk + Branch auf *.4* :oops: . Aber das muss jeder Beta- Tester sicherlich selbst entscheiden. :wink: Und setzt natürlich voraus, dass man die Extension in den betroffenen Profilen auch händisch beherrscht!


    [1] http://www.camp-firefox.de/for…opic.php?p=605403#p605403
    [2] http://antennasoft.net/robcee/…eckcompatibility-version/

  • Gibt es im Seitenkontext keine "Eigenschaften" mehr?
    Ich finde nur noch "Grafik-Info" und "Seiteneigenschaften"