Aktionen werden oft doppelt ausgeführt

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Moin Moin,


    ich spreche ein Problem mit FX 0.8 an, welches ich schon länger habe:


    Browser-Aktionen (Linkklick, Browserback, NewTab, bookmark öffnen,...) werden fast immer doppelt ausgeführt, d.h. wenn ich einen Link anklicke öffnen sich 2 Fenster. Wenn ich im Browser auf Zurück klicke, komme ich 2 Seiten zurück usw.


    Über die Suchfunktion habe ich kein ähnliches Problem gefunden. Habe ich einen Leidensgenossen? :|


    Mein System: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

    Gruß,
    Feuerfuchs


    Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

  • 'namd,


    Also ich hab mit keiner der bisher hier verwendeten Fx-Versionen ein derartiges Problem feststellen können. (Aktuelle Version siehe Sigline)


    Kann es sein, dass Du entweder aus Versehen Doppelklicks machst oder (falls Du ne 3-Tasten-Maus hast) die mittlere Taste als Doppelklick definiert hast und die benutzt?


    Oder hast Du irgendwelche Extensions (Erweiterungen) installiert? Die können unter Umständen auch solche Probleme verursachen.


    Was andres fällt mir momentan nicht ein.


    Viele Grüße . . . Martin


    In a world without walls and fences, who needs windows and gates?
    - - -
    Kein Support per PN oder email!

  • Bei mir startet Firefox 0.9 und 0.9.1 doppelt, wenn ich einen Link in Outlook oder Word anklicke. Bei Firefox 0.8 hatte ich das Problem nicht. Hat jemand eine Idee?

  • hatte das Problem auch mal. Ne Neuinstallation (also vorher deinstallation und löschung der Profile) hat das Problem behoben. Ka. woran es lag.

    Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

  • Vielleicht liegt es ja gar nicht am Fuchs?


    Ich hatte ein ähnliches Problem mit verschiedenen Applikationen und habe dann den Tip bekommen, mal eine andere Maus auszuprobieren.
    Und siehe da: bingo.


    Des Rätsels Lösung war, daß der Mikroschalter meiner linken Maustaste defekt war und prellte und daher öfter mal was doppelt ausführte. Hört sich im ersten Moment exotisch an, habe ich aber seitdem öfter gesehen. Probiers mal aus, vielleicht hilft es ja.

  • Zitat von rotbaer

    Bei mir startet Firefox 0.9 und 0.9.1 doppelt, wenn ich einen Link in Outlook oder Word anklicke. Bei Firefox 0.8 hatte ich das Problem nicht. Hat jemand eine Idee?


    Bei mir (WinXP, FF 0.9) hat folgendes geholfen:
    'Systemsteuerung' -> 'Ordneroptionen' -> 'Dateitypen' ->
    Erweiterung: 'Keine', Dateityp:'URL:HTTP (HyperText Transfer-Protokoll)' ->
    'Erweitert' -> 'open': 'bearbeiten' -> Checkbox 'DDE verwenden' deaktivieren.


    Das gleiche für:
    Erweiterung: 'Keine', Dateityp:'URL:HTTP (HyperText Transfer-Protokoll) mit Sicherheitssystem'.


    Viel Erfolg.

  • Danke! Dieser Typ hat tatsächlich genutzt! Zwar lässt sich der DDE-Eintrag bei mir nicht deaktivieren (das Häkchen ist beim nächsten Öffnen wieder gesetzt), allerdings ist das Feld "DDE-Eintrag" leer. Vorher waren da ein paar Daten eingetragen, die wohl fehlerhaft sind und das doppelte Öffnen verursacht haben.

  • Zitat von rotbaer

    Zwar lässt sich der DDE-Eintrag bei mir nicht deaktivieren (das Häkchen ist beim nächsten Öffnen wieder gesetzt), allerdings ist das Feld "DDE-Eintrag" leer.


    Stimmt - ist bei mir genauso. Ich hatte gehofft, dass die DDE-Maske ausgefüllt bleibt und das ganze sich bei Bedarf wieder sehr einfach durch aktivieren der DDE-Checkbox rückgängig machen lässt. Aber dazu scheint es keinen Anlass zu geben: System und Browser laufen seit Tagen damit einwandfrei.
    Da war das Ziel mal wichtiger als der Weg ;-)

  • Super.
    Genau das habe ich gesucht ;)
    Bei mir klappt es nun auch wieder.
    Aber warum das bei der Umstellung von 0.8 auf 0.9.1 passiert ist, kann ich leider nicht sagen.
    Egal.
    So long.
    Greetz
    ScOoZ


    //EDIT
    Habe nun auch rausgefunden, was das mit dem DDE zu bedeuten hat. Wenn eine Instanz vom FireBird schon geöffnet ist, dann wird der Link in diesem Fenster geöffnet. Wenn man DDE deaktiviert (bzw. keine Anweisungen drinnen stehen), dann wird immer ein neues Fenster geöffnet, sobald man einen Link z.B. in Outlook anklickt.
    Vielleicht kann ja jemand diesen Befehl so modifizieren, dass Outlook Links in geöffneten Fenster öffnet, aber nicht, wenn FireBird noch geschlossen ist, 2x FireBird startet.


    //EDIT
    Hat jemand von euch zufällig die original Einträge, die in diesen Feldern standen?

  • Zitat von ScOoZ

    Hat jemand von euch zufällig die original Einträge, die in diesen Feldern standen?


    Erhältst Du, wenn der IE wieder als Standardanwendung definiert wird:


    DDE-Nachricht:
    "%1",,-1,0,,,,


    Anwendung:
    IExplore


    Thema:
    WWW_OpenURL

  • Ganz logisch erscheint mir die Erklärung nicht, denn auf meinem Notebook läuft 0.9.1 wie er soll (ohne dass ich das DDE-Häkchen entferne). Es wäre schon gut, wenn Firefox nicht jedesmal ein Fenster öffnet, wenn ich einen Link in einer Email anklicke. Das ist jetzt der Fall, nach dem "Häkchen-Trick".


  • um zu verhindern, dass der Browser 2 mal startet empfiehlt sich die Tab Browser Extension oder die SingleWindow Extension.


    die TBE gibt hier:
    http://white.sakura.ne.jp/~pir…tensions.html.en#download



    Original dde Nachricht: "%1",,-1,0,,,,

    Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0


  • Danke für Deine Antwort.
    Die TBE habe ich nun mal installiert.
    Allerdings bringt mir die momentan nichts. Immer wenn ich einen Link aus einer Nachricht von Outlook öffne, öffnet sich auch automatisch ein neues Browser Fenster.
    Der Eintrag der DDE-Nachricht klappt leider nicht. Wenn ich den Link anklicke, öffnet sich das Browser Fenster und ein zweites Fenster zum Speichern einer Datei.
    Hier mal meine momentan Einstellungen für die DDE-Nachricht.


    [Blockierte Grafik: http://home.pages.at/scooz/FireFox.jpg]


    Mit den ^^ Einstellungen öffnet sich immer wieder ein neues Fenster.
    Für diese Einstellungen bräuchte ich die "original" Einstellungen.


    ScOoZ

  • Bei mir sieht es fast genauso aus, nur daß bei "Anwendung" noch "IExplore" steht (das ist wohl ein Überbleibsel, Firefox ist aber trotzdem als Standardbrowser eingetragen).


    Außerdem steht bei "Thema" bei mir "WWW_OpenURL"

  • Oki doki.
    Nun scheint es zu klappen.
    Anscheinend war das "WWW_OpenURL" dran schuld. ;)
    Nun öffnet sich der FireFox nur noch einmal, wenn man Links unter Outlook anklickt. So soll es sein ;)


    Danke.
    Greetz
    ScOoZ


    //EDIT
    Toll. Klappt doch noch nicht. Ab und zu öffnet sich nur ein Fenster aber meistens kommen jetzt doch wieder 2. Also weiter suchen :(:(

  • ich habe einfach bei Anwendung den IExplorer durch FIREFOX ersetzt und den rest so gelassen. Jetzt geht alles Wunderbar.

    Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040626 Firefox/0.9.1

  • Tja.
    Leider steht FIREFOX bei mir schon in der Zeile.


    [Blockierte Grafik: http://home.pages.at/scooz/FireFox_2.jpg]


    Und mit diesen Einstellungen ^^ klappt es bei mir leider nicht.
    Hast Du bei dir was anderes noch drin stehen oder sind Deine Einstellungen identisch mit den meinen?


    ScOoZ


    //EDIT
    Anscheinend habe ich es hinbekommen.
    einfach manuell die Zeile DDE-Nachricht löschen.
    Die Zeile mit openURL stehen lassen.
    So wird nur ein Fenster aus Outlook heraus geöffnet.


  • Ja, so hats bei mir auch geklappt!



    STRAT

    Carpe diem, Baby!

  • Sorry. Aber ich muss meine Aussage von vorhin wieder einmal korrigieren.
    Leider klappt es bei mir immer noch nicht.
    Folgendes.
    Mit o.g. Einstellung bekommt man zwar nur ein Fenster, wenn man auf einen Link klickt, aber leider öffnet sich auch immer wieder ein neues FireFox Fenster, auch wenn schon ein anderes offen ist.
    Das ist auch blöde.
    Ich will, dass nur ein Fenster aufgeht (klappt) und dass, wenn FireFox schon offen ist, der Link aus der Emailnachricht auch in dem geöffneten Fenster aktiv wird und nicht in einem 2. neuen Fenster.


    Also weiter suchen.
    ScOoZ