1.5 RC1 keine Erweiterungen mehr installierbar ???

  • Hi. Ich hab vor kurzem von 1.07 auf 1.5 RC1 upgedatet (dt. Version). Ich hab mir ein kleines Erweiterungen-Archiv zugelegt und bislang Erweiterungen nicht online, sondern via USB Stick über Datei > Datei öffnen installiert. Dazu habe ich in der Version 1.07 die Option "Websites das Installieren von Software erlauben" den Haken gesetzt. Dadurch ließen sich Erweiterungen unproblematisch installieren. In der Version 1.5 RC1 heißt diese Option nun "Warnen, wenn Websites Erweiterungen oder Themes installieren möchten". Ergebnis : Haken raus, kein Unterschied zu Haken gesetzt
    Ich kann manuell Erweiterungen, die ich auf einem USB Stick abgelegt habe und von dort installieren möchte, im 1.5 RC1 nicht mehr installieren. Ist das noch ein Bug des RC1 , oder liegt die Option jetzt in einem anderen Menue ??

  • Ach ja: Ich hab natürlich drauf geachtet, dass es sich um bereits aktualisierierte Erweiterungen wie z.B. PDF Download 0.5.1.2 handelt, die für 1.5x bereits frei gegeben sind.

  • Die Einstellungen "Websites das Installieren von Software erlauben" im 1.0.7 und "Warnen, wenn Websites Erweiterungen oder Themes installieren möchten" sind dasselbe. Nur, diese Einstellungen sind nur relevant, wenn Du direkt von der Webseite aus installierst.


    Von USB-Stick ist imho das Gleiche wie von Festplatte. Und das Installieren von Erweiterungen von der Festplatte mit Datei öffnen... funzt bei mir auch im 1.5 ohne irgendwelche Probleme.


    Könnte es sein, dass bei Dir unter about:config der Eintrag xpinstall. enabled auf false steht?

  • Zitat von Road-Runner

    Die Einstellungen "Websites das Installieren von Software erlauben" im 1.0.7 und "Warnen, wenn Websites Erweiterungen oder Themes installieren möchten" sind dasselbe.

    Nein. Darauf bin ich auch schon reingefallen....:wink:


    1.0x: Kein Haken --> keine Installation von Webseiten aus möglich
    1.5 : Kein Haken --> keine Nachfrage bei Installation von Webseiten aus...



    Gebe Dir ansonsten aber recht, vom Stick aus dürfte das egal sein....


    Gruß,
    Bazon

  • SunnyMike


    In die Adressleiste about:config eingeben. In die Filterleiste xpi eingeben. Den Eintrag xpinstallenabled per Doppelklick auf true setzen.


    Bei 'nem neuen Profil steht es defaultmäßig auf true, womöglich hast du ja das Profil vom Fx 1.0.7 übernommen... :?:


    Wenn es so ist, reichlich dämlich von den Developern, da werden sich bestimmt noch viele Leute wundern, warum sie plötzlich keine Erweiterungen mehr installieren können...:wink:


    Ich fand die alte Lösung sowieso besser...


    Gruß,
    Bang

  • Könnte es sein, dass bei Dir unter about:config der Eintrag xpinstall. enabled auf false steht?


    Jau, thanx a lot. Das wars. Super. Nach der Umstellung ging die Installation ohne Probleme.

  • [quote='Bang'] SunnyMike


    In die Adressleiste about:config eingeben. In die Filterleiste xpi eingeben. Den Eintrag xpinstallenabled per Doppelklick auf true setzen.


    Jau, thanx a lot. Das wars. Super. Nach der Umstellung ging die Installation ohne Probleme.


    Wenn es so ist, reichlich dämlich von den Developern, da werden sich bestimmt noch viele Leute wundern, warum sie plötzlich keine Erweiterungen mehr installieren können...:wink:


    Was sich die Jungs dabei gedacht haben ist mir nicht klar. Es gibt einfach super Erweiterungen. Wer jetzt kein Bock hat sich durch die Konfigurationsmöglichkeiten die "about:config" bietet, durchzuwühlen, der steht erst mal auf dem Schlauch.

  • Könnte es sein, dass bei Dir unter about:config der Eintrag xpinstall. enabled auf false steht?


    Ja genau. Ich habs umgestellt. Danach funzte es. Alles klar. Danke für den Tipp.

  • Zitat von SunnyMike


    ... der steht doch schon standartmäßig auf true.
    Jedenfalls habe ich heute nachgeschaut und ich mußte nichts umändern.


    Was ich aber bemerkt habe, daß viele englischsprachige Erweiterungen für den Forefox 1.6 konzipiert sein sollen; klicke ich auf installieren, dann meckert das Programm rum, daß diese Erweiterung nur für einen älteren Browser geschrieben worden ist... :(

  • ... der steht doch schon standartmäßig auf true.
    Jedenfalls habe ich heute nachgeschaut und ich mußte nichts umändern.


    Bei mir nicht. Ich hab den FF 1.5RC1 jetzt auf 9 Rechnern installiert und auf jedem PC mußte ich die obige Einstellung auf TRUE setzen. SunnyMike

  • hängt das evt. mit der Einstellung zusammen, daß ich in einem PopUp bestimme, ob die Downloads von diesen Seiten gestattet sind???


    Bei der ersten Verwendung des neuen FF bekomme ich immer so ne gelbe Warnleiste oben und wenn ich auf das Button "Einstellungen" gehe, kann ich dann festlegen, ob der generelle Download von dieser Page erwünscht ist.
    Also ehrlich, ich habe in der auto:config nichts geändert...

  • Dibo


    das Problem haben ja auch nur Leute, die a) ein altes Profil der 1.0.7 weiterverwenden, und b) dort den Haken bei "Websites das Installieren von Software erlauben" klugerweise rausgenommen haben und c) ihre Extensions nicht online sondern von Hand installieren.


    In der 1.5 gibt es nun o.g. Haken/Einstellungsmöglichkeit nicht mehr, deine pref.js bleibt aber erhalten und die Leiste erscheint nur bei direktem install von einer Webseite...


    Gruß,
    Bang