Firefox für Android ab Version 79 markiert besuchte Links nur manchmal

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Version
    ab Version 79

    Hallo Zusammen,


    bereits Anfang Oktober 2020 hatte ich bei Computerbase diesen Beitrag verfasst. Bis heute konnte Niemand etwas dazu sagen. Das Problem konnte nur von einem anderen Nutzer bestätigt werden.


    Hier mein Beitrag von damals:



    Hallo Zusammen,



    seit einigen Wochen nutze ich jetzt den neuen Firefox für Android der jetzt ja technisch eine neue Basis erhalten hat.



    Als längjähriger CB-Leser surfe ich damit täglich die News aus dem CB-Ticker ab.



    Besuchte links werden im Ticker grau markiert, neue News sind orange.



    Das hat beim Firefox auch immer funktioniert. In der neuen Version zeigt jetzt aber quasi jeder Besuch des Ticker ein anderes Ergebnis:



    Manchmal sind alle Links orange, obwohl ich die meisten schon gelesen habe, sie also grau sein müssten.



    Manchmal sind tatsächlich alle Links grau welche zu bereits gelesenen News führen.



    Meistens ist es aber so das eine bunte Mischung zu sehen ist, also manche besuchte Links grau sind, manche orange. Dabei verhalten sich einzelne Links nicht immer gleich. Es lässt sich keine Logik erkennen!



    Ich hatte Anfang 2020 bereits Firefox Preview Versionen gestestet wie auch Betas und Nightlys. Dieses Verhalten war immer vorhanden! Nur bei der alten Version bis 68.0 wurden immer alle Links richtig gekennzeichnet, ohne Ausnahme.



    Hat hier Jemand das selbe Verhalten und vielleicht sogar eine Lösung?

  • Guten Morgen,


    das Problem betrifft auch andere Seiten, dort fällt es allerdings nicht auf da ich andere Seiten nicht immer wieder ansteuere.


    Andere Browser zeigen nicht das gleiche Verhalten. Auch der "alte" Firefox für Android zeigt das Verhalten nicht.


    Habe es auf mehreren verschiedenen Smartphones mit und ohne aktivem Firefox Sync getestet.


    Das Problem bestand von Anfang an beim neuen Firefox für Android. Auch in diversen Preview-Versionen.

  • Hallo,


    dann ist das Problem für mich nicht reproduzierbar. Und bei einem allgemeinen Problem würde ich zahlreiche Fehlerberichte im Issues Tracker von Mozilla erwarten, was aber auch nicht der Fall ist.


    Die Tatsache, dass du das Probem nicht nur auf einer bestimmten Seite hast, deutet auf eine Ursache bei dir hin. Denn es ist klar, dass Firefox etwas so Grundlegendes wie besuchte Links markieren natürlich kann. Das bringt uns zu den folgenden Fragen:


    Ist Firefox so eingestellt, dass er beim Beenden automatisch die Chronik löscht? Wird Firefox im privaten Modus genutzt? Sind Add-ons installiert, falls ja, welche?

  • Die Funktion besuchte Links zu markieren funktioniert grundsätzlich auch, jedoch nicht zuverlässig. Bei manchen Seitenaufrufen wird es richtig markiert, beim nächsten wiederum nicht usw. Dabei ist zu erkennen dass die zu grunde liegende Information eigentlich schon vorhanden ist. Die Anzeige aber oft nicht dazu passt.


    Firefox Sync funktioniert ja auch Geräteübergreifend. Und es werden niemals noch nicht besuchte Links grauf gekennzeichnet. Es kommt also nur vor dass bereits besuchte nicht gekennzeichnet werden.


    Die Chronik wird beim beende nicht automatisch gelöscht, diese Einstellung nutze ich nur am Desktop-Firefox.


    Im privaten Modus nutze ich Firefox nicht.


    An Add-Ons ist nur der Dark-Reader installiert. Das aber erst seit wenigen Wochen. Das Problem konnte ich ja schon auf diversen Smartphones seit weit über einem Jahr nachvollziehen. Die Installation vom Dark-Reader hat am Verhalten auch nichts geändert.

  • Zum Ticker

    https://www.computerbase.de/ticker/


    Also mit der Nightly und vollständigem Profil konnte ich das insofern nachvollziehen, als Öffnen in einem neuen Tab den Link als unbesucht liess, erst im gleichen Tab wurde es grau.


    In der Beta (frisch installiert für den Test) funktionierte es in beiden Fällen, also Ergebnis grau=besucht.

    v68 (vollständiges Profil) macht es auch sofort "richtig".


    Ich könnte mir vorstellen, dass deren CSS Schuld hat, da wird "visited" nicht auf "a" angewendet, sondern auf die Klasse.

    Code
    .ticker__article-link:visited, .ticker__update:visited {
        color: var(--gray1a);
    }
    a {
        color: #e84d0e;
    }
    *|*:visited {
        color: rgb(85, 26, 139);
    }


    Code
    <a href="/2021-05/nano-ii-series-anker-schrumpft-die-usb-c-gan-netzteile-deutlich/" class="ticker__article-link">
    
    <span class="ticker__article-context">Nano II Series
       <span class="ticker__article-colon">:</span>
    </span>
    
    <span class="ticker__article-title"> Anker schrumpft die USB-C-GaN-Netzteile deutlich</span>
    </a>

    zu :visited

    https://developer.mozilla.org/de/docs/Web/CSS/:visited

    Zitat


    ist es deshalb wichtig, die LVHA-Reihenfolge einzuhalten: :link — :visited — :hover — :active.

    https://www.computerbase.de/css/main.237ef2fa.css


    visited kommt in Zeile 6683, hover in 6634, also da weicht es schon zur MDN ab.

  • Vielen Dank!


    Also es wird manchmal 20x hintereinander grau, dann wieder mehrere Male nicht. Oft werden die besuchten Links auch teilweise grau und teilweise nicht - ohne erkennbares Schema.


    Seit einigen Wochen ist es in den Nighly-Builds so dass innerhalb eines funktionierenden Tabs die Links auch nicht grau werden wenn man die Links mit der Funktion "Link in neuem Tab öffenen" auf macht.


    So hatte ich mir immer geholfen: So lange die Seite ansurfen bis alle besuchten Links richtig grau angezeigt werden. Dann die neuen Artikel nach und nach mit dieser Funktion öffnen. Dabei wurden diese dann auch sofort beim öffnen grau und ich hatte wieder den Überblick. Das geht jetzt aber auch nicht mehr.


    Liegt dass dann wirklich an Computerbase? Andere Browser und auch der FF bis 68.0 zeigen dieses Verhalten icht.

  • Der von dir gezeigte Code sagt etwas anderes. Ein :visited bei einem span würde auch keinen Sinn ergeben, da wirkungslos.

    Ich hatte es nochmal korrigiert, weil span falsch ist. Du bist einfach schneller als dein Schatten beim Antworten ;)

    Andere Browser und auch der FF bis 68.0 zeigen dieses Verhalten icht.

    Ich würde behaupten, dass der aktuelle Firefox es richtig macht, ich hatte nicht umsonst auf das MDN verwiesen, allerdings habe ich damit keine Erfahrung. Man könnte es allenfalls ein eigenes CSS (zB mit Stylus) zur Anwendung bringen, welches die Reihenfolge berücksichtigt und neu testen.

  • Auf anderen Seiten kann ich es nicht mit 100%-tiger Sicherheit bestätigen.


    Auf Computerbase habe ich es jetzt seit ca. 1,5 Jahren intensiv beobachtet.

    Einmal editiert, zuletzt von flo212 ()

  • Computerbase hat sich inzwischen dazu gemeldet und ich habe nochmal weitere Seiten getestet. Diesen Beitrag habe ich gerade dort verfasst:


    Vielen Dank für die schnellen Rückmeldungen!



    Ich habe jetzt einige Zeit auch andere Seiten getestet und auch da tritt das Problem definitiv auf. Es kann also nicht an ComputerBase liegen! Nur hier fällt es mir besonders auf weil ich alle lückenlos News der zeitlichen Reihe nach lese.



    Es gibt weitere Nutzer mit diesem Problem. Ich habe auch unzählige Test gemacht seit Anfag 2020 und konnte den Fehler jedes Mal auf CB nachweisen. Nur der Firefox für Android ab Version 79.0 ist betroffen! Keine Desktop-Versionen und auch nicht die alten Android-Versionen bis 68.0 (69-78 gab es nicht für Android).



    Folgende Test habe ich gemacht:



    - Seit mindestens Anfang 2020 die Preview-, Beta-, Final- und Nightly-Versionen vom neuen Firefox für Android auf meinem Galaxy A5 2017;



    - Mein Smartphone hatte zwischenzeitlich auch diverse neue ROMs. Der Firefox-Fehler war trotzdem immer wieder da;



    - Zusätzlich habe ich es auf diversen Smartphones im Freundes- und Familenkreis getestet: Fehler auch immer vorhanden! Smartphones von Samsung, Huawei und OnePlus wurden getestet mit allen möglichen Android-Versionen;



    - Der "alte" Firefox für Android hatte diesen Fehler jeweils nicht;



    - Diesen Beitrag hatte ich erst im Oktober verfasst weil ich bis ca. Anfang September noch den alten Firefox als Hauptbrowser benutzt hatte. Erst dann wurde er durch das Update ersetzt. Parallel hatte ich immer schon die Vorabversionen des neuen Browsers installiert. Ohne diesen Fehler hätte ich bereits ab Anfang 2020 den neuen FF als Hauptbrowser benutzt. Ich dachte damals dass das Problem bis zur Final behoben sein wird.



    Als letzten möglichen Anhaltspunkt kann ich noch nennen dass ich grundsätzlich immer Firefox-Sync verwende. Da hätte ich auch schon als mögliche Fehlerquelle im Verdacht gehabt. Bei Neuinstalltionen hatte ich aber immer zunächst ohne FF-Sync getestet - der Fehler war trotzdem da. Auch funktionierte FF-Sync bei der Desktop-Version und bei der alten Android-Version immer zuverlässig. Sowohl was das Sync selber betrifft als auch die Markierung bereits besuchter Seiten.



    Es ist wie gesagt auch erkennbar dass die Information der besuchten Seiten grundsätzlich auch trotz dem Fehler vorhanden ist. Es wir nur oft nicht entsprechend gekennzeichnet angezeigt. Dabei kann es sein dass 10 Seitenaufrufe lang - oder manchmal sogar mehr - die richtige Funktionalität gegeben ist. Dann plötzlich werden alle bereits besuchten Seiten als "neu" markiert, dann wieder teils-teils usw. Es ist absolut kein System dahinter erkennbar!

  • Google könnte ich ausprobieren, Bing nutze ich nicht. Kann aber etwas dauern. Ich könnte mir aber vorstellen, dass beide wie bei CB eine falsche Reihenfolge des CSS haben. Kannst du am Desktop "Untersuchen" mit dem Inspector.

  • Was für eine "falsche Reihenfolge des CSS"? :/ Vor allem, da das Problem für mich nicht reproduzierbar ist, kann es auch keinen Zusammenhang zum CSS der Seite geben, denn sonst müsste ich zwangsläufig ebenfalls betroffen sein. Ebenso spricht dagegen, dass der Themenersteller das Problem nicht in anderen Browsern hat. Das geht ja auch nicht, wenn's ein CSS-Problem der Website wäre. Und dass ComputerBase, Google und Bing alle einen identischen Fehler begehen, ist auch extrem unwahrscheinlich, zumal ich es da ebenfalls nicht reproduzieren kann.


    Die einzige logische Erklärung ist ehrlich gesagt, dass mit der Chronik was nicht stimmt. Das Profil komplett zurückzusetzen, wäre einen Versuch wert, aber das bedeutet dann natürlich, dass Chronik, Lesezeichen etc. weg sind.