Änderungen, selbst aus der user.js, werden nicht übernommen

Die Verwendung einer veralteten Browser-Version stellt ein erhebliches Sicherheits-Risiko dar. Um kostenlose Hilfe zu Firefox zu erhalten, installiere bitte umgehend die neueste Version von Firefox.
Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hi Leute,


    ich hab seit heute ein merkwürdiges Problem.
    Klingt erst mal vertraut, nämlich, dass sich Änderungen nicht speichern lassen. In meinem Fall handelt es sich um die Einstellungen zu den Cookies, die auf "Immer" eingestellt sein sollen (um dann bis auf die Ausnahmen beim Browser schließen gelöscht werden sollen), aber nach einem Neustart immer wieder auf "Nie" umgestellt wird, was bei manchen Seiten für mich einfach unkomfortabel ist.


    Ich kenne die ganzen üblichen Lösungswege, doch keiner davon hat gefruchtet. Na ja, bis auf die Ausnahme im Safe-Mode bzw. mit einem neuen Profil. Weil mein Fx aber sehr stark angepasst ist, hab ich keine echte Lust, diesen komplett wieder neu einzurichten.


    Einer der Lösungsvorschläge lautet ja, sich um die user.js zu kümmern. Die war aber bei mir nicht vorhanden.
    Aber ich dachte mir, meinem Problem damit als Workaround ein Schnippchen schlagen zu können, in dem ich mir eine user.js anlege und dort den Wert eintrage, den ich haben will.
    Wenn ich es richtig in Erinnerung hab, dann sollte Fx beim Starten ja die Werte der prefs.js übernehmen und eventuell in der user.js vorhandene Werte dann zum Überschreiben nutzen. Deshalb dachte ich, mein Trick könnte funktionieren, aber Pustekuchen.
    Nun bin ich nicht nur ratlos, sondern frage mich, warum dann auch noch die user.js ausgeschaltet wird, von der ich immer annahm, dass sie die letzte "Instanz" wäre?


    Ich hab auch einen Verdacht, woher das Problem kommen könnte, bin mir aber total unsicher, weil es zwar theoretisch passt, aber praktisch dann doch wieder nicht.
    Ich hatte einen Artikel über die Erweiterung Disconnect gelesen, vorher noch mal Google gefragt, ob irgendwo negatives darüber berichtet wird und sie dann einfach mal ausprobiert. In dem Artikel stand auch, dass es ab und an mal zu Problemen insbesondere mit Google-Seiten kommt, was für das Verursachen meines Problems mit den Cookies sprechen würde. Ich hab die Erweiterung dann auch schon nach einigen Minuten wieder deinstalliert. Erst danach ist mir das Problem aufgefallen.
    Es spricht also ziemlich viel dafür, dass diese Erweiterung Schuld an dem ganzen ist.


    Allerdings hab ich die Erweiterung auch noch mal in ein frisches Profil übernommen und dort gab es das Problem nach der Deinstallation nicht. Ebenso wenig konnte ich in deren Forum ein ähnliches Problem wie meines entdecken.
    Ich fürchte daher, bei der Deinstallation ist was schief gegangen, irgendwelche Reste sind irgendwo hängen geblieben oder was weiß ich.


    Wie auch immer, hat einer von euch noch Ideen, wie ich das lösen kann, ohne mir ein neues Profil anlegen zu müssen?


    Ich nutze den aktuellsten Fx auf Windows 7.

  • Wie sieht denn deine user.js aus und liegt diese auch im richtigen Profil?

  • Gut, dass du fragst, da war ich mir nämlich echt nicht sicher, wie sie auszusehen hat.
    Ich hab gegoogelt und es bei Mozillazine so verstanden, dass einfach nur die Werte, die geändert werden sollen, eingefügt werden müssen, ohne vorherigen Text in der user.js.


    Meine ist also bis auf die Zeile
    user_pref("network.cookie.cookieBehavior", 0);
    komplett nackt.
    Und sie liegt im mittlerweile einzigen Profil, das andere hab ich wieder gelöscht.


    Ebenso werden bei mir die Dateiendungen nicht ausgeblendet, so das es sich tatsächlich um eine *.js Datei handelt.

  • 0 ist schon Standard, von daher sollte das nicht wundern. Sollte dem nicht so sein, dann ist eine Erweiterung schuld.

  • Ähm, wie gesagt, das ist mir klar, dass 0 Standard ist.
    Dennoch wird der Wert in about:config immer auf 1 geändert.
    Und auch, wenn ich den Wert in der user.js alternativ auf 3 setze, wird diese Änderung nicht übernommen.


    Das eine Erweiterung Schuld ist, vermute ich ja auch und hab sie oben schon benannt. Aber wie man oben lesen kann, bringt mich das auch nicht weiter.

  • Dann fang ein neues Profil an, und lass einfach dieses Pseudo-Gelumpe weg. Ich nutze selbst nur Noscript und ABP, alles andere stelle ich direkt in Firefox ein, wo Cookies und wo nicht.

  • Na ja, wie gesagt, das hatte ich versucht, zu vermeiden. Dass das der letzte Weg ist, war mir klar, hatte aber gehofft, hier eine Alternative zu finden.
    Zumal diese Erweiterung dieses Problem ja auch nicht pauschal auslöst, wie der versuch mit einem sauberen Profil gezeigt hat.


    In so fern, wenn jemand noch eine Idee hat, dann würde ich mich freuen, davon zu hören.
    Außerdem interessiert es mich, ob ich die Funktion der user.js als "letzte Instanz" richtig verstanden hab und es eigentlich sehr ungewöhnlich ist, dass die Einstellungen dort noch mal übergangen werden können.

  • Hab was neues festgestellt, was mich sehr verwirrt.
    Ich hab dann doch noch mal ein neues Profil erstellt und alle Erweiterungen nach und nach installiert und nach jedem Neustart geschaut, ob sich was an den Einstellungen ändert.
    Und tatsächlich, bei Proxtube hat sich genau das unerwünschte Verhalten eingestellt.
    Nach der Deinstallation von Proxtube im neuen Profil lief wieder alles wie gewünscht.


    Also zurück ins alte Profil, dort auch Proxtube deinstalliert, aber hier gab es keine Besserung.
    Wie kann das nun wieder sein?

  • Weil mit der Deinstallation nicht automatisch alle Änderungen zurückgenommen werden, so einfach ist das. Deswegen ist Zurücksetzen ein probates Mittel neben einem neuen Profil. Sollte ich auch mal wieder durchführen, auch wenn ich keine Probleme verzeichne, wenn ich nicht nur so "träge" wäre :mrgreen: