Beiträge von pat_42

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    Firefox ist auch bei mir ein heftiger Speicherfresser. Im Ressourcen-Monitor stehen immer mehrere Firefox-Tasks ganz oben in der Speicherbelegung. Manchmal sogar mit weit über einem Gigabyte pro Task, Tendenz steigend.


    Zeitweise kann man den Tasks sogar bei Wachsen zuschauen (obwohl man nichts damit macht). Schießt man dann so einen Task ab, geht meistens nur ein einziger Tab zu. Macht man den wieder auf, kommt er als Task mit ganz wenig Speicherbedarf wieder. Bis er sich wieder vollgefressen hat...


    Das passiert regelmäßig und ist schon seit vielen, vielen Jahren so. Wer nur einzelne Tabs auf hat, wird das wahrscheinlich nie bemerken. Wenn man aber mehrere Tabs auf hat, wird es schnell sehr eng.

    Firefox markiert große Bereiche einer Website beim Öffnen von Links in neuem Fenster mit SHIFT plus MITTLERER Maustaste seit FF 89.0.0.

    Und zwar wird die ganze Seite von Anfang (oder Ende) an bis mitten in den Link markiert (also so wie man mit der linken Maustaste Text markiert).



    War vorher nicht so, ist ein neuer Fehler.

    Liegt nicht an Windows, da es mit Opera den Fehler nicht gibt.

    Ist auch nicht von der Website abhängig (passiert auf allen Seiten).

    Und über dreißig Versionen weiter zeigt sich der selbe Fehler immer noch.
    Anstatt dass mal Fehler ausgemerzt werden, kommen immer nur noch mehr hinzu.
    Die Meldung an sich ist ja auch schlichtweg gelogen; nicht die Grafik enthält Fehler, sondern der Fehler ist im Firefox!
    Inzwischen ist der Browser leider weitgehend unbrauchbar. Seit 2014 hat die Absturzhäufigkeit dramatisch zugenommen.
    Die Speicherverwaltung von Firefox ist einfach eine Katastrophe. Hat man viele Tabs auf- und wieder zu gemacht, geben andere Browser den Speicher wieder frei, nicht jedoch Firefox, die Speicherbelegung steigt und steigt, bis die Tabs sich nicht mehr richtig öffnen, beim Tab-Wechsel der Inhalt mehrerer Seiten durcheinander erscheint, und das Programm wieder abschmiert... Das lässt sich eigentlich nur verhindern, indem man alle paar Stunden den Browser schließt und wieder öffnet. Andere Browser schaffen es dagegen tage- und wochenlang durch zu laufen!

    Diese Seite (https://www.mozilla.org/de/plu…mpaign=plugincheck-update) sagt:

    Zitat

    Möglicherweise angreifbare Plugins Plugin Ergebnis Aktion
    Shockwave FlashShockwave Flash 15.0 r0 angreifbar
    15.0.0.223
    Jetzt aktualisieren


    Das Dumme ist nur, dass der"Jetzt aktualisieren" Button auf eine Seite (http://helpx.adobe.com/securit…ash-player/apsb14-26.html) führt, die das Wort "Shockwave " nicht einmal im Text erwähnt:
    "

    "


    Edit 2002Andreas
    Text in Klammercode gesetzt.

    Set FF Version 31 oder 32 ist es so, dass beim Start von Firefox die Lesezeichen-Leiste über der Symbolleiste positioniert wird. Sobald man die Anpassung aufmacht und schließt - ohne irgendetwas eingestellt oder verändert zu haben - wirklich nur öffnen und schließen der Anpassung - ist die Lesezeichen unter der Symbolleiste. Bei jedem Neustart dann wieder darüber. :grr:
    Wieso bleibt die Lesezeichen-Leiste nicht da, wo ich sie positioniert habe :-???

    Herzlichen Dank für die Hilfe.


    Das Tool ist zwar etwas wortkarg, hat aber prima funktioniert.
    Zum Zurückspielen musste ich nur die Pfade anpassen, und dann hat alles funktioniert.
    Dann sollte ich ja auch auf den entfernten Rechner einfach nur das Backup-Verzeichnis kopieren müssen...


    Es ist sogar besser als Sync, denn ich habe nun auch alle Tab-Gruppen genauso wie auf dem anderen Rechner, und die Einstellungen der Addons sind auch identisch; das kann Sync auch nicht.

    Heute hat Sync auf ZWEI Rechnern ALLE Passwörter, Lesezeichen und fast alle Addons gelöscht!


    Eigentlich wollte ich, dass Sync auf EINEM Rechner zusätzliche Addons von einem dritten Rechner übernimmt, da bei einem letzten Sync nur teilweise dessen Addons übernommen wurden. Dazu hatte ich dort dann unter Sync alls bis auf Addons abgewählt.


    Aufgefallen ist es, als Noscript fragte, ob es wirklich deinstalliert werden sollte!?


    Jetzt habe ich natürlich Angst, dass wenn ich den dritten Rechner wieder ans Netz hänge, dass auch dort dann das Selbe passiert, und dann sind meine Passwörter überall weg!!!
    Wie kann ich das verhindern (außer den Netzwerk-Stecker zu ziehen) ?


    Wieso werden Daten, die man nicht mehr synchronisiert, überall gelöscht???


    Kann man diese Fehlfunktion noch mal rückgängig machen?



    Wer kann die folgenden Zeilen deuten und interpretieren (error-txt aus about:sync-log)?
    (ich wollte die txt-Datei eigentlich anhängen, aber es ist nicht erlaubt, txt-dateien hinzuzufügen - was soll das denn???)



    Edit 2002Andreas
    Text in Klammer Code gesetzt.

    Nein, nicht betroffen. Hätte mich auch verwundert, wenn der DNS-Changer nur Firefox beträfe, und nicht auch den IE.


    Wenn es ein Trojaner wäre, würde der auch nicht nur auf einzelnen Seiten sein Unwesen treiben, oder? Hunderte andere Seiten, viele davon auf den selben Domains, funktionieren ja weiterhin problemlos. Der Effekt tritt immer nur - und dann auch nur manchmal - auf, wenn eine Seite nicht erreichbar ist, und sich der Provider da reinfunkt. Er tritt nie mit dem IE auf, den ich dann testweise auf der selben Seite nutze.

    Wer sollte es denn sonst gewesen sein? Wenn es mit dem IE zur selben Zeit NICHT passiert, und wenn es selbst im SAFE_MODUS ohne irgendwelche Plugins oder Addons noch passiert?
    Und es funktionierte erst NACH dem Verlassen des SAFE_MODUS wieder, nicht in diesem!!! Vorurteilsfrei lesen bitte!!!


    Derzeit ersetzt Firefox auch diese Adresse:
    http://www.panoramio.com/group/33952/discussions
    durch diese:
    http://sddnserror8.wo.com.cn:8…/group/33952/discussions&
    nachdem einmal ein Verbindungsproblem mit/bei/zum Provider auftrat.
    IE hatte auch zeitweilig (als die Adressänderung erstmalig im Firefox auftrat) ein Problem die Seite zu erreichen, aber jetzt eben nicht mehr, da geht wieder alles fehlerfrei, und Firefox eiert weiterhin konstant in die Umleitung, obwohl ich jetzt an einem ganz anderen Netz hänge.


    Anstatt real existierende Probleme zu leugnen könnte man sich ja mal Gedanken um den dahinter stehenden Mechanismus machen und um die Lösung, aber das wäre ja mit Nachdenk-Aufwand anstatt Standard-"Kann nicht sein"-Antworten verbunden.


    Genau das selbe Problem hatte ich nun auch, allerdings mit maps.google.com. Firefox hat immer das http durch https ersetzt, womit die Seite nicht mehr erreichbar war. Auch hier half das Deaktivieren aller AddOns und Plugins nichts, der Fehler war weiterhin aktiv. Erst nach dem Beenden des Safe-Modes funktioniert es nun wieder. Mit MS IE 9 hat es parallel immer funktioniert, also war es kein Problem der Internet-Verbindung...


    Wieso hat man es innerhalb von sieben Jahren "Weiterentwicklung" nicht geschafft, diesen Fehler in Firefox zu finden und zu beheben?


    Info by Road-Runner: Bitte vor dem Posten lesen sagt unter Punkt 5:


    Zitat

    Eröffne Deinen eigenen Thread im Forum. Auch wenn das in einem anderen Thread geschilderte Problem auf den ersten Blick identisch mit Deinem Problem ist: es gibt immer die eine oder andere Abweichung (anderes Betriebssystem, andere Erweiterungen, andere Sicherheitssoftware usw.). Ausserdem werden Threads, in denen mehrere User das +- gleiche Problem schildern schnell unübersichtlich und es könnte sogar sein, dass Deine Frage schlicht und einfach übersehen wird.


    Ausserdem ist es sinnlos, Uralt-Threads auszugraben, da die Vorgaben nach 4 Jahren mit Sicherheit geändert haben.


    Deswegen habe ich Deine Frage abgetrennt.

    Das war ja nicht der Erst-Start, ich hatte FF10 gestern so etwa 3-4 mal neu gestartet, ohne dass diese Tabs kamen; erst jetzt nach dem PC-Reboot.
    Diese Tabs kamen ausschließlich für die schon installierten Add-ons. Oben in der Adresszeile steht about:newaddon=?ID{...}


    Wer ist "die KB"? Dass der Extension-Reset bei mir nicht funktioniert hat sollte nicht verallgemeinert werden, das müssten dann noch ein paar Anwender testen. Das FF-Forum ist ja voll mit seltsamen Sachen, die immer nur bei wenigen Usern passieren...

    Update: Nach dem heutigen Rechner-Start überraschte FF10 mit einer ganzen Reihe von Tabs, wo alle schon installierten Add-Ons nachgeladen werden sollen, siehe Bild


    [attachment=0]Zwischenablage01.png[/attachment]
    Die Formulierung ist sehr dubios, was soll denn dieses "andere Programm" sein, dass dort erwähnt wird?


    Jedenfalls geht nun nach einem Neustart die Anzeige der Add-Ons wieder richtig, auch ohne irgendwelche Dateien zu löschen.

    Version ist FF10.0, die einzige derzeit verfügbare Release-Version.


    Die in der Beschreibung erwähnten extensions.*-Dateien habe ich entfernt, das hat aber nur dazu geführt, dass nun auch keine Add-Ons mehr beim Start geladen werden. Also noch ein weiterer Rückschritt :(
    Habe daraufhin die extensions.*-Dateien wieder hergestellt, und die Erweiterungen werden wieder geladen, aber natürlich weiterhin nicht aufgelistet.



    Im extensions.log habe ich folgende Einträge seit der Installation der V10.0 gestern Abend:


    2012-02-01 20:12:21 ERROR addons.manager: Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.execute]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource:///modules/XPIProvider.jsm :: XPIDB_rollbackTransaction :: line 4056" data: no] at resource:///modules/XPIProvider.jsm:4056


    2012-02-02 18:23:45 ERROR addons.manager: Exception calling provider startup: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.execute]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource:///modules/XPIProvider.jsm :: XPIDB_rollbackTransaction :: line 4147" data: no] at resource:///modules/XPIProvider.jsm:4147


    Was bedeutet das?

    Obige Meldung kommt seit dem Update, wenn man sich die installierten Erweiterungen auflisten lassen will.
    Die vorher installierten Add-Ons sind allerdings nach wie vor aktiv. Allerdings sind so keine Updates von Add-Ons mehr möglich. Auch bei den Erscheinungsbildern kommt exakt die selbe Meldung. Die Auflistung der Plugins funktioniert dagegen problemlos. Was ist da los?

    Mit einem leeren Profil passiert natürlich nichts; wäre auch seltsam, wenn das schon so einprogrammiert wäre :)


    Gut, dann formuliere ich die Frage um: Wie kommt Firefox dazu, so einen Mist in mein Profil einzubauen, und wie wird man das wieder los? Denn ein neues Profil anzulegen ist ja extrem aufwendig.

    Ich finde Sync auch sehr verwirrend. Habe es zwar einrichten können, und dazu gibt es ja auch eine seitenlange Anleitung, aber danach fühle ich mich im Regen stehen gelassen. Denn wie es danach weiter geht, dazu finde ich nichts mehr!
    Es hat zwar nach vielem Frust und Probieren einmal funktioniert, aber das war es wohl.
    Man hat zwar im Menue unter Extras den Punkt "Jetzt synchronisieren", aber der ist anscheinend funktionslos. Man sieht jedenfalls nicht, dass irgendetwas passieren würde. Den "Sync-Button" muss man sich erst mühsam hervorkramen (für den Geek kein Problem, für viele Normaluser schon), anstatt dass er automatisch angezeigt wird, wenn Sync eingerichtet wurde. Der Button wird mal kurz animiert, wenn man ihn drückt, aber ansonsten gibt es keine Rückmeldung, ob und was passiert. Ein testweise gesetztes Lesezeichen wurde jedenfalls mal nicht übertragen.


    Das ist einfach schlecht gemacht, wie vieles in der letzten Zeit. Ich habe den Eindruck, es wird vieles nicht mehr fertig entwickelt, so wie die Tab-Gruppierung, die auch irgendwo mitten in der Entwicklung stehen geblieben ist.

    Zitat von Boersenfeger

    Guck mal genau hin! Du hast 2 Adressen in der URL-Zeile.. die von rtl.now und die von starobserver zusammengemixt...


    Ich rufe nur den hinteren Teil auf, den vorderen Teil mixt Firefox selber (oder wer/was auch sonst immer) davor. Das beschreibe ich übrigens schon von Anfang an...
    Auf eine Erklärung des Warum warte ich seitdem vergeblich.