Beiträge von Hundekeks

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    Ich glaube, ich sehe gerade vor lauter Wald die Bäume nicht.

    Ich würde gerne das RestartFirefoxButton_Movable.uc.js Skript einbinden, weiß aber nicht wie genau. Ich habe alle Dateien in die entsprechenden Ordner geschoben, das Skript ebenso, aber wenn ich mich recht erinnere, muß es noch verlinkt werden? In der userChrome.js? Wie genau muß ich da vorgehen?


    Hat sich erledigt. Allerdings war das wohl doch nicht das Skript, das ich vorher hatte. Das Icon passt gar nicht zum Rest. Schade.

    Die folgenden Codes betreffen die Tabs:


    Hallo! :)


    Ich hatte vor dem Verlust meines alten Rechners ein Code-Häppchen in meine userChrome.css eingefügt, der meine inaktiven Tabs kleiner als den aktiven machte. Es funktionierte tadellos, aber leider hatte ich mein Profil-Backup noch nicht auf den neuesten Stand gebracht.

    Der jetzige Code, den ich mir zusammengesucht habe, scheint auf den ersten Blick zu tun, was er soll. Leider ist das wohl doch nicht der Fall, denn hin und wieder bleibt an der Stelle eines geschlossenen Tabs ein Leerraum. Dann hilft nur ein Neustart.





    Außerdem suche ich nach einer Möglichkeit, das Firefox-Favicon in leeren Tabs zu ersetzen oder einfach komplett verschwinden zu lassen. Es läßt sich zu leicht mit der Mozilla Support-Seite verwechseln.

    Hallo!


    Ich wollte gerade einen Screenshot mit dem in Firefox integrierten Tool machen, aber es scheint defekt zu sein, obwohl das Profil noch sehr frisch ist. Vielleicht ein Überbleibsel meiner Probleme mit dem Rüberkopieren des Profils?

    Der Eintrag in der URL-Leiste ist noch vorhanden, das Icon fehlt jedoch. Wenn ich auf den Menüeintrag klicke, passiert nichts.


    Ich habe alle Erweiterungen deaktiviert, das half aber nicht. Aus meinem uralten Profil hatte ich Passwörter und Lesezeichen übernommen.

    In einem frischen Testprofil funktioniert es.


    Firefox 67.0.4

    Ich habe wirklich keine Ahnung, wovon du sprichst. Was willst du mir damit sagen? Dass ich was erfinde? :rolleyes:



    Folgendes habe ich getan, im Überblick. Nochmal zum Mitschreiben und falls jemand ein ähnliches Problem haben sollte.


    Firefox 50-irgendwas war vorinstalliert, habe ich deinstalliert, Profilordner entfernt.

    67.0.2 installiert, gestartet, geschlossen. Profil entleert und mit meinem alten gefüllt. Firefox konnte nicht geöffnet werden. Ich mußte mit einem neuen Profil updaten, das ich dann geleert habe. Mein altes kopierte ich da wieder rein. Addons funktionierten nicht. Optionen-Buttons führen zu Fehlermeldungen.

    Firefox deinstalliert, Mozilla-Ordner in AppData inklusive Profilordner gelöscht.

    67.0.4 installiert, gestartet, geschlossen, Profil entleert und mit meinem alten gefüllt. Kein Optionen-Buttons mehr. Aktivieren und Deaktivieren der Addons löste das Problem. Fast. Ein Addon, Clippings, mußte ich neu installieren, hatte meine selbst festgelegten Texthäppchen dann aber wieder.

    Ich habe Firefox nochmal neu installiert, diesmal gleich Version 67.0.4, vorher den Mozilla-Ordner untere AppData (Win10) manuell gelöscht, aber Firefox konnte sich trotzdem irgendwo her noch meine Passwörter etc. holen (gibt's da noch ein verstecktes Backup?).

    Jetzt gibt es nichtmal mehr den Optionen-Button bei den Erweiterungen. :(


    Danke für den Hilfe-Versuch. Der Rechner ist brandneu, erst seit einigen Stunden hier, ich weiß wirklich nicht, wo da das Problem liegen könnte. Eine alte Firefox-Version (in den 50ern irgendwo) war vorinstalliert, aber die hatte ich entfernt. Können da noch Reste irgendwo festhängen.

    Bisher hat das für mich so immer wunderbar geklappt, und ja, es gab normalerweise keine Probleme. Heute ist dann wohl Schluss mit 'normalerweise'.

    Hallo!


    Ich bin gerade einen neuen Rechner am Aufsetzen, habe Firefox 67.0.2 (hatte ich noch auf der externen Festplatte) installiert, mein ca. 10 Tage altes Profil rüberkopiert - und da wollter er schon nicht. Ich mußte ein neues Profil erstellen, auf 67.0.4 updaten, um mein 'altes' Profil starten zu können.

    Mein Theme wurde nicht angezeigt, keine Erweiterung funktioniert, obwohl alles angezeigt wird. Manche der Erweiterungen haben in der Überesicht jedoch kein Icon. Der Optionen-Button fehlt. Die Add-ons auf den neuesten Stand bringen half auch nicht.

    Edit: Wenn ich auf Optionen klicke, bekomme ich Meldung im Anhang.


    Ich habe mühevoll in neues Profil erstellt, nachdem ich jahrelang mit demselben von Version zu Version gehüpft bin. Was ist da los? Hat jemand eine Idee?

    Dieser Code funktioniert nicht, wie ich oben bereits erwähnt habe. Ich bekomme mein Favicon in der Favoritenleiste angezeigt (die ich nicht nutze), nicht jedoch im Tab und dem Lesezeichenmenü (z.B. in der Sidebar) und dementsprechend in der URL-Leiste.
    Ich habe meinem Eröffnungsbeitrag noch ein Bild hinzugefügt, das vielleicht eher verdeutlicht, woran es hapert.


    Ich habe früher ein wenig Webdesign gemacht. Ist schon ewig her, aber ich weiß, wie rudimentäres CSS funktioniert.

    Ich muß leider dieses Thema nochmal zum Leben erwecken.


    Mit dem Update auf Firefox 65 ist die Erweiterung favicon-customizer nahezu nutzlos geworden. 45 Favicons kann ich anlegen, beim Versuch Nummer 46 zu bestimmen, wird die Benutzeroberfläche der Erweiterung einfach schwarz. Das war vorher nicht der Fall. Neuinstallation hat daran nichts geändert. (siehe Screenshot im Anhang)


    Code, den ich in die userChrome.css einfügen könnte, wäre wirklich am besten, aber dieser Code hier

    CSS
    .bookmark-item[label="Dings"] image {
    width:0!important;
    height:0!important;
    padding: 0 0 16px 16px !important;
    background:url('Link zum Bild oder Base64 Bilddaten') !important;
    }


    hat wie schon im verlinkten Forumsbeitrag erwähnt bei mir gar nichts gebracht, weder im Lesezeichenmenü noch in den Tabs. Nur in der der Favoritenleiste wird tatsächlich mein eigenes Favicon angezeigt, aber das bringt mir gar nichts.
    [attachment=0]FirefoxBM01.jpg[/attachment]


    Die Erweiterung war zwar auch eher unzuverlässig, hat aber in der Regel in den Tabs fast immer das neue Favicon angezeigt, im Lesezeichenmenü etwa bei der Hälfte.
    Ich habe mich halb zu Tode gesucht, aber es taucht immer nur dieser Code auf und sonst gar nichts. Ich wiederhole nochmal: Ich möchte meine eigenen Favicons im Lesezeichenmenü (und damit auch im Drop-down der URL-Leiste) sowie in den Tabs selbst. Die Lesezeichen-Favoritenleiste nutze ich nicht.
    Da die Erweiterung theoretisch ja funktioniert, muß es doch eigentlich auch manuell per CSS (oder mit einem Script?) machbar sein, oder?


    Ich verzweifele hier gerade, da mir dies wirklich wichtig ist und Surfen für mich wesentlich erträglicher macht. (Dahinter steckt ein neurologisches Problem; Details sind zu kompliziert.) :(

    Das hat leider nicht so wirklich funktioniert. Ich habe zwar ein Hover-Effekt, aber man sieht einen Schatten unter dem Zurück-Pfeil und es sieht generell etwas seltsam aus.
    Ich habe wieder auf die kompakte Ansicht gewechselt und außerdem noch die Option 'Drag Space' (engl. Firefox-Version) ausgewählt, dadurch wirkt zumindest die Tab-Leiste großzügiger.
    Trotzdem natürlich danke für die Hilfe. Es war einen Versuch wert. Diese extrem flache Optik ist generell nicht so meins.

    Die Kompaktansicht habe ich dann später auch noch entdeckt und hätte sie vermutlich auch genutzt, aber da dein Code wunderbar funktioniert, bleibe ich bei normal. Kompakt ist mir einen Tick zu gequetscht. Allerdings fehlt mir noch der Hover-Effekt für den Vor- und Zurück-Button. Gibt's dafür auch noch den passenden Code?


    Dankeschön! :)