JavaScript-Problem, youtube halb kaputt

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hallo zusammen,


    nachdem gestern noch alles reibungslos lief, treten heute auf einmal JavaScript-Probleme auf youtube auf, wobei zwischenzeitlich nichts verändert wurde, der PC wurde bloß aus- und wieder eingeschaltet. Ich kann Videos zwar ansehen, aber diverse Steuerungsfunktionen sind einfach tot, z.B. das Ausklappen der Beschreibung, die Vorschaubilder in der Related-Leiste rechts, die Steuerung im eigenen Accountbereich, etc.


    Beim Aufrufen eines Youtube-Videos gibt mir die Fehlerkonsole folgendes aus (xxxxxxxxxxx = beliebiger youtube-code):



    Nun liegt der Fehler bei mir, da ich mit IE diese Probleme nicht habe, aber diese Meldung gibt mir keinen Hinweis, da sie den Fehler bei youtube ausmacht.


    Html-Proxy (Proxomitron) deaktivieren bringt nichts, Plugins deaktivieren bringt nichts, löschen von Cookies auch nichts (außer dass ich mich nun gar nicht mehr einloggen kann), ich will aber FF nicht komplett neu installieren, solange es nicht absolut sein muss, daher die Frage hier, was kann ich tun?
    Liegt das Problem irgendwo in einer der vielen Konfigurationsdateien von FF?


    PS: Firefox Version: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
    Betriebssystem: Windows XP

  • Hallo Khris,


    falls das Problem Profil noch vorhanden ist,
    kannst Du in der prefs (Dateityp: JScript Script File) für Dich wichtige Einstellungen vorfinden.


    "Benutzereinstellungen zurücksetzen"
    Da bei mir auf der YouTube Webseite auch Probleme auftraten und der Abgesicherte Modus kein
    Erfolg
    brachte habe ich die Firefox-Einstellungen auf die Werkseinstellung zurückgesetzt.


    Gruß. Erich

  • Die Einstellungen im abgesicherten Modus zurücksetzen hätte auch geholfen, hab's gerade ausprobiert, aber ich wusste nicht, was da alles zurückgesetzt wird, daher habe ich lieber erstmal ein neues Profil erstellt, und nachdem das dann ging, bleibe ich jetzt dabei.

  • Hallo zusammen,


    ich habe seit gestern genau dasselbe Problem und bin gerade durch Zufall auf diesen Thread gestoßen. Sehr seltsam, dass uns das gleichzeitig passiert.. :-???


    Das mit der prefs.js hatte ich auch schon rausgefunden, allerdings weiß ich nicht, welchen Eintrag ich dort ändern muss. Hat einer von euch vielleicht eine Idee? Ich möchte eigentlich meine ganzen Einstellungen usw. behalten.


    Gruß

  • ja der Zufall will es. weroviho Hallo und Willkommen im Firefox Forum.


    Das Vorhaben in der prefs.js gezielt den Eintrag zu finden der Verantwortlich ist habe ich sehr schnell aufgegeben.
    Frage: Hast Du die Erweiterung Greasemonkey installiert?


    Gruß. Erich

  • Es bzw du bist der Einzelfall, weil es bei allen anderen (Millionen) keine Probleme gibt.
    Und da drei Rechner ein systematischer Fehler. Oder YT schraubt wieder.
    Führe die verlinkten Standardfehlerprozeduren aus, dann melde dich wieder,
    anders hats keinen Sinn.

  • ich habe dies schon versucht, alle erweiterungen deaktiviert, abgesicherter modus, neues profil! das ergebnis ist das selbe.
    mit dem IE gehts und hab grad mal testhalber google chrome inst. da geht es auch.


    entweder liegt es an yt oder ich weiß mir nicht weiter. ebenfalls von gestern abend auf heute morgen, wie gesagt bei allen und ohne änderungen, nur aus und einschalten.

  • Zitat von mirco11

    Hast Du die Erweiterung Greasemonkey installiert?


    Ich hatte es schon öfters installiert, mittlerweile habe ich es aber wieder entfernt. Wieso fragst Du? Glaubst Du, dass da möglicherweise ein Skript (bzw. ich *g*) rumgepfuscht haben könnte? Das ist ziemlich unwahrscheinlich, da ich es schon vor einer ganzen Weile deinstalliert habe und bis gestern Abend alles tadellos lief. An den Addons scheint es nicht zu liegen.


    An Tiberias:
    Schließe den Firefox und warte einige Sekunden. Dann suche in in diesem Ordner


    Code
    C:\Users\x\AppData\Roaming\Mozilla\Firefox\Profiles\x (Vista)


    nach der Datei prefs.js. Ziehe sie vorläufig in einen anderen Ordner. Nach dem nächsten Neustart von Firefox müsste es wieder funktionieren - allerdings ohne deine alten Einstellungen.

  • weroviho, danke dir für die Informationen in Bezug auf Greasemonkey


    Lösche ich alle Einträge im Problem-Profil (prefs.js) die mit user_pref("dom
    beginnen ist das Verhalten auf der YouTube Webseite wieder in Ordnung.


    Beispiel:

    Code
    user_pref("dom.disable_window_move_resize", true);


    Gruß. Erich

  • Hatte folgendes Problem bei You Tube, alles läuft nur die Bilder auf der Seite wurden nicht mehr angezeigt.


    @mirco11 Danke für deinen Tip :klasse:

    Win 7 X64


    Firefox 23 aktuell

  • bei mir war es : user_pref("dom.storage.enabled", false);


    soweit so gut, aber was hat das für weitere Auswirkungen, für irgend etwas wird der Eintrag ja vorgesehen sein.


    Weiß jemand wofür und was jetzt eventuell nicht mehr funktioniert?

  • user_pref("dom.disable_window_move_resize", true);


    Ist bei mir true, fett, also Benutzereinstellung.
    Ist bei Fx 3.6x in den Einstellungen > Javascript zu finden, bei v4 derzeit nicht mehr.
    Sollte also auch ohne about.config machbar sein...
    Allerdings frage ich mich, was diese Einstellung mit den o.g. Scriptfehlern zu haben soll!?
    Bei mir funzt das alles mit diesen Einstellungen, schon seit Jahren.