Entwicklung Firefox (Trunk)

  • Ich hab das von caschy verlinkte minimalistische Thema auf den 40b3 installiert, sieht nett aus.
    http://stadt-bremerhaven.de/fi…uer-das-netbook-anpassen/


    Obwohl die Schaltflächen insgesamt sichtbar sind, habe ich ein Problem mit zB den Proxy-Knopf
    aus den "Toolbar Buttons", weil man bei dem nicht mehr sehen kann, ob aktiv oder nicht (Rahmen ein/aus).
    Da TMP derzeit schwächelt bin ich ersatzweise auf "Superbar Mode" umgestiegen.
    Passt allerdings nicht ganz zum Mini-Thema, aber durch Fummelei im JS+CSS wurde auch das behoben.


    [Blockierte Grafik: http://img3.imagebanana.com/img/kz9mpzki/thumb/fx4b3_mini_super.png]


    Das Menü links kommt durch Superbar und der zweite Knopf von rechts ist der Proxy-Knopf (aktiv).


    Funktionierende Erweiterungen bislang:
    - TabPreview (irgendwie zerhaut es mir immer die interne Vorschau)
    - Toolbar Buttons
    - SmoothWheel
    - CookieCuller
    - Super Tab Mode (von Haus aus schon)
    - Context Search
    - Linkifikation
    - OldBar (die einfache Variante, nicht Old Location Bar)
    - BBcode
    - Link And Form Info
    - Easy Youtube Video Downloader
    (- 1-Click Youtube Downloader evtl auch)
    - Download Statusbar (bedingt, nicht mit diesem Mini-Thema zB)
    - ImageTweak
    - RDR Redirect Remover
    - Checkplaces
    - colorsecureurl
    - Firegestures 1.6b3 (nur diese, hier siehe Webseite)
    (- AllInOneGestures nur mit Anpassung, siehe MozillaZine-Forum)
    - GoParentFolder
    - ShowParentFolder
    - Inspector (DOMi)
    - SkipScreen
    - Statusbardate


    Prefs wurden neu erstellt, alle sqlites übernommen.
    Bei den Cookie-Einstellungen spinnt die build-26.07. noch rum, da behält er nicht "benutzerdefiniert".

  • Zitat von Brummelchen

    ...Wenn ich jedoch den Link manuell ändere,
    bekomme ich einen Download:...


    Jetzt werden aber alle Register gezogen :)

  • Zitat von Brummelchen

    ich seh grad, dass im Ordner \releases ein\4.0b2 steht.

    Und ? Irgendwann musste dort doch eine Version auftauchen.

    Zitat von Brummelchen

    Allerdings gelange ich [...]

    Dafür gibt es einen Grund

    Zitat

    Add index.html to cover the files before release time

    denn vorab lief

    Code
    rsync [...] \
      /pub/mozilla.org/firefox/nightly/4.0b2-candidates/build1/ \
      /pub/mozilla.org/firefox/releases/4.0b2

    d.h. alle Spiegelserver müssen synchron sein und die aktuelle Dokumentation muss noch bereitgestellt werden, danach klappt es auch mit dem richtigen Link.


    P.S. in den Pfaden des Web wird ein / (Slash) und kein \ (Backshlash) benutzt.

  • Was die Dokumentation angeht, falls du dazu auch die Informationsseiten zur Beta meinst, die auf mozilla.com hätten stehen sollen: Ich hab' grade erfahren, dass die Seiten zu neuen Funktionen und die Versionshinweise nicht übersetzt werden sollen.

    Gruß Coce


    Keine Garantie für Richtigkeit meiner Tipps! Fragen/Antworten nicht per PN/IM/E-Mail!

  • Zitat von Coce

    [...]die Informationsseiten zur Beta meinst, die auf mozilla.com hätten stehen sollen [...]

    Nicht stehen sollen, sondern stehen werden. Im Prozess der Bereitstellung sollte man doch nicht die transienten Zustände als augenscheinlich permanente Zustände publizieren - egal von wem.


    Eine Transliteration ist dabei absolut unerheblich.

  • Funktionieren bei Euch die Video's (Flash & Quicktime) ?
    http://trailers.apple.com/


    Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre
    Quicktime 7.6.6
    Flash Player 10.1.53.64


    PS:
    Hiermit funktioniert es
    Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

    HauptPC: ASRock X99M Extreme4; i7-5820K; 4x4GB DDR4-2400; Gigabyte GTX 1060 6GB Mini OC; 950 Pro 512 GB
    ZweitPC: Asus M4N82 Deluxe; Phenom II x6 1090T; 4x2GB DDR2-800; GeForce GT530
    TestPC: Gigabyte GA-K8NS Pro; Athlon 64 Venice 3200+; 2x 1GB MDT DDR-400; Club3D HD4670 AGP
    Notebook: ASUS K53SV; i5-2410M/HD3000; GeForce 540M 2GB; 2x4GB DDR3-1866: 850 EVO 500 GB

  • Hier funktionieren auch einige Videos nicht richtig:
    http://www.esm.psu.edu/Faculty/Gray/movies.html


    Könnt Ihr dies bestätigen?

    HauptPC: ASRock X99M Extreme4; i7-5820K; 4x4GB DDR4-2400; Gigabyte GTX 1060 6GB Mini OC; 950 Pro 512 GB
    ZweitPC: Asus M4N82 Deluxe; Phenom II x6 1090T; 4x2GB DDR2-800; GeForce GT530
    TestPC: Gigabyte GA-K8NS Pro; Athlon 64 Venice 3200+; 2x 1GB MDT DDR-400; Club3D HD4670 AGP
    Notebook: ASUS K53SV; i5-2410M/HD3000; GeForce 540M 2GB; 2x4GB DDR3-1866: 850 EVO 500 GB

  • Nö, kann ich nciht bestätigen, da sie bei mir laufen, wenn auch in einer Sandbox, da ich QT nicht auf meinem System haben will. :D

    Aurora 7.0a2, WinXP 32bit

  • Ich vermisse eine Funktion "Add-on für alle / aktuellen Benutzer installieren".


    Manche Add-ons würde ich gerne für alle Benutzer installieren, die dann auch die selben (zentralen) Einstellungen verwenden.
    Also in "All Users" liegt.


    Z.B. für:
    - NoScript
    - WOT
    ...


    was haltet Ihr davon ?

    HauptPC: ASRock X99M Extreme4; i7-5820K; 4x4GB DDR4-2400; Gigabyte GTX 1060 6GB Mini OC; 950 Pro 512 GB
    ZweitPC: Asus M4N82 Deluxe; Phenom II x6 1090T; 4x2GB DDR2-800; GeForce GT530
    TestPC: Gigabyte GA-K8NS Pro; Athlon 64 Venice 3200+; 2x 1GB MDT DDR-400; Club3D HD4670 AGP
    Notebook: ASUS K53SV; i5-2410M/HD3000; GeForce 540M 2GB; 2x4GB DDR3-1866: 850 EVO 500 GB

  • Zitat

    Manche Add-ons würde ich gerne für alle Benutzer installieren

    Dann mache das.
    http://kb.mozillazine.org/Inst…sions#Global_installation


    Zitat

    die dann auch die selben (zentralen) Einstellungen verwenden


    https://developer.mozilla.org/…or/Locked_config_settings

  • Zitat von boardraider

    Dann mache das.

    Nur zur Info:

    Zitat von <woltlab-metacode-marker data-name=

    Command_Line_Options#Add-ons" data-link="">

    Gecko 1.9.2 note
    -install-global-extension and -install-global-theme have been removed from Gecko 1.9.2 and upwards.

    Somit die xpi herunterladen, in das Verzeichnis extensions kopieren und den Fx neu starten.

  • Da müsste man wohl noch den Wiki-Artikel überarbeiten, der enthält zwar beide Wege, allerdings damit auch den veralteten. Der sollte zumindest als <3.6 gekennzeichnet sein, bis sich das EOL für 3.5 eingestellt hat.

  • Zitat von .Ulli

    Somit die xpi herunterladen, in das Verzeichnis extensions kopieren und den Fx neu starten.


    Danke für die Hinweise, werde ich heute Abend ausprobieren.


    Ich hatte eigentlich an eine noch (für den Benutzer) leichtere Variante gedacht:
    [Blockierte Grafik: http://img.album.de/files/images/screen/181/18101028991782.jpg]
    (oder so ähnlich)

    HauptPC: ASRock X99M Extreme4; i7-5820K; 4x4GB DDR4-2400; Gigabyte GTX 1060 6GB Mini OC; 950 Pro 512 GB
    ZweitPC: Asus M4N82 Deluxe; Phenom II x6 1090T; 4x2GB DDR2-800; GeForce GT530
    TestPC: Gigabyte GA-K8NS Pro; Athlon 64 Venice 3200+; 2x 1GB MDT DDR-400; Club3D HD4670 AGP
    Notebook: ASUS K53SV; i5-2410M/HD3000; GeForce 540M 2GB; 2x4GB DDR3-1866: 850 EVO 500 GB

  • Ich hab grad die build vom 1.08 aufgespielt, da ist im Menu ein "Developper" drin, seit wann das dann?

  • Keine Ahnung warum du mit ollen Kamellen spielst, es geschah am Freitag.