[FF 0.8] Standardbrowser macht Ärger

  • Firefox ist bei mir (win2k) als Standarbrowser eingerichtet, und Thunderbird als Standrard-Emailclient.


    Seit neustem beobachte ich folgendes, seltsames Verhalten:


    - jpg und jpeg Dateien werden im Firefox geöffnet, obwohl ich dies Standardmässig auf IrfanView eingestellt hatte. Wenn ich die Zuordnung manuell wieder ändere, sagt Firefox beim nächsten Start, daß er nicht der Standardbrowser sei und ob dies eingerichtet werden soll. Bei "JA" werden die JPEG's dann wieder mit Firefox angezeigt.


    - Wenn ich einen Link in einer Email öffnen will, wird nicht der Link in Firefox geöffnet, sondern die Datei heruntergeladen und dann aus dem TEMP Ordner im Firefox angezeigt. Das bedeutet bei Webseiten ohne Bilder, Serverseitig generierte CGI Seiten funktionieren dann gar nicht.


    Hat jemand ähnliche Probleme?
    Wie bekomme ich das wieder hin?


    Gruss, S.

  • Zitat

    - Wenn ich einen Link in einer Email öffnen will, wird nicht der Link in Firefox geöffnet, sondern die Datei heruntergeladen und dann aus dem TEMP Ordner im Firefox angezeigt. Das bedeutet bei Webseiten ohne Bilder, Serverseitig generierte CGI Seiten funktionieren dann gar nicht.


    Zumindest hierfür habe ich eine Lösung gefunden:


    In Explorer/Ordneroptionen/Dateitypen muss für die Erweiterung URL:HTTP die Box für "Download bestätigen" NICHT ausgewählt sein.


    Gruss, S.

  • Alle Probleme gelöst.


    Offensichtlich hatte ich mir meine Registry ordentlich zerschossen.


    Ich habe einfach alle registrierten Grafik Dateien gelöscht und wieder neu assoziiert. Jetzt läuft wieder alles.


    Gruss, S.

  • zu 1)


    Firefox registriert bei jeder Installation automatisch verschiedene Bilddokumente wie JPG, so dass diese dann automatisch im FF geöffnet werden.


    Das ist lästig, aber dieser Fehler wurde behoben, und ab Version 0.9, wird er sich nicht mehr als Standardbildbetrachter registrieren.


    Dann werden die Bilder auch bei einer Neuinstallation von Firefox wie gewohnt mit IrfanView geöffnet.


    Du hast also deine Registry nicht zerschossen.


    Du kannst diesen Fehler im englischsprachigen Bugzilla nachlesen