Firefox start auf aktivem virtuellem Desktop

  • Firefox-Version
    118
    Betriebssystem
    Windows 10

    Hallo zusammen,

    ich arbeite unter Windows 10 mit mehreren virtuellen Desktops. Dabei stört mich ein verhalten von Firefox:

    Firefox startet (die erste Instanz) immer auf dem Desktop, auf dem die letzte Instanz geschlossen wurde. Nach "Murphys Gesetz" ist das dann auch IMMER ein anderer Desktop als der gerade aktive :(

    Nach dem ersten Start funktioniert das dann wie gewollt: auf dem gerade aktivem Desktop startet eine neue Firefox-Instanz.

    Gibt es eine Möglichkeit, dass Firefox nicht auf dem letzten sondern auf dem gerade aktivem Desktop startet?


    Grüße!

  • Firefox merkt sich den Zustand, bei dem es geschlossen wurde. Alles andere macht Windows, wahlweise per Tool. Nur bei Tools sollte man aufpassen, die können da nicht wirklich unterscheiden, vor allem nicht, wenn die Titelleiste dem Tab-Titel folgt.

    Wenn du weinen möchtest, bist du falsch hier. Hier gibt es nur Lösungen!

    Oh Herr, wirf Hirn, oder Steine - Hauptsache, du triffst endlich. Das Netz wird dominiert von Goof:ienen:ies und Dullek:innen:s vom Dienst. Schlabokka!

  • Ich weiß, die Wege von Windows sind unergründlich.

    Aber von allen Programmen, die ich in dieser Umgebung verwende (Von MS Office, Notepad, (Programmier-) Tools, Google Chrome, ...) zeigt jedoch nur Firefox diese Verhalten.

    Alles andere startet (wie gewünscht) auf dem gerade aktivem virtuellen Desktop.

    Warum macht Windows das nur bei Firefox?

  • Dazu müsstest du wissen, wie Desktops durchgezählt werden. 0,1,2 usw steht zwar dran, aber technisch werden Pixelangaben genutzt.

    Wenn deine Desktops zB 1024px breit sind, fängt Desktop 7 bei (1024*6) an, und das merkt sich Firefox. Ich vermute jedenfalls so, ist so bei meinen (echten) Monitoren. Andere Programme scheint das nicht zu interessieren. Selbst Notepad merkt sich die Position. Dass ausgerechnet Chrome sich das nicht merken soll, halte ich für ein Gerücht, Edge merkt sich auch die Position. Allerdings könnte es sein, dass Windows durch die Verflechtung mit MS-Programmen das evtl anders löst.

    Bugzilla meint dazuhttps://http://bugzilla.mozilla.org/buglist.cgi?qu…virtual+desktop

    Das mit den VD ist sone Sache, die meisten haben/hatten das Problem, dass Firefox genau das nicht macht, was bei dir der Fall ist.

    Ach ja, aktuell ist Firefox 119, bitte das Update installieren - falls noch nicht passiert - und neu testen, evtl wurde ja was behoben.

    Solltest du den Zeitrahmen eingrenzen können, ab wann das Problem auftrat, wäre mozregression hilfreich.

    Wenn du weinen möchtest, bist du falsch hier. Hier gibt es nur Lösungen!

    Oh Herr, wirf Hirn, oder Steine - Hauptsache, du triffst endlich. Das Netz wird dominiert von Goof:ienen:ies und Dullek:innen:s vom Dienst. Schlabokka!

  • Okay. Es sieht so aus, als ob ich mich damit abfinden müsste. Zeitlich kann ich das nicht wirklich eingrenzen. Ich meine mich zu erinnern, dass es vor sehr langer Zeit mal anders war. Schon seit vielen Jahren ist das Verhalten dann so wie beschrieben und ich habe schon vor einigen Jahren mal nach einer Lösung ohne Erfolg gesucht.

    P.S.

    Chrome ist hier installiert und zeigt das Verhalten wie oben beschrieben. Auch Edge startet immer auf dem gerade aktiven vrtuellen Desktop, egal wo man die letzte Instanz geschlossen hat!

    Mir ist nur Firefox mit dem Verhalten bekannt!

    Reden wir vielleicht aneinander vorbei? :/

    Grüße!

  • Vermutlich, weil ich keine virtuellen Desktops nutze. Aber ein kurzer Test zeigte mir, dass beide Monitor jeweils dazugehören. Mein Testprofil auf Desktop 3 gestartet/beendet, zu Desktop 1 gewechselt - dort aufgerufen, blieb auch in Desktop 1 und nicht wieder in 3. So wie jetzt beschrieben sollte es bei dir sein. Nutzt du irgendwelche Zusatzprogramme von deiner Grafikkarte?

    Ich habe eben nach "programm öffnet auf falschem virtuellen desktop" gesucht. Ja, gibt es, aber bei denen ist das zugehörige Programm schon auf dem entsprechenden Desktop aktiv. Also zB wenn Excel offen ist auf Desktop 2, und man auf Desktop 1 eine Tabelle öffnet, springt es zu Desktop 2. Könnte es daher auch sein, dass Firefox auf dem unerwünschten Desktop bei dir noch aktiv ist? Schau dazu bitte in den Taskmanager.

    Wenn du weinen möchtest, bist du falsch hier. Hier gibt es nur Lösungen!

    Oh Herr, wirf Hirn, oder Steine - Hauptsache, du triffst endlich. Das Netz wird dominiert von Goof:ienen:ies und Dullek:innen:s vom Dienst. Schlabokka!

  • Das Verhalten ist bei mehreren (privaten / geschäftlichen) Installationen identisch. Keine relevanten Tools installiert.

    Letztendlich war der Auslöser für das Verhalten eine Einstellung in Firefox:

    "Allgemein" -> "Vorherige Fenster und Tabs öffnen"

    Diese Einstellung ist bei mir aktiviert. Das sorgt dafür, dass sich Firefox wohl auch den Desktop merkt, auf dem die letzte Instanz geschlossen wurde.

    Bei deaktivierter Option ist das Verhalten wie bei allen anderen Programmen (start auf gerade aktivem Desktop).

    Also eine wohl sehr exotische Kombination aus "Nutzung virtueller Desktops" und der genannten Einstellung in Firefox.

    Die Option habe ich sehr ins Herz geschlossen, ich werde deshalb mit dem Verhalten leben müssen.

    Wenigstens weiß ich jetzt, dass ich nicht total verrückt bin ;)