Beiträge von maxif

    bananovic Das Problem mit Geo-Blocking kenne ich, möchte auch oft in legalen DE-Mediatheken Filme schauen, aber darf man nicht ...

    Die von Dir erwähnten Add-Ons kenne ich nicht, aktuell (hatte schon 2-3 unterschiedliche) funktioniert es gut mit CyberGhost, wer weiß, wie lange :/

    Viel Länder gibt es nicht zur Auswahl, aber mir reicht es, wenn ich DE auswählen kann :) Eine neue IP gibt es da nur, wenn ich das Gerät entweder runterfahre od. kurz vom Ethernet trenne (nutze Laptop, Provider-Router mit Ethernet, WLAN deaktiviert). Dass solch kostenlose Lösungen bzgl. Sicherheit nicht

    Liegt wohl an der API. K.A., welches Gerät du nutzt, aber es müssen auf HW- und SW-Ebene alle Dinge mitmachen.

    Kann sein, dass FF für Deinen Laptop keine passende API programmiert hat oder Win-OS die Treiber nicht anbietet oder LIDL die Website nicht passend für Dein Gerät gemacht hat oder, oder ...

    Bei meinen Geräten (Thinkpads) bzw. Win-OS konnte ich dein Problem nicht "erleben".

    Ich habe andere Probleme, wo ich auch nicht verstehe, warum das seit Update auf Fx 90.0.2 nun anders ist X(


    Ach ja, die PC-Welt: Man glaubt, genug zu wissen - aber es ist immer zu wenig :|

    Interessant. Also es liegt an Touchpad/Mouse. Nicht an FF, sondern Diskrepanz zw. HW u. OS-Update?

    Ich kämpfe oft mit Win-Updates - manchmal sind passende Treiber f. HW dabei, manchmal nicht :/

    Gut, dass Du das Problem eingrenzen konntest. Auf die Idee, eine externe Mouse anzuschliessen, wäre ich nicht gekommen.

    Dazugelernt :)

    Hallo Zitronella (ich liebe Zitronen über alles *g*)

    Niemand außer Dir scheint dieses Anzeigeproblem zu haben, auch ich nicht (Fx 90.0.2, Win10 EDU aktuell, Win7 *seufz*).

    Hm, Treiber usw. hast ja schon gemacht. Vermutlich auch Update von Win Home?

    Ggf. noch mal ein Update von Win 10 Home anstoßen? Vor einigen Tagen hatte ich bei Win10 z.B. Probleme mit stehend bleibenden Verknüpfungsrahmen am Desktop. Ein weiteres Update hat die Sache gelöst.

    Oder liegt es an Add-On's? Aber bei FF hast Du sicher mehr Ahnung als ich ;)

    Und: Ich kann nachvollziehen, dass es irre nervt, wenn es ein Problem gibt u. man keine Idee hat, woran es liegt ?(

    2002Andreas Nein, dass die Screenshots bearbeitet wären - auf diese Überlegung wäre ich nicht gekommen.

    Ich meine, dass mir niemand glaubt, dass ich wirklich bis vor einer Woche (bzw. bis zum Update auf 90.0.2) keine PopUps hatte.

    Und es nicht an veralteten FF-Versionen liegt. Die Updates werden mit einigen Tagen Zeitverzögerungen (manchmal haben die ersten Updates noch Bugs) immer eingespielt.

    Nochmal: Das mit dem Kontexmenü - kann sein, dass mir das bisher nicht aufgefallen ist.


    Da ihr alle mein Anliegen nicht nachvollziehen könnt, evtl. liegt es an Kaspersky. Zwar habe ich Webzugriff deaktiviert (als ich sah, dass er auf jede Website sein Script reinsetzt). Aber Programmkontrolle generell ist da.

    BITTE keine Kommentare zu KIS.

    Bitte verarscht mich nicht!

    Dieses neue Verhalten von Adresszeile u. Suchfeld bilde ich mir nicht ein. Auch habe ich immer die aktuellsten FF-Versionen upgedatet (meist nicht sofort, sondern mit einigen Tagen Verzögerung, weil es manchmal Bugs in den Updates gibt, die nach einigen Tagen dann gefixt sind). Das mit dem Kontext-Eintrag - ich habe erwähnt, dass es den ggf. schon zuvor gegeben hat, ohne dass es mir aufgefallen wäre.


    Es scheint, als ob mein Problem ein "Hirngespinst" ist - na super ...

    Ich weiß, wie Adress- u. Suchfeld bis vor einer Woche auf beiden Notebooks funktionierten (ohne PopUp von Suchmaschinen usw.)

    Mir ist bisher auch nicht aufgefallen, dass bei Rechts-Click auf Links (Kontext-Menü) es einen Eintrag wie <Suchmaschine>-Suche nach "..." (s. Screenshot) gegeben hätte. Aber mag sein, dass es diesen Eintrag im Kontext-Menü schon früher gab :/

    Fakt ist: Irgendwie ist alles anders, ich habe keine Idee, warum. Die Grundeinstellungen bzgl. Suche habe ich bei Einstellungen immer deaktiviert.

    Nein, die habe ich deaktiviert (File-Endung umbenannt).

    Ich teste an 2 PCs (Win10, Win7) mit Fx 90.0.2. Also am OS kann es nicht liegen.

    Mir bleibt wohl nur der Versuch, eine frühere Version von FF zu installieren. Leider habe ich keine Sicherung von einer früheren Installation :(

    Ich melde mich, sobald ich das getestet habe ...


    milupo Danke für die Hinweise, aber diese Einstellungen sind alle gemacht (deaktiviert) worden: alle Hakerln raus, mehr geht nicht ...

    Danke .DeJaVu :thumbup:

    Vor lauter Recherieren u. Testen (*.css, user.js, about:config usw.) bringe ich schon vieles durcheinander, auch den Underscore :(

    Zumind. das Thema mit view-source ist geklärt 8)

    Ändert aber nix an den anderen Problemen: In Adress- u. Suchleiste kommt ab dem 1. Buchstaben ein PopUp.

    Das war zuvor nicht so. Evtl. war die Änderung nicht ab 90.0.1, sondern ab 90.0 ?

    Aber fix ist: Bis vor wenigen Tagen war die Suchfunktion anders (ohne PopUp) usw.

    Sucheinstellung bei mir: "Suchleiste zur Symbolleiste hinzufügen"

    Bis Fx 90.0.1 war es so:

    In Adresszeile (Urlbar) konnte ich Links eintippen, ohne automatische Suchfunktion.

    Also auch view_source:chrome://.... anzeigen lassen.

    In Suchfeld (Searchbar - oder wie das heißt) konnte ich Suchbegriffe eingeben, mit Enter wurde

    über Standardsuchmaschine gesucht. Wenn ich eine andere Suchmaschine wollte, konnte ich über

    den Pfeil beim Icon die Dropdown-List anzeigen lassen u. eine andere wählen.


    Ab Fx 90.0.2 ist alles anders - sowohl Urlbar wie Searchbar sind gleich:

    Sobald ich nur 1 Buchstabe tippe, kommt automatisch ein PopUp mit Vorschlägen aller aktivierten

    Suchmaschinen (s. Screenshot). Ich hatte mich so gefreut, endlich die chrome://.. files lesen zu können - darin sind auch

    die ganzen zugehörigen css-files, da konnte ich stöbern, um IDs, Classes usw. besser zu verstehen (welches UI-Element wie angesprochen wird). Aber nun kann ich mir das nicht mehr ansehen. Einzig about: ... wird nicht an Suchmaschine weitergegeben.


    Gibt es eine Möglichkeit, über about:config die Suchfunktion der UrlBar zu deaktivieren?

    Bzw. dieses PopUp wieder in ein DropDown (Aktivierung durch Click auf Pfeil bei Icon) zu verwandeln?

    Meine Versuche (ich kenne mich zu wenig aus) waren ergebnislos:

    browser.urlbar.suggest.searches bzw. ... .engines = false.

    services.sync.prefs.sync.browser.urlbar.suggest.searches bzw. ... .engines = false

    -> ohne Wirkung :(

    In der pref.js lese ich von gepinnten Adressen - vermutlich wird das von Mozilla so gesteuert,

    dass alles, was man in beiden Input-Fields tippt, an Google u. Mozilla weitergeleitet wird?


    Tja, so wie es momentan ist, macht das extra Suchfeld eh keinen Sinn mehr.

    Aber ich kann mir auch nix mehr über view_source: ansehen ?(


    Hat jemand Hinweise dazu, wie ich die Adresszeile wieder ohne automatische Suchfunktion nutzen kann?


    Indirekt bin ich der Auslöser für diese Diskussion :(

    Bevor ich hier um Hilfe fragte, habe ich etl. Stunden recherchiert. U.a. auch hier im Forum. Den Zeilenabstand konnte ich alleine lösen. Dann schien mir, als ob ich hier mit meinen Fragen zu CSS-Code für Ordner u. Favicon "gut aufgehoben" wäre. Vielleicht sollte man die gelbe Infobox, die auf jeder Seite erscheint, anders formulieren?

    Vielen Dank nochmals für die prompte, unkomplizierte Hilfe, Andreas :thumbup:

    Ich meine, damit hast Du nicht nur mir geholfen, sondern auch vielen "stillen" Lesern eures Forums?


    PS: In einem meiner wenigen Foren klagten auch einige über Fx 89 (90) - Zeilenabstand der Bookmarks usw. Ich habe mein "Wissen" bzgl. Zeilenabstand gepostet: CSS-Code inkl. Anleitung u. hilfreicher Links. Denn ich behalte mein (geringes) Wissen nicht im stillen Kämmerchen für mich, sondern helfe auch gerne, wenn ich kann ...

    Auch bei mir erscheint diese Fehlermeldung. Allerdings nur, wenn Cookies deaktiviert sind und NoScript aktiviert ist (dabei nur nur Forenddomain, nicht agenedia.com). Ob uBlock on/off ist, macht keinen Unterschied. uMatrix nutze ich nicht.

    Die Fehlermeldung kommt wenige Sekunden nach dem Start, nach Wegklicken kann ich ein anderes Thema anklicken

    (kurze Einblendung von "undefined"), kann Thema öffnen. Dort taucht die Fehlermeldung wieder auf -> wieder

    wegklicken, manchmal reicht aber, das Thema 2x anzuklicken. Dieses Prozedere erfolgt bei jedem Themenwechsel bzw. Wechsel zu neuer Seite. Im Übrigen auf beiden PCs (beide FF v90.0.2).


    ABER: Wenn ich Javascript ganz deaktiviere, kann ich problemlos im Forum lesen. Natürlich mit eingeschränkter Funktion, aber zum Lesen reicht es meist. Wenn Cookies u. JS aktiviert sind, läuft alles wieder fehlerfrei.

    Ihr wisst ja, wie das Finden der Ursache funktioniert. Wie gesagt, normal ist das nicht, also liegt die Ursache dafür bei euch.

    Sorry, ich habe keine Erfahrung damit, evtl. hilft mein Versuch mit Browser Konsole :/

    Ich glaube, zu verstehen, was gemeint ist, denn auch ich hatte 2 Profile (unterschiedl. Ziffern):


    Standardprofil: xxxxxxx.default-release - je 1x als Wurzelordner (AppData/Roaming) u. Lokaler Ordner (AppData/Local)

    Profil 2: yyyyyyy.default - ebenfalls unter Roaming bzw. Local


    Keine Ahnung, warum es bei mir 2 Profile gab, aber das yyyyyyy.default Profil war sinnlos:

    Local ohne Inhalt, Roaming nur times.json ("FirstUse":null).

    Dieses Profil ist nun gelöscht.


    Zum besseren Verständnis: Unter Roaming legen alle Programme die Nutzerdaten ab. Unter Local hauptsächl temp. Daten.

    Ich sichere zwischendurch Maildaten u. FF-Profil - dazu kopiere ich die Daten aus Roaming.

    Details dazu kannst Du z.B. (Stand 26.7.2021) hier oder hier nachlesen.

    Du hast den Code von Aris getestet?

    Die Weltkugel hat damit ein neues Icons?

    Und alle Lesezeichenordner haben jeweils unterschiedliche Icons wie der TE es gerne möchte?

    Ich habe die 1,4MB entpackt, in userChrome.css

    Alle Ordner waren gelb, auch im Bibliothek Hauptfenster (nicht nur im Verzeichnisbaum).

    Die Kugel bleibt aber unverändert. Unter image habe ich globe.png (darin versteckt globe.svg) durch eine Grafik von mir ersetzt, Name ebenfalls globe.svg. Ohne Auswirkung.

    Dann noch stundenlang die css-files durchforstet, die @import "./css/tabS/missing_tab_favicon_restored_globe_v2.css"; eingefügt, weil dort u.a. steht:

    CSS
    #main-window .tabbrowser-tab[pinned] .tab-icon-image:not([src]),
    #main-window .tabbrowser-tab:not([pinned]) .tab-icon-image:not([src]) {
    list-style-image: url('./../../image/globe.svg') !important;
    }

    Klappte auch nicht, denn tabbrowser-tab wird wohl ein anderes Objekt sein. Ich meine ja die Kugel beim Aufklappen der Ordner von der Lesezeichensymbolleiste.Wie erwähnt: Ich durchschau nicht, welche CSS Benennungen von ID-, Klassennamen usw. sich auf welches Objekt beziehen.

    Bzw. weiß ich nicht, wo das defaulFavicon.svg überhaupt liegt, um das ggf. durch meine Grafik zu ersetzen.

    Zum besseren Verständnis, warum mich die Kugel so stört, hier ein Sreenshot:

    .


    Es sind kaum zugeordnete Favicons da, weil ich Bookmarks immer als html exportiere/importiere, um sie im Notfall auch auf anderen Systemen auslesen zu können. Mir war nicht bewusst, dass ich auch places.sqlite, favicons.sqlite mitspeichern muss . Ist mir bis jetzt noch nie aufgefallen. Alle Lesezeichen neu als Favorit speichern ist sinnlos!

    Eine Idee hatte ich schon: Vom alten PC die beiden sqlite -files eingespielt. Ich hatte deutlich mehr zugewiesene Favicons, was das Suchen viel übersichtlicher macht. Allerdings war der neue Ordner, wo ich Bookmarks, die ich auf neuem PC speichere, nicht mehr dabei. Denn kann ich aber auf alten PC kopieren, die paar Lesezeichen dort neu aktivieren und die beiden sqlite zurückspielen.

    Dann finde ich durch die Logos viele Bookmarks deutlich besser, es gäbe weniger defaultFavicons u. die plumpe Kugel stört weniger.


    So - dies mal ein erster Zwischenbericht :)

    Zu der Weltkugel, da hatte ich schon ein Thema verlinkt. (Icon in Urlbar)

    Wo bzw. bezieht sich das auf mich oder auf Herman4?

    Aber so wie ich nun all die vielen Beiträge durchflogen habe, scheint es nicht möglich, das defaultFavicon zu ändern?

    @ Andreas - Danke, auch das hat geklappt. Aber das ist schon alles sehr komplex, denn im Hauptfenster sind noch immer die Standardordner:


    Frage: lässt sich diese Weltkugel nun durch eine andere Grafik als defaultFavicon ersetzen oder nicht? Wenn ja, dann sind das wieder mehrere Regeln (also für browser, bookmarksSidebar, places ...).


    Aber ich freue mich schon, dass ich nimmer die (für mich) unhübschen Ordner ansehen muss :)

    Danke für die Hilfe (kostet ja alles Zeit) :thumbup:

    Meinst du den?

    Genau! Vielen Dank :) Für die Sidebar habe ich auch was hier im Forum gefunden. Zum Spaß mit anderem Icon getestet:


    ett wäre, wenn sich auch die Ordner in der Bibliothek ändern liesen. Wenn ja, wie?


    Anleitungen zum Ordnersymbol findest du fix und fertig bei Aris in der Sammlung

    GitHub - Aris-t2/CustomCSSforFx: Custom CSS tweaks for Firefox 57++

    Muss man nicht neu erfinden. (bookmark_icons_colorized.css)

    Diese Sammlung habe ich schon gestern gefunden, aber nicht durchschaut. Ohne Deinen Hinweis hätte ich diese css nie gefunden. Aber auch die ist mir zu kompliziert, ich kann die Elemente nicht zuordnen (also welches wofür steht).


    Das mit der Weltkugel verstehe ich schon. Aber ich hätte lieber ein anderes defaultFavicon bei den Lesezeichen, nicht in der Urlbar.

    Mein erster Beitrag hier im Forum - Hallo an euch alle :)

    Ich nutze das FF Standard Theme.

    Problem 1 (großer Zeilenabstand zw. Lesezeichen-Dropdown) ist gelöst: Im Profilordner den Ordner chrome mit userChrome.css erstellt:

    CSS
    /* Tighten up drop-down/context/popup menu spacing */
    
    menupopup > menuitem, menupopup > menu {
    padding-block: 1px !important;
    }
    :root {
    --arrowpanel-menuitem-padding: 4px 8px !important;
    }

    Das passt nun :)


    Aber bei Problem 2 (Ordnersymbol ändern) und Problem 3 (Weltkugel bei Lesezeichen ändern) bitte ich um Hilfe.

    Ich möchte den bekannten, liegenden Win-Ordner (geöffnet). Ich finde ich ihn weder bei Win10 noch bei Win7 - habe aber nicht alle dll durchsucht.

    Wo finde ich diesen Ordner, welches Format (png, ico, svg) braucht es, welche Größe?

    Eine Grafik habe ich gefunden, ist zwar was anderes, aber soll mir auch recht sein:


    Unterordner chrome/icons ist auch angelegt. Grundkenntnisse zu CSS2 hatte ich mal, aber schon lange her ...

    Zu Mozilla CSS habe ich zumind. eine Referenz gefunden, doch bis ich das durchblicke :)


    Wäre super, wenn mir jemand den CSS-Code posten könnte: Für Ordnersymbol ändern und für Lesezeichensymbol ändern. :whistling:

    Evtl. werde ich @import nutzen, mal sehen. Denn viel mehr am Layout will ich eigentl. nicht ändern. Obwohl: Zum Testen ist es einfacher.