Fenster öffnet sich zu klein.

  • Hallo,


    ich habe ein kleines Problem. Auf einer Seite, wo sich beim klicken auf ein Button ein Chatfenster öffnen soll, öffnet sich auch ein neues Fenster, dass aber leider von der grösse viel zu schmal ist, um überhaupt das Chatprogramm was drin ist, darzustellen. das heißt ich kann ca. nur die Hälfte sehen, von dem, was geschrieben wird. Leider gibts auch gleichzeitig keine Scrollbars oder eine Möglichkeit das Fenster an das Programm im Inneren anzupassen. Strg + oder - verändert auch nichts. Das Fenster scheint für mich ziemlich unveränderbar zu sein. Was kann man da tun?


    Danke im Voraus. Super Support hier.

  • hallo erstmal!


    wie meinst du das? wenn man ein fenster öffnet und mit strg+ bzw strg- rumspielt, dann verändert man ja nur die 'auflösung' im fenster, egal ob es 800*600 pixel oder blub*blubber pixel ist.
    die größe des fensterrahmens ist ja unabhängig von deiner auflösung.
    heißt das, dass du das fenster nicht größer ziehen kannst wenn du es in der unteren rechten ecke anklickst und ziehst?
    was geschieht wenn du mit rechtsklick auf den oberen (blauen) rahmen klickst und 'maximieren' auswählst?



    ...nur ein paar unqualifizierte fragen...
    mfg...

  • Hi ollux[!],


    Wahrscheinlich ist das Chatfenster ein per JavaScript geöffnetes Fenster, bei dem die Möglichkeit des Vergrößerns bzw. Scrollens per Code der Seite unterbunden wird - zumindest versucht man es.


    Hierbei hilft dir dies workaround: man kann auch dann, wenn JavaScript gesteuerte Fenster dies zu unterbinden versuchen, durch bestimmte (verborgene) Einstellungen dafür sorgen, dass man zumindest die Größe solcher Popups ändern kann, also solche Fenster mit der Maus aufziehen kann. Es gibt in diesem Zusammenhang mehrere dieser Einstellungen. Erläuterungen dazu findest du im Firefox-Wiki under about:config (Einstellungen) (Link) (diese sind aber unvollständig dokumentiert, die englischsprachiche Seite http://kb.mozillazine.org/About:config_entries ist vollständiger). In diesem Zusammenhan interessant sind die Einstellungen dom.disable_window_open_feature.*


    Für diese spezielle Problem sollte die Einstellung dom.disable_window_open_feature.resizable auf true gesetzt werden. Das kann man entweder in about:config (Link) oder aber durch setzen dieser Einstellung in der Datei "user.js" (Link). Dort müsste man folgende Zeile einsetzen:

    Code
    user_pref("dom.disable_window_open_feature.resizable", true);


    Wenn Fragen offen bleiben oder Probleme auftauchen, melde dich wieder hier.


    Zitat von <woltlab-metacode-marker data-name=

    Pumbaa80 (Link)" data-link="">

    ...und für Otto-ich-trau-mich-nicht-an-die-about:config-Normalanwender gibt es zu diesem Zweck die Erweiterungen JavaScript Options und Controle de Scripts. :klasse:


    Have fun,
    NightHawk

  • uiuiui nighthawk,
    da hast du mich aber geflasht!
    aber du hast natürlich mehr erfahrungen und ideen wie ich...
    und 'ein paar' mehr beiträge..
    lg vom sturmvogel