Beiträge von black10

    2002Andreas



    Dein Code funktioniert leider nicht (richtig).

    Der Scrollbalken bleibt, egal was ich in Zeile 12 auch verändere. ZUdem habe ich über der Adressleiste jetzt plötzlich noch ne Tableiste die ich vorher nicht hatte...siehe Photo.


    Im übrigen nutze ich nicht das Skript "CustomScrollbars" von Aris...!



    Krieg das nicht so richtig hin mit dem Quellcode..


    Auf jeden Fall ist das dort meine alte UserChrome.Css

    Hallo,


    Nach Update auf Version 107.0 wurde aus meiner seit Ewigkeiten bestehenden 2-zeiligen Lesezeichen-Symbolleiste plötzlich eine 3-zeilige..obwohl ich keine weiteren Favoriten zusätzlich ablegte.

    Außerdem erschien (siehe Photo) ein blauer Scrollbalken rechts neben der Leiste.


    Wie bekomme ich die 27 Favoriten/Symbole wie vorher auch auf nur 2 Zeilen ( und ohne Scrollbalken) verteilt hin...?

    Hallo,


    Unter Einstellungen - Datenschutz+Sicherheit - Chronik - nach benutzerdefinierten Einstellungen anlegen gab es (irgendwann mal noch) bei dem Punkt "Die Chronik löschen, wenn Firefox geschlossen wird" den Passus "Einstellungen".


    Dort konnte man explizit z.b. Aktive Log-ins, Cookies, Cache, Suchbegriffe+Formulardaten, Besuchte Seiten+Download-Chronik EINZELN aus/abwählen.

    Den Passus "Einstellungen" gibt es (jetzt) dort nicht mehr.

    Ja, ich kann unter dem Punkt "Cookies+Website-Daten" nen Haken reinsetzen, aber wie kann ich den Rest (vor allem den Cache) s.o. auswählen..?

    Ich hab jetzt rausgefunden was in der userChrome.css stört.


    Dort ist


    CSS
     #personal-bookmarks,
        #PlacesToolbar,
        #PlacesToolbar > hbox {
            display: block !important;
        }


    eingetragen....



    Lösche ich dies, erscheint die Seite mit dem Überhangmenü/Anpassen Symbolleiste völlig normal.

    Aber...merkwürdigerweise habe ich DANN nur noch eine einzeilige Lesezeichensymbolleiste.

    Die üblicherweise 2. Leiste kann ich dann nur mit einem kurzen Scollbalken oben rechts anvisieren... 8|


    Heißt, ich hab scheinbar nur die Möglichkeit entweder/oder.

    Nur ne einzeilige Lesezeichenleiste und dafür ne komplette Anzeige des Überhangmenüs, oder ne fehlerhafte Anzeige und dafür meine 2zeilige Lesezeichenleiste... :?:

    Ja, die Tableiste "hasse" ich. Die brauche ich absolut nicht.

    Um ehrlich zu sein, vieles was da drin steht ist schon längere Zeit "einfach so da".


    Wichtig für mich


    - Mehrzeilige Lesezeichensymbolleiste

    - keine Tableiste (!)

    - vor/zurück Button mit blauem Pfeil

    - bestimmte Abstände im drop-down Menü.



    Ich habe herausgefunden das man die Symbolleiste ja auch im Fehlerbehebungsmodus, also ohne Chrome/AddOns, anpassen kann.

    Und diese Anpassungen bleiben auch beim Start mit Chrome/AddOns aktiviert. Von daher...

    Also ohne den Chrome Ordner funktioniert alles einwandfrei, sprich das Anpassen der Symbolleiste/Überhangmenü ist problemlos möglich.


    Also muß es etwas mit (Chrome) userChrome.css zu tun haben.


    Hier der Inhalt der userChrome.css


    Hallo,


    Beim Versuch die Symbolleiste anzupassen stolpere ich immer über diese merkwürdige Darstellung unter "weitere Werkzeuge - Symbolleiste anpassen".

    Mein Bild sieht permanent so aus wie in Bild 1.

    Im Normalfall, den kenne ich nur vom Hörensagen...soll es ja so aussehen wie wie unter Bild 2.



    Wie bekomme ich eine normale Darstellung..?

    Ja, ich hab ne andere noch dunklere Blau-Farbe genommen.


    Auch die Rundungen des Scrollbalkens in deinem Skript hab ich rausgenommen.

    Und auch die Farbänderung (rot) beim draufklicken auf den Balken hab ich in diesen Blauton ändern können.

    Nicht zu glauben, jetzt hats endlich funktioniert.


    Kopiere die Datei in ein anderes Verzeichnis (z.B. unter Eigene Dateien), nimm dann die Änderungen vor und kopiere die Datei wieder an den Ursprungsort zurück. Gegebenenfalls wird Windows vor dem Einfügen das Administrator-Kennwort verlangen.


    Nur so ging es...!


    Ein "normales" abspeichern der Änderung hat nie funktioniert. Mit dem kopieren in ein anderes Verzeichnis und wieder zurück ging es endlich.

    Das hat Nerven gekostet...


    Danke für die Tipps :thumbup:

    milupo


    Wenn ich über Datei - Speichern gehe springt er dann automatisch wieder in das Fenster mit "Speichern unter"...!


    Wenn ich z.b. in der scrollbar.uc.js etwas ändere und über das Kreuz rechts oben einfach schließe...ist das automatisch gespeichert.

    Nein, sieht so aus





    Ich verstehe nicht wieso nach dem hineinkopieren des neuen Skripts und schließen der Datei über Kreuz überhaupt ein Fenster erscheint mit der Abfrage wohin ich die utilitie.js abspeichern will ??? (Photo)




    "Natürlich" kommt dann die Info das die Datei bereits existiert, aber eine Ersetzung der alten Datei durch die Neue wird halt quittiert mit....


    Sorry, es muss in Zeile 51und 61 rein.


    Hab ich jetzt erst gesehen...und geändert


    Skript sieht jetzt so aus


    Hat allerdings auch nichts geändert....


    Dann kann es doch eigentlich nur an den fehlenden Anpassung für die Nutzung von Scripten in Fx92 liegen.


    Vielleicht kann man mir noch mal bei meinem Problem in Beitrag 74 beschrieben helfen.

    Ich kann die Änderung der utilities.js nicht abspeichern...!

    Also, jetzt werd ich so langsam verrückt.


    Nach dem Hinweis

    Du hast mit Sicherheit diese Anpassung für die Nutzung von Scripten in Fx92 nicht gemacht..


    #1

    wollte ich dies dann nachholen.



    Also die userChromeJS aufgerufen, utilities.js bearbeitet und den neuen Skript der utilities.js einkopiert.


    Nachdem ich dann die utilities.js wieder schließen und eigentlich speichern wollte, erschien ein Fenster (Photo) mit "Speichern unter"....

    Nachdem ich dann das vorgegebene Speichern unter "utilities.js" mit OK bestätigte erschien der Hinweis das die datei bereits existiere. Ob ich denn ersetzen möchte..?

    Ja, will ich...dann erschien ein Fenster (Photo) das ich keine Berechtigung zum öffnen der Datei besitze...


    Wie speichere ich bitte den neu eingepflegten Skript der utilities.js ab...???