Beiträge von klickman

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.


    Hast du hier auch den Haken entfernt?

    Ja. Bei jeder Option die annährend dafür verantwortlich sein könnte, sind die Häkchen entfernt.



    [attachment=3]Bildschirmfoto 2018-12-15 um 22.26.10.jpg[/attachment]




    [attachment=2]Bildschirmfoto 2018-12-15 um 22.26.36.jpg[/attachment]




    [attachment=1]Bildschirmfoto 2018-12-15 um 22.26.47.jpg[/attachment]




    [attachment=0]Bildschirmfoto 2018-12-15 um 22.27.04.jpg[/attachment]

    Selbst im privaten Modus und mit gelöschter Chronik erscheint das hier:



    [attachment=1]Bildschirmfoto 2018-12-15 um 21.44.30.jpg[/attachment]



    Ich hab das mit einem neuen Profil getestet, weil diese "Suchvorschläge" (oder was das auch immer ist) in meinem "Arbeitsprofil" erst seit FF65 Beta aufgetreten sind - obwohl ich die gesamte Chronik standardmäßig beim Schließen des Browsers löschen lasse und auch das hier eingestellt ist:



    [attachment=0]Bildschirmfoto 2018-12-15 um 21.51.58.jpg[/attachment]



    Sollte so nicht sein.

    Doch noch Scripte zum Laufen bekommen...
    Ich habe im neuen Profil lediglich CSS-Code eingefügt, der mir die Tableiste unter Lesezeichen- und Toolbar legt, sowie dein Script aus #4 und die userChrome.js, die für die Ausführung von Scripten nötig ist. Leider kein Erfolg. Die Konsole zeigt:


    Neuen Versuch gestartet, indem ich die Meldungen in der Konsole gelöscht und FF neu gestartet habe. Die erscheinenden Meldungen in der Konsole scheinen einen Hinweis auf dein Script zu enthalten. Hilft dir das? Drittletzte Zeile:
    "ReferenceError: gBrowser is not defined[Weitere Informationen] TabFocus.uc.js:6:7"


    Verzeih, hatte das nicht mehr in Erinnerung.
    In der Konsole stehen einige Einträge. Die Mehrzahl allerdings Twitter und dessen Skripte betreffend, da ich uMatrix verwende. Habe selbst zwar keinen Twitteraccount, wollte aber einige Tweets lesen. Habe die Twittereinträge gelöscht, da sie sehr wahrscheinlich nicht maßgeblich sind.
    Wenn ich irgendwelche Aktionen durchführen soll um ein aussagekräftiges Ergebnis in der Konsole zu bekommen, bitte einfach sagen.


    Hier das Resutat:


    Die ich mit cmd+alt+K am Mac aufrufe? Jede Menge, allerdings hauptsächlich Youtube betreffend. Also habe ich das Fenster mit den Meldungen geleert, den Browser neu gestartet, Tabs geöffnet und folgendes Ergebnis erhalten [sofern ich das vom korrekten Reiter ("Konsole") gelesen habe]:


    Code
    Content Security Policy: 'x-frame-options' wird wegen 'frame-ancestors'-Direktive ignoriert.



    EDIT: Noch einen neuen Tab geöffnet und folgendes Ergebnis erhalten:


    [attachment=0]Bildschirmfoto 2018-12-14 um 23.06.47.jpg[/attachment]

    Hallo Ihr hilfreichen Kollegen,


    seit FF65 Beta will das genannte Script nicht mehr so wie es sollte, alle anderen funktionieren nach wie vor. Ich habe es schon lange in Verwendung und irgendwann (leider weiß ich icht mehr für welche FF-Version) war #aborix so nett und hat es angepasst. Das Script sieht nun jedenfalls so aus:


    HideTabbarWithOneTab-FixSkriptAborix.uc.js:


    Wenn nun nur ein Tab geöffnet ist, wird zwar die eigentliche Tableiste ausgeblendet, doch es bleibt ein sichtbarer Abstand in Höhe der Tableiste bestehen. Dass die Tableiste eigentlich korrekt ausgeblendet wird erkenne ich daran, weil ich sie mittels CSS-Code hellblau eingefärbt habe. Der sichtbar verbleibende Abstand trägt jedoch die Farbe Grau. Das sieht so aus:


    Mehrere Tabs:
    [attachment=1]Bildschirmfoto 2018-12-14 um 11.37.17.jpg[/attachment]



    Ausgeblendete Tableiste, doch grauer Abstand:
    [attachment=0]Bildschirmfoto 2018-12-14 um 11.37.44.jpg[/attachment]



    Weiß jemand was zu tun ist, um die Tableiste bei nur einem Tab wieder ohne "Rückstände" auszublenden?


    Danke!


    den Reiter-Hintergrund werde ich vielleicht selbst lösen (googeln oder mein html-wissen erweitern

    Ohne jetzt genau nachgelesen zu haben, was du genau verändern möchtest, hier der Inhalt meiner "custom_tab_color_settings.css", mit der alle möglichen Farben von allen möglichen Arten von Tabs verändert werden können, entnommen von hier: https://github.com/aris-t2/customcssforfx
    Vielleicht hilft dir das eine oder andere Codeschnippsel weiter. Farben kannst du individuell anpassen.
    Empfehle dir auch, die komplette "customcssforfx"-Geschichte anzusehen. Damit kannst du extrem vieles am Aussehen des FF manipulieren.


    macko:
    Sensationell, vielen Dank für deine Mühe! :klasse:
    Eine unverschämte Bitte habe ich. Und zwar sind in der folgenden URL alle Parameter so eingestellt, wie sie Startpage nutzen sollte:

    Code
    https://www.startpage.com/do/mypage.pl?prfh=suggestionsEEE0N1Ngeo_mapEEE1N1Nwikipedia_iaEEE1N1Nother_iaEEE0N1Ndisable_open_in_new_windowEEE0N1Ndisable_video_family_filterEEE0N1Nenable_post_methodEEE1N1Nenable_proxy_safety_suggestEEE1N1NsslEEE1N1Nlanguage_uiEEEdeutschN1NlanguageEEEdeutschN1Nwt_unitEEEcelsiusN1Nnum_of_resultsEEE20N1Nlang_homepageEEEs/dawn/de/


    Wo muss ich nun z. B. auf mycroftproject.com was eingeben, damit ich das entsprechende Suchplugin mit diesen Parametern erstellen kann?


    EDIT:
    Sorry, hier noch die codierte URL:

    Code
    https://www.startpage.com/do/mypage.pl?prfe=67d6f7efcd45238dc5da976ba89cf2c11aad15df09559e99290124a24ab07d5fca28d15736b2628f984abfd0db70840b

    Zitronella:
    Mittels Cookie ist das sowieso möglich. Nur lasse ich 1. sämtliche chronikrelevanten Daten beim Beenden von Firefox löschen und 2. hab ich das Add-on "Vergiss Mein Nicht" installiert, das den Rest eliminiert. Ausnahmen bekomme ich nicht hin, das gespeicherte Cookie ist trotz erstelllen einer Ausnahme in den FF-Einstellungen, und trotz einer erstellten Regel in "Vergiss Mein Nicht" nach Neustart des Browsers weg.
    Möglicherweise sind auch meine weiteren Enstellungen kontraproduktiv:

    Code
    user_pref("browser.cache.disk.enable", false);
    user_pref("browser.cache.disk_cache_ssl", false);
    user_pref("browser.cache.offline.enable", false)


    Ob sich diese auch auf Cookies auswirken, keine Ahnung. Müsste ich erst austesten.


    EDIT: Um auf deine Frage einzugehen: Seinerzeit war kein Cookie nötig. Da wurde der Link, der nach Anpassung der Einstellungen angeboten wurde, als Suchmaschine gesetzt. Genau das klappt nun nicht mehr. Man kann den Link nur mehr als Startseite oder als Lesezeichen verwenden