Beiträge von Pucky

    Man kann sich die Unterschiede mit dem uBlock Origin Logger ansehen.


    In meinem Fall habe ich es mit Debian Stable und Firefox 104(von Mozilla) und Chromium(104.0.5112.101-1~deb11u1) gemacht.

    Firefox hat dort drei andere und weniger Sachen geladen, als Chromium. Das was gleich geladen wurde habe ich schon aus der Liste entfernt. Mit einem neuen Profil und Firefox 104 sieht die Seite bei mir ebenfalls wie rechts auf dem zweiten Bildschirmfoto aus.


    Firefox 104

    Code
    11:47:09www.mms.telekom.de1imagehttps://www.mms.telekom.de/OTP/images/de/fullLogin.png
    11:47:08www.mms.telekom.de1scripthttps://www.mms.telekom.de/OTP/scripts/otp.js
    11:47:08www.mms.telekom.de1imagehttps://www.mms.telekom.de/OTP/images/down.gif


    Chromium(104.0.5112.101-1~deb11u1)

    Das Live Ubuntu vom USB-Stick hat ja nur Firefox Snap dabei. Damit passiert es auch.


    Die Profile liegen halt überall unterschiedlich, das ist klar. Auch weiß ich, dass Snap echt übel sein kann, falls man die aktuell installierte Version entfernt und gegen eine andere Firefox Version austauscht, wird gleich der .mozilla Ordner im Snap-Ordner mit entfernt.


    Wenn man sich dann doch wieder zum Beispiel die Firefox ESR Snap Version installiert, dann schnappt sich Snap den ggf. alten in Home befindlichen .mozilla Ordner und man wundert sich, warum nichts mehr aktuell ist.

    Für mich sind das komische Dinge, die Snap macht.


    Ich habe einen Fehlerbericht bei bugzilla gemacht, mal sehen was daraus wird.

    Ich habe noch ein weiteres Bildschirmfoto hinzugefügt.


    Ich importiere sie per Lesezeichenmanager über die Option Wiederherstellen und wähle die entsprechen Lesezeichen.json aus. Der Profil-Ordner -mozilla wurde immer zum testen neu angelegt.


    Die Bilder zeigen die Fenster, die sich innerhalb von Sekunden geöffnet haben, nachdem die Lesezeichen importiert wurden. In den kleinen Fenstern sind die URLs von manchen Webseiten, wie Sparkasse zu sehen. Was die Fenster genau bedeuten, weiß ich nicht.


    Der Firefox lässt sich bedienen und auch schließen, allerdings bekomme ich diese Fenster im geöffneten Zustand nur weg, wenn ich sie in der richtigen Reihenfolge schließe.

    Weil das alles offline passierte, wurde nichts aufgerufen. Beim aufrufen mit dem Terminal konnte ich nichts auffälliges finden, die Logs von Ubuntu zeigen aber einige Einträge, die ich mir noch genauer ansehen müsste.


    Das läuft alles in der Flatpak oder Snap Snadbox ab. Ich glaube nicht, dass es so gut ist, dies ohne auszuprobieren. Deswegen, werde ich es vorerst nicht mit dem Firefox von Mozilla ausprobieren.


    *Edit*

    Mit einem Ubuntu Live USB Stick habe ich es versucht. Mit dem Firefox 103.0.2 von Mozilla passiert es nicht. Also vielleicht doch eher ein Problem welches Flatpak und/oder Snap betrifft.


    Nur warum tritt es nicht auf, wenn ich vor dem exportieren die favicons.sqlite bei dem .mozilla Profil lösche, bei dem die Lesezeichen das Problem mit den Fenstern verursachen?

    Nachdem ich zum testen den Firefox 103.0.2 Snap und Firefox 103.0.2 Flatpak Browser in Ubuntu 22.04 am 9.8.22 auf nur noch ein Adblock-Addon umgestellt habe und JS aktiviert gelassen habe, habe ich nun das erste Problem festgestellt und beschreibe es kurz. Es tritt auch mit Debian Stable(Flatpak Firefox 103.0.2) auf.


    Ich speicher die Lesezeichen als .json ab. Danach spiele ich sie in ein neu angelegtes Profil ein. Nun öffnen sich unzählige Fenster, in denen URLs stehen.


    Ein Lesezeichen Backup vom 12.8.22 zeigt dieses Verhalten noch nicht. Wenn ich vor dem Export der Lesezeichen, die dieses Verhalten zeigen, die favicons.sqlite lösche, dann passierte es nicht, dass sich diese Fenster beim einspielen der Lesezeichen alle öffnen. Es waren etwa 20-30 Fenster.


    Ich hatte beim Suchen das gefunden.

    Zitat

    Mozilla veröffentlicht Firefox 103

    ...
    Beim Importieren von JSON Lesezeichen-Backups werden jetzt auch die Favicons importiert.

    Quelle

    Darf ich hier im Forum Bildschirmfotos einfügen, die auf einem Hoster hochgeladen wurden? Vielleicht hat noch jemand dieses Verhalten festgestellt.

    Danke für die Erklärung und den Tipp.


    Ich werde dann testweise den Browser mit nur einem AdBlock Addon und wenigen Anpassungen verwenden. Mit uBlock Origin und NoScript hatte ich ein paar Probleme, die bei mir ein paar Fragezeichen hinterlassen haben. Ich werde jetzt nicht genauer darauf eingehen.


    Wie sieht es denn bei euch aus, gab es ein paar Probleme oder irgendwelche Auffälligkeiten mit manchen Addons?

    Der Firefox verwendet mit der strengen Aktivitätenverfolgung den "Do Not Track" Mechanismus, dass dieser auch funktionieren kann, kann man z.B. an geizhals.de sehen.


    Dort wird mir dann folgendes angezeigt.

    Zitat

    "Do not Track"-Modus erkannt! Es werden nur technisch notwendige Cookies verwendet.

    Quelle


    Mit den Addons kann man sich sicherlich auch weitere Lücken aufmachen.

    In uBlock Origin gab es einmal zum Beispiel solche Lücken, die für mich doch recht kritisch aussehen.


    Zitat

    Version 1.39.0

    Veröffentlicht 22. Nov. 2021 – 2,79 MB

    ....
    [discovered by @hackvertor] Security: Smuggle arbitrary CSS inside cosmetic uBlock filters

    [discovered by @hackvertor] Security: JavaScript URL injection allowed in query string parameter and redirection to uBlock origin urls

    Quelle

    Mein Samsung Galaxy A52 zeigt dieses Verhalten mit der ab Werk installierten Samsung Tastatur und dem Gboard nicht. Firefox Klar und Firefox für Android laufen ohne das beschriebene Verhalten. Vielleicht ist das eher ein Fehler der in einer neueren Android Version behoben wurde.


    Hier habe ich eine Fall gefunden, bei dem sich auch die Tastatur ausgeblendet hat, aber nicht speziell auf den Browser bezogen.


    Verschwindet die Tastatur auch bei anderen Apps?

    Wenn in uBlock Origin die AdGuard Filterlisten aktiviert sind, dann bekomme ich in der Firefox-Konsole(STRG+UMSCHALT+J) immer eine Meldung die ich nicht einordnen kann, wenn ich login.mailbox.org aufrufe. Vielleicht kann das jemand von euch.


    Damit diese Meldung nicht mehr erscheint, reicht ein Zurücksetzten der Einstellungen in uBlock Origin nicht aus. In about:support muss "Refresh Firefox..." ausgeführt werden oder die prefs.js muss gelöscht werden. Mit den aktuellen Einstellungen aus uBlock Origin klappt es dann ohne diese Meldung.


    Die Seite auf dem ersten Bild wurde wahrscheinlich als Lesezeichen gespeichert. Man erkennt darunter nur Vorschläge, diese Vorschläge könnten soweit ich das sehe auch (nur) aus den Lesezeichen stammen oder?


    Auf dem zweiten Bild sieht man gut ein blaues Sternchen. Schlägt "Firefox-Vorschläge" nur vorhandene Favoriten vor und die Vorschläge die per Suchmaschine vorgeschlagen werden, werden immer per "Lupen-Symbol" gekennzeichnet?


    Demnach könnte dann, das was ihn(unter Firefox-Vorschläge) verunsichert aus den eigenen Lesezeichen stammen?


    Ich habe ein ganz neues Profil angelegt und dort den Begriff "hard...." eingegeben und das jeweils für die im Firefox gespeicherten Suchmaschinen, es war alles harmlos was angezeigt wurde. Google zeigte keine Ergebnisse an und Ecosia nur harmlose Ergebnisse.


    Zur Aufklärung kann denke ich nur der Fragesteller beitragen. ;)

    Ich hatte schon einen Fehlerbeschreibung bei webcompat.com gemacht. Ich habe das, nachdem ich mich bei bugzilla.mozilla.org registriert habe, darüber gefunden. Später habe ich dann noch eine Fehlerbeschreibung bei bugzilla gemacht. In der Zwischenzeit hat sich die Fehlermeldung von Firefox in Fedora 36 und in /home ausgeführt auch noch etwas verändert.

    bugzilla.mozilla.org

    github.com


    Mal sehen, was daraus wird. Danke für die Antworten und Hilfe!

    Jetzt mal doof gefragt - aber Videos kannst du dennoch schauen? zB Youtube?

    Wird problemlos auf youtube abgespielt.

    Ich würde empfehlen, ein eigenes Ticket auf Bugzilla zu erstellen und mal zu schauen, was die Entwickler von Firefox dazu zu sagen haben.

    Kann man den Fehler auch per webcompat.com melden? Bisher habe ich den Fehler nur auf Youtube gesehen.

    Sonst werde ich noch versuchen einen Bugreport auf bugzilla.mozilla.org zu schreiben.

    Ich habe eine Frage zu einer Fehlermeldung, die erscheint, wenn ich den Firefox mit dem Terminal starte bzw. das Terminal anzeigen lasse und youtube.com aufrufe.


    Der Fehler "ERROR mp4parse" tritt unter allen drei Distributionen und dem Firefox von Mozilla "firefox-100.0.2.tar.bz2" auf. Es wird Gnome Wayland verwendet und Firefox wird nativ unter Wayland gestartet(about:support / Window-Protokoll wayland). Der Fehler tritt mit Firefox Snap, Firefox Flatpak, Firefox(aus dem Repo von Fedora) auf.


    Der Fehler "resource creation failed" tritt unter Fedora auf und vor ein paar Wochen auch mal unter Ubuntu auf.


    Code
    Unsupported modifier, resource creation failed.
    XXX: resource creation failed
    Unsupported modifier, resource creation failed.
    XXX: resource creation failed
    Unsupported modifier, resource creation failed.
    XXX: resource creation failed
    [2022-05-26T09:36:51Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
    [2022-05-26T09:36:51Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
    [2022-05-26T09:36:51Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
    [2022-05-26T09:36:53Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"


    Youtube verwendet laut laut den "Statistiken für Interessierte" die folgenden Codecs.


    Code
    Codecs
    vp09.00.51.08.01.01.01.01.00 (247) / opus (251)


    Die Meldung mit "ERROR mp4parse" erscheint nicht mehr, wenn in der about:config "media.mp4.enabled" auf "false" gestellt wird.


    Kann mit jemand sagen, was diese Fehlermeldungen bedeuten?

    Moinsen,


    seit etwa 1 Woche, vielleicht auch schon länger, habe ich deutliche Performance Probleme, sobald im Browser mehrere Videos auf Youtube geöffnet sind oder ich z.B. einen Stream auf Twitch schaue und nebenher noch etwas anderes mache


    Es könnte vielleicht an mp4 liegen. Hier hat der Firefox mit Debian(Flatpak), Ubuntu(Snap), sowie der Firefox 100.0.2 von Mozilla und direkt in /home ausgeführt, ein paar Probleme damit, wenn Youtube aufgerufen wird.


    Du könntest testen, ob es daran liegt. In die Adresszeile about:config eingeben und nach "media.mp4.enabled" suchen, den Wert von "true" auf "false" stellen.