Nightly 58 aktuell Font-Problem?

Hier geht es um Betas, Nightlies und alle anderen nicht offiziellen Releases.
Antworten
Benutzeravatar
HT-Frogger
Mitglied
Beiträge: 474
Registriert: Mo, 18. Jan 2016 22:14
Wohnort: Hamburg

Nightly 58 aktuell Font-Problem?

#1

Beitrag von HT-Frogger Themen-Starter » Fr, 10. Nov 2017 21:52

Ich habe gerade ein neues Nightly-Problem entdeckt. Webseite: http://www.hamburg-termine.de/show-text.php?id=00000390 aber auch noch einige andere Seiten von dieser Domain, aber nicht alle. Bei anderen Domains ist es mir noch nicht aufgefallen.

Links im Bild FF 57 Beta (56 ist auch so), rechts FF 58 Nightly (ist auch im abgesicherten Mode so). Beides Portabel-Versionen unter Linux, beide die gleichen Addons und die gleichen userChrome.css und user Content.css und gleiche Scripte. Aber die wirken ja im abgesicherten Mode ohnehin nicht.
Screenshot_20171110_213821.png
Hat jemand eine Idee? Soll ich noch was besonderes testen?

Gruß Harry
FF aktuell/beta/nightly, 64Bit, Linux, openSUSE Leap mit KDE

Lurtz
Mitglied
Beiträge: 366
Registriert: Sa, 14. Nov 2015 15:33

Re: Nightly 58 aktuell Font-Problem?

#2

Beitrag von Lurtz » Fr, 10. Nov 2017 21:54


Benutzeravatar
AngelOfDarkness
Senior-Mitglied
Beiträge: 15361
Registriert: Di, 20. Jul 2004 20:01
Wohnort: Menden

Re: Nightly 58 aktuell Font-Problem?

#3

Beitrag von AngelOfDarkness » Fr, 10. Nov 2017 21:57

Also hier unter Windows 10 und Firefox Version 58.0a1 Build-ID 20171110100139 keine Probleme.
Erweiterungen und Scripte und Codes siehe Signatur.
„Mutter ist der Name für Gott, auf den Lippen und in den Herzen aller Kinder dieser Welt.“ (The Crow)

verwendete Browser und Erweiterungen - Sicherheitskonzept für Windowsnutzer

Benutzeravatar
milupo
Senior-Mitglied
Beiträge: 3766
Registriert: Fr, 27. Okt 2006 22:25

Re: Nightly 58 aktuell Font-Problem?

#4

Beitrag von milupo » Fr, 10. Nov 2017 22:45

Laut Bug betrifft das nur Linux.

In Fx 58 wurde der Wert der Einstellung security.sandbox.content.level sogar noch auf 4 erhöht. Setze den Wert in about:config auf 1.
Übersetzer für Obersorbisch und Niedersorbisch auf mozilla.locamotion.org und pontoon.mozilla.org, u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django und LibreOffice

Benutzeravatar
AngelOfDarkness
Senior-Mitglied
Beiträge: 15361
Registriert: Di, 20. Jul 2004 20:01
Wohnort: Menden

Re: Nightly 58 aktuell Font-Problem?

#5

Beitrag von AngelOfDarkness » Fr, 10. Nov 2017 22:48

Jepp, habe ich nachdem ich meinen Beitrag geschrieben habe auch gesehen .. also den vorher bereits genannten Link zum Bug :oops:
„Mutter ist der Name für Gott, auf den Lippen und in den Herzen aller Kinder dieser Welt.“ (The Crow)

verwendete Browser und Erweiterungen - Sicherheitskonzept für Windowsnutzer

Benutzeravatar
Sören Hentzschel
Administrator
Beiträge: 15862
Registriert: Mi, 23. Nov 2011 0:39
Wohnort: Salzburg
Kontaktdaten:

Re: Nightly 58 aktuell Font-Problem?

#6

Beitrag von Sören Hentzschel » Fr, 10. Nov 2017 22:50

Nur auf Windows ist der Level in der Nightly-Version auf 4, auf macOS und Linux noch auf 3. Aber bitte erst Level 2 testen, bevor Level 1 eingestellt wird. Den Sandbox-Level zu verstellen, weil es aufgrund von Problemen notwendig ist, ist okay, nur betrifft das eben auch die Sicherheit und da sollte man das Maximale nehmen, was möglich ist. Oder noch besser: schlafen gehen und gar nichts ändern. Der verursachende Patch wurde bereits zurückgenommen, im nächsten Nightly Build ist also alles wieder in Ordnung.

Benutzeravatar
HT-Frogger
Mitglied
Beiträge: 474
Registriert: Mo, 18. Jan 2016 22:14
Wohnort: Hamburg

Re: Nightly 58 aktuell Font-Problem?

#7

Beitrag von HT-Frogger Themen-Starter » Fr, 10. Nov 2017 22:57

Mein Englisch ist nicht so gut. Ich lese da was von in pre- und code- Elementen? Das ist aber hier nicht der Fall...

Folgendes habe ich getestet:
1. Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten NICHT erlauben
2. Zusätzlich andere Schriftarten eingestellt
3. Den Wert security.sandbox.content.level testweise auf 1 und auf 2 eingestellt (default: 3)

Ergebnis: Es bringt nichts...
Warten wir die Zukunft ab, ich beobachte das weiter.

Gruß Harry

Alles klar, danke Sören!
FF aktuell/beta/nightly, 64Bit, Linux, openSUSE Leap mit KDE

Benutzeravatar
Sören Hentzschel
Administrator
Beiträge: 15862
Registriert: Mi, 23. Nov 2011 0:39
Wohnort: Salzburg
Kontaktdaten:

Re: Nightly 58 aktuell Font-Problem?

#8

Beitrag von Sören Hentzschel » Fr, 10. Nov 2017 22:59

Was in der Beschreibung des verlinkten Tickets steht, ist für dein Problem irrelevant. Die Symptome auf deinem System sind eine unerwünschte Nebenwirkung des Patches, welcher zur Lösung dieses Tickets gelandet war. Dein Problem hat also wenig mit dem zu tun, was da steht. In diesem Ticket wurde nur die Änderung implementiert, welche dein Problem leider ausgelöst hat.

Benutzeravatar
HT-Frogger
Mitglied
Beiträge: 474
Registriert: Mo, 18. Jan 2016 22:14
Wohnort: Hamburg

Re: Nightly 58 aktuell Font-Problem?

#9

Beitrag von HT-Frogger Themen-Starter » Fr, 10. Nov 2017 23:13

Danke für die Info. Ich habe mich ja schon lange gewundert warum es nie größere Probleme mit der Nightly gegeben hat (57er und 58er). Da hatte ich an sich mit mehr "Problemchen" gerechnet... Bislang haben die Entwickler also gute Arbeit gemacht!

Gruß Harry
FF aktuell/beta/nightly, 64Bit, Linux, openSUSE Leap mit KDE

Benutzeravatar
POLIKS
Senior-Mitglied
Beiträge: 502
Registriert: Di, 22. Nov 2016 14:32

Re: Nightly 58 aktuell Font-Problem?

#10

Beitrag von POLIKS » Sa, 11. Nov 2017 0:11

milupo hat geschrieben:
Fr, 10. Nov 2017 22:45
Laut Bug betrifft das nur Linux.

In Fx 58 wurde der Wert der Einstellung security.sandbox.content.level sogar noch auf 4 erhöht. Setze den Wert in about:config auf 1.
Habe seit dem heutigen update gleiches Problem wie der BE; allerdings nur unter Linux openSUSE Leap 42.3.
Bei Linux oS Tumbleweed ist davon nichts zu sehen, alles funzt fehlerfrei. Habe die Sandbox-Werte mit 3 - 2- und auch 1 versucht. Keine Veränderung, Fehler bleibt. Abwarten ...
HT-Frogger hat geschrieben:
Fr, 10. Nov 2017 22:57
...
Folgendes habe ich getestet:
1. Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten NICHT erlauben
2. Zusätzlich andere Schriftarten eingestellt
3. Den Wert security.sandbox.content.level testweise auf 1 und auf 2 eingestellt (default: 3)
Hatte ich auch in Verdacht, alles versucht, keine Besserung.
Mich irritiert eben sehr, dass der Fehler unter Leap 42.3 auftaucht, aber unter Tumbleweed nicht erscheint ... :-???
Firefox 57 Quantum * Nightly 59 // openSUSE Leap 42.3 / openSUSE Tumbleweed

Benutzeravatar
HT-Frogger
Mitglied
Beiträge: 474
Registriert: Mo, 18. Jan 2016 22:14
Wohnort: Hamburg

Re: Nightly 58 aktuell Font-Problem?

#11

Beitrag von HT-Frogger Themen-Starter » Sa, 11. Nov 2017 11:04

Ich habe gerade gemerkt, daß es bei vielen Webseiten auftritt. Auch bei meiner eigenen, sogar auf den localhost! Ich habe da als Schriftart nur allgemein sans-serif und monospace verwendet, aber auch umstellen auf eine bestimmte Schriftart bringt es nicht. Ich habe hier übrigens noch Leap 42.2 am laufen.

Gruß Harry
FF aktuell/beta/nightly, 64Bit, Linux, openSUSE Leap mit KDE

Benutzeravatar
POLIKS
Senior-Mitglied
Beiträge: 502
Registriert: Di, 22. Nov 2016 14:32

Re: Nightly 58 aktuell Font-Problem?

#12

Beitrag von POLIKS » Sa, 11. Nov 2017 13:06

Hallo Harry,

nein, hatte das auch mit den Schriften (NOTO usw.) versucht. Meine Standardschrift ist DeJaVu Sans sowie Monospace; auch bei Sans Serif bleibt das Problem bestehen. Ich denke dass es nicht an den Schriften liegt. Dass es bei dir unter 42.2 (und zu 42.3 ist ja kein großer Unterscheid) auftaucht heisst, es könnte an Linux und/oder auch an Linux Leap liegen, da es hier (derzeit mit Tumbleweed Vs. 20171109 unterwegs ... ) nicht auftritt.

Bei mir tritt das Problem übrigens auch nur auf einigen Seiten auf
  • camp-firefox
    amazon
    facebook
    google mail
und einige mehr ...

Nicht unter
  • windows forum
    tagesschau
    gmx
Dachte auch, es habe etwas mit der Sandbox oder http/https zu tun; hat aber nicht :( Und das auch nur mit Nightly 58.0a1, nicht mit Firefox 56.0 etc.

Gruß Chris
Firefox 57 Quantum * Nightly 59 // openSUSE Leap 42.3 / openSUSE Tumbleweed

Benutzeravatar
HT-Frogger
Mitglied
Beiträge: 474
Registriert: Mo, 18. Jan 2016 22:14
Wohnort: Hamburg

Re: Nightly 58 aktuell Font-Problem?

#13

Beitrag von HT-Frogger Themen-Starter » Sa, 11. Nov 2017 13:43

Mit dem neuen Update von heute ist nun alles wieder gut (wie Sören ja schon schrieb). Vorher war auch die Quelltextanzeige davon betroffen, auch bei den Seiten die sonst richtig angezeigt wurden. Und das hat ja mit dem Fonts der Webseite nichts zu tun. Das ist mir zu hoch, ich belasse es dabei...

Gruß Harry
FF aktuell/beta/nightly, 64Bit, Linux, openSUSE Leap mit KDE

Benutzeravatar
POLIKS
Senior-Mitglied
Beiträge: 502
Registriert: Di, 22. Nov 2016 14:32

Re: Nightly 58 aktuell Font-Problem?

#14

Beitrag von POLIKS » Sa, 11. Nov 2017 15:26

Danke für die Info, dass es wieder funzt. Werde das die Tage mal austesten.
Den Quelltext hatte ich gar nicht kontrolliert, da siehste mal ... ;)
Firefox 57 Quantum * Nightly 59 // openSUSE Leap 42.3 / openSUSE Tumbleweed

Antworten

Wer ist online?

Mitglieder in diesem Forum: geldhuegel und 1 Gast