Mehrzeilige Tableiste für aktuelle FireFox-Versionen (71+)

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Da braucht sich niemand wundern. Wenn du den 68er deinstalliert hast und den 73er neu installiert hast, hast du möglicherweise auch unterschiedliche Profile. Und warum hast du den 68er deinstalliert, warum hast du ihn nicht einfach aktualisiert?


    Das ist ja die Version die ich mal vor langer Zeit instaliert habe wieso wird das nicht aktualisiert wenn die ihre Updates einspielen?

    Diese Frage musst du dir selbst stellen. Du musst doch mal gemerkt haben, dass nicht aktualisiert wird.

    Für was macht man denn dann die Updates wenn da nix geändert wird. Sicherheit ?

    Wie es aussieht, hast du gar keine gemacht. Der Ball liegt bei dir. Du kannst hier nicht Mozilla verantwortlich machen. Wenn nicht aktualisiert wird, könnte z. B. eine user.js schuld sein, die du nicht selbst angelegt hast. Du hast die ja vorhin schon mal erwähnt.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

    Einmal editiert, zuletzt von milupo () aus folgendem Grund: Ein Beitrag von milupo mit diesem Beitrag zusammengefügt.

  • Du hast da was falsch verstanden. Als ich damals Win10 installiert habe, war es die Firefox 68 Version bei der installation, natürlich mache ich alle Updates die beim Firefox angezigt werden mit. War noch nie anders. Also war bis jetzt dann Firefox73.01 die letzte. Aber wieso wird da der UserAgent nicht mit angepasst, das versteh ich dann nicht, das sollte doch so nicht sein. Ich mache hier wirklich nichts an dem Browsern rum, paar Addons und das wars. Die nehme ich schon seit Jahren da hat sich so gut wie nichts geändert.

    nichts ist unmöglich doch unmöglich ist nichts

  • Schau mal im Profil nach, ob du eine user.js hast. Wenn ja und du bist dir sicher, dass du sie nicht selbst angelegt hast, stelle den Inhalt hier mit dem Code-Symbol </> ein.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Hallo Andreas, ich hab tatsächlich mal den ESR installiert gehabt, weil da noch die alten Plugins gingen die ich damals benutze. Da es dann aber die meisten in der neuen Form/Version gab, bzw Alternativen dazu, bin ich wieder weg davon. Aber ich habe damals die Sync natürlich angehabt. Und genau da liegt zu mindestens mal 1 Haken. Denn durch die Sync von den Einstellungen wird mir der 68er eingeschrieben. Hab festgestellt das man über das Bereinigen das weg machen kann. Also jetzt steht wieder die richtige Version im User Agent und die Einstellungen lass ich nicht mehr Syncen. Musste das 2 mal machen mit dem Bereinigen, weil ich vergessen hab mich abzumelden, dann legt der natürlich gleich los^^. So also das haben wir mal geklärt. Morgen mache ich in aller Ruhe nochmal alles von Seite 1 und geb Rückmeldung. Danke Jungs Prima Klima hier. Freut mich das ihr auch so hartnäckig dran geblieben seit. Hoffe das morgen dann endlich alles klappt.


    nichts ist unmöglich doch unmöglich ist nichts

  • Was ich nur nicht verstehe, welche Version hast du denn als portable dann benutzt, weil es damit ja auch nicht funktioniert hat:/


    Da du den Fx 73.0.1 ja neu installiert hast, und wahrscheinlich auch ein neues Profil nutzt, muss du alle Dateien für die Scripte wieder neu installieren.


    Dann noch in about:config den Schalter:


    toolkit.legacyUserProfileCustomizations.stylesheets


    auf true stellen, um CSS Codes über die userChrome.css nutzen zu können.


    Dann über


    about:profiles


    prüfen, welches Profil du für den Fx 73 nutzt, damit du in diesem dann die Änderungen vornimmst.

  • Hallo 2002Andreas natürlich das weiß ich ja selbst. Ich habe ihn komplett gelöscht auch in Registry, ja ich weiß ist normal unnötig habs trotzdem gemacht. Sämtliche Profile gelöscht und alle Ordner die Firefox angelegt hat. Dann Firefox 73.01 neu installiert. Natürlich in das neue Profil und Installordner alles Dateien neu rein kopiert. UserAgent ist 73.01 und was soll ich euch sagen. Es geht nicht. Die userChrome.css geht. Scripte keine Chance alles so wie gehabt. Mein PC will das einfach nicht. AUf meinem Laptop geht es übrigens auch nicht. Hab das Gefühl das da was bei den Scripten nicht stimmt. Entweder wird da bei dem Inhalt kopieren etwas falsch gemacht bei den uc.js Dateien weil was anderes kann es jetzt faktisch nicht mehr sein. Die userChrome.css wird aber korrekt übernommen soweit ich das sehen kann. Leider hab ich sonst keine möglichkeit das jetzt noch irgendwie zu verifizieren. Achso ja der Portable FF war ebenfalls 73.01.


    Zippe mir mal die Dateien ucerChrome.css Nr 2 und die uc.js Nr3 bzw diesen about:config Button vielleicht ist das jetzt dann die letzte möglichkeit die ich sehe.

    nichts ist unmöglich doch unmöglich ist nichts

  • das da was bei den Scripten nicht stimmt.

    Wenn es an den Scripten liegen würde, dann wäre das Forum voll mit Hilferufen, das kannst du mir glauben;)


    Ich nutze hier 39 Scripte, andere User teilweise noch mehr.

    In allen Profilen und Versionen, auch portable, auf meinem PC funktionieren die einwandfrei.


    Die userChrome.css hat nichts mit den Scripten zu tun.

    Die ist zuständig für CSS Dateien, Scripte laufen unter .uc.js


    Mir fällt echt nichts mehr ein, warum das bei dir nicht funktioniert:/


    bei dem Inhalt kopieren etwas falsch gemacht

    Du musst nur auf diesen Button klicken, dann wird der kompl. Code in der Zwischenablage gespeichert.


    Mit freundlichem Gruß.
    Andreas
    Mein System    Meine Add-ons

    Einmal editiert, zuletzt von 2002Andreas () aus folgendem Grund: Ein Beitrag von 2002Andreas mit diesem Beitrag zusammengefügt.

  • Ich habe ihn komplett gelöscht auch in Registry, ja ich weiß ist normal unnötig habs trotzdem gemacht. Sämtliche Profile gelöscht und alle Ordner die Firefox angelegt hat. Dann Firefox 73.01 neu installiert.

    Wozu das Ganze? Das war unnötig, zumindest für die Einrichtung der Skriptbenutzung. Wenn du jetzt wirklich Fx 73 hast, musst du nur die richtigen Dateien im Profilordner - userChrome.js und die Skriptdateien mit der Endung .uc.js sowie die notwendigen Dateien config.js, den Ordner userChromJS im Wurzelverzeichnis des Installationsverzeichnisse und die Datei config-prefs.js im Installationsverzeichnis unter defaults/pref/ haben.


    Die richtige Version für aboutconfig-button.uc.js ist wieder in Beitrag #166.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Und beachte auch, dass du die Scripte mit der Zeichenkodierung UTF-8 speicherst und nicht als ANSI oder sonst was.

  • Bin mir nicht sicher, ob ich dich richtig verstanden habe :/


    Wenn du keine 'Mehrzeilige Tableiste' benutzt, dann braucht du auch das von dir verlinkte Skript nicht. Dann nimmst du einfach die CSS-Version von 2002Andreas: hier.


    Oder tritt das Problem bei nur einer Tabzeile auf und verschwindet, wenn mehrere Tabzeilen dargestellt werden ?


    Hast du das neue Skript(3) (Update vom 18.02) benutzt? #1

    In diesem Skript ist die Funktionalität von 'TabsRunter.uc.js' schon integriert und das Skript muss entfernt werden!

    Einfach die Update-Hinweise lesen...;)

    Wie bekomme ich das rechts weg (minimieren/schliessen)?

    CSS
    #TabsToolbar > .titlebar-buttonbox-container {
        display: none !important;
    }    
  • Bin mir nicht sicher, ob ich dich richtig verstanden habe :/

    Doch, ich denke schon.:)

    Erst einmal danke für deine Rückmeldung. Alles, was du da anführst, habe ich gewissenhaft gelesen und auch getestet. Auch den css-Code von Andreas, der funktioniert tadellos. Es ging mir allein um dieses kleine Script, um es auch ganz normal nutzen zu können (ohne mehrzeilige Tabreihen).

    Den von dir eingestellten Code zur Ausblendung der Button-Box hatte ich in diesem Zusammenhang auch getestet, aber da trat das von mir geschilderte Problem auf.

    Jetzt habe ich Folgendes gemacht, das Script eingesetzt, und den css-Code zusätzlich eingearbeitet. Dadurch habe ich links den Pfeil, rechts Neuer Tab. Das ist weiter nicht schlimm, denn ich kann bequem mit der Maus horizontal in der Tabreihe hin und her scrollen, obwohl mir rechts auch der Pfeil zusagen würde, dafür NewTab weg.

    CSS
     #TabsToolbar > .titlebar-buttonbox-container {
    display: none !important;
    }
    /* Buttons/Zwischenräume Ausblenden */
    hbox.titlebar-spacer,
    #alltabs-button,tabs tab:not([fadein]), 
    [class="scrollbutton-down"] { 
        display: none; 
    }

    Grüße vom FuchsFan

  • BrokenHeart


    Die letzten Tage habe ich mir deine Collection mal in Ruhe angesehen und auch durchprobiert. Du berufst dich ja auch auf die Scripte von Endor für mehrzeilige Tabreihen, die, obwohl ich sie persönlich nie voll ausnutzen werde, mir es doch sehr angetan haben.

    Deine CSS-Codes mit den Scripten von Endor, was will man mehr.

    So, was habe ich probiert?

    Ich habe den CSS-Code aus 2.) genommen, dort die Zeilen 17 bis 47 entfernt. Gleich dazu noch, in dem Code gibt es zweimal den identischen Punkt "Tab Höhe", Zeile 5 bis 12 und Zeile 95 bis 102.

    Dann habe ich die Scripte 01 und 03 für meine Zwecke vorbereitet. Dazu habe ich aus dem Script 02 den Absatz für die Scrollbar entnommen und ihn in die Scripte 01 und 03 eigearbeitet. Hier der Code aus Script 02:

    Wie in dem Script auch beschrieben sind die Basis 5 Tabreihen, dann die Scrollbar. Ich habe das auch auf 3 reduziert, kann nach Bedarf geändert werden.


    Eventuell hast du ja Interesse daran, dir das auch noch mal anzuschauen. Das würde meiner Ansicht nach deine Sammlung hier noch komplettieren. Danke für das reichhaltige Angebot.:thumbup::)


    Hier ein Schnappschuss von Script 01:



    hier von Script 03:


    Grüße vom FuchsFan

    Einmal editiert, zuletzt von FuchsFan ()

  • Sorry, habe momentan wenig Zeit irgendwas zu testen. Was bewirken deine Änderungen? Ich kann das momentan an Hand deines Codes und deiner Beschreibung nicht ganz nachvollziehen...:/

  • Seit meinem Update auf FF81 spinnen meine TABs total.
    Könntet ihr bitte einmal einen Blick darauf werfen, was da falsch läuft ?

    Aktuelles Verhalten sieht so aus:
    http://image-bugs.com/images/2…/25-09-_2020_15-55-59.gif

    Bis FF79 ging bei mir alles und ich habe kein "MultiLineTab-V4.uc.js" oder ähnliches benutzt dafür.

    Ich habe auch schon einen Thread dafür aufgemacht und beschrieben was bei mir aktuell falsch läuft im FF81.
    Hier der Link => RE: Firefox 81 TABs viel zu klein !


    Mein Ordner sieht so aus:



    Meine aktuelle "userChrome.css" sieht so aus:

  • was bei mir aktuell falsch läuft im FF81.

    Das kann ich Dir auch nicht sagen. Aber ich habe Deinen Code von hier genommen, und nur diesen in die userChrome.css eingefügt.Es funktioniert mit der Anzeige der Tabreihen, als auch mit dem Verschieben der Tabs.

    Ich sehe gerade, Du hast da noch einen Ordner css, also nutzt Du noch anderen Code?

    Grüße vom FuchsFan