Suchmaschinensuche in Adressleiste komplett ausschalten?

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hallo,


    beim Umstieg von Waterfox auf den neuesten Firefox ist mir aufgefallen, dass die Suchfunktion via Suchmaschine immer läuft, egal, was ich in den Einstellungen vornehme.

    Auf dem nachfolgenden Screenshot sieht man ein Beispiel, was ich meine:



    Unter Einstellungen -> Suche -> Standardsuchmaschine sind alle Häkchen entfernt, und natürlich habe ich eine extra Suchleiste.

    Trotzdem wird, wenn ich bspw. "heise" anfange in die Adressleiste zu schreiben, zu allererst die Google-Suche angeboten und ist bereits blau unterlegt. D.h. wenn ich jetzt also "heise" so per Enter bestätige, lande ich bei google, nicht bei heise.de! Und das, obwohl FF ja offenbar auch heise als Website findet, wie man in den Einträgen unterhalb sehen kann. Letzteres ist auch gewollt, da ich unter Einstellungen -> Datenschutz & Sicherheit -> Adressleiste, ein Häkchen bei "Einträgen aus der Chronik" gesetzt habe.


    Auch, wenn ich mich mal verschreibe, bei der Adressangabe, lande ich sofort bei google. Eigentlich sollte dann da aber stehen, dass die Seite nicht gefunden werden konnte.


    Mich verwirrt das einfach immer wieder, wenn Adress- und Suchleiste zusammengeworfen werden, deshalb würde ich die Suchmaschinen-Suche in der Adressleiste gerne komplett deaktivieren.

    Geht das noch irgendwie anders?


    Die FF-Installation und auch das Profil sind komplett neu aufgebaut, allerdings habe ich die Lesezeichen aus einem früheren Profil importiert.

    Mir ist dieses Verhalten auch schon bei Comodo Ice Dragon (der z.Zt. auf FF 65 basiert) aufgefallen, mit dem ich parallel auch etwas experimentiert habe.

    Es scheint sich also über ein profil-übergreifendes Problem zu handeln, oder ich habe das Talent eben in beiden Profilen irgendeine Funktion zu aktivieren/deaktivieren, dass das bei mir so auftritt ...

  • Hallo


    Folgendes Vorgehen:


    1. Einen Ordner namens chrome im Profilordner speichern
    2. Den Editor öffnen und folgenden Eintrag tätigen #urlbar-results {display: none !important;}
    3. Datei im erstellten Ordner chrome speichern wie folgt:
    Dateiname: userChrome.css
    Dateityp: Alle Dateien
    Codierung: UTF-8
    4. Firefox neu starten.

    "Wir fahren diesen Planeten gerade an die Wand"
    Klimaforscher Hans Joachim Schellnhuber

  • Hallo,


    der Ansatz von StandingBill ist aus dem von Andreas genannten Grund falsch. Der Ansatz von Andreas ist der richtige, wenn man grundsätzlich die Zeile entfernen möchte, welche anzeigt, was passiert, wenn man Enter drückt. Das betrifft ausdrücklich nicht nur den Fall der Suchmaschine und ist rein optisch, das heißt, das Kriterium, folgendes zu ändern, wird nicht erfüllt:

    D.h. wenn ich jetzt also "heise" so per Enter bestätige, lande ich bei google, nicht bei heise.de


    Eine Anpassung via CSS kann das Verhalten des Browsers nicht verändern, sondern nur Kosmetik betreiben.


    Geht es um das Deaktivieren der Standard-Suchmaschine in der Adressleiste, ist der richtige Ansatz, über about:config keyword.enabled auf false zu setzen. Dann versucht Firefox aber, jede Eingabe als Host zu interpretieren, das wird ebenfalls nicht den ersten Vorschlag automatisch aktivieren.

  • Danke für die Antworten!


    Also, es ist halt so, dass "früher" (mit Waterfox) meist der erste Buchstabe oder die ersten Buchstaben gereicht haben, dann wurde schon die richtige Seite aus der Chronik vorgeschlagen (und zwar auschließlich aus der Chronik, ohne Google-Suchvorschläge) und ich musste nur noch mit Enter bestätigen - und ich war auf der Seite.


    Jetzt laufe ich immer Gefahr, dass mir die Google-Suche dazwischen funkt!



    Ich habe jetzt mal beide Vorschläge aus Beitrag 3 und 4 nacheinander (also nicht gleichzeitig) getestet und beide bringen zumindest eine Verbesserung, soweit ich das bis jetzt beurteilen kann.


    Der Eklärung nach ist wohl die about:config Änderung die effektivere Methode.

    Im Falle meines Beispiels "heise" lande ich dann allerdings bei heise.com (nicht heise.de), obwohl ja heise.de an sich schon in der Chronik steht (im Gegensatz zu heise.com; bzw. jetzt steht es halt mittlerweile dummerweise auch in der Chronik, da ich es ja "unfreiwillig" einmal angewählt habe, bzw. es von selbst so ausgewählt wurde).

    Jetzt ist mir aber heise auch nicht so wichtig, war ja nur ein Beispiel. Bei anderen Seiten, die ich öfter mal im Laufe des Tages abklappere, klappt es eigentlich einwandfrei.


    Auch anders scheint jetzt zu sein: Früher konnte man unliebsame Suchvorschläge in der Adressleiste einfach mit der Entfernen-Taste löschen (also zuvor mit den Pfeil-Tasten anwählen, so dass es blau unterlegt ist und dann auf entf drücken), das bewirkt aktuell aber genau nichts!

  • Im Falle meines Beispiels "heise" lande ich dann allerdings bei heise.com (nicht heise.de)


    Du könntest über about:config den Schalter browser.fixup.alternate.suffix von ".com" auf ".de" stellen. Das gilt zwar auch immer, kann aber auch nochmal eine Verbesserung darstellen, falls du mehr Seiten mit ".de" als mit ."com" öffnest. Oder du schaltest diese Vervollständig via browser.fixup.alternate.enabled (false) komplett aus. Dann landest du im schlimmsten Fall auf einer Fehlerseite.


    Auch anders scheint jetzt zu sein: Früher konnte man unliebsame Suchvorschläge in der Adressleiste einfach mit der Entfernen-Taste löschen (also zuvor mit den Pfeil-Tasten anwählen, so dass es blau unterlegt ist und dann auf entf drücken), das bewirkt aktuell aber genau nichts!


    Halte dabei die Shift-Taste gedrückt. Das ist auf Windows jetzt gleich wie es auf macOS schon immer war.

  • ... Oder du schaltest diese Vervollständig via browser.fixup.alternate.enabled (false) komplett aus. Dann landest du im schlimmsten Fall auf einer Fehlerseite.

    Ja, ich glaube, das wär mir am liebsten, das probiere ich auf jeden Fall mal aus.


    Okay, und mit der Shift-Taste + Entf klappt auch das Löschen!


    Danke für die Tipps! :)