PWA will unter Android auf 65.0 und 66.0b.11 nicht laufen

  • Hallo,
    seit Tagen kämpfe ich damit eine PWA auf unserem Samsung Galaxy Tab A6 10.1" (SM-T580) zum laufen zu kriegne. Es ist ein debian server (PHP 7.0, Apache 2, https) auf dem die Seite läuft.
    Ich habe alle für mich auffindbaren Anleitungen gelesen und ausprobiert, aber nichts läuft.
    Die WebApp, die ich zum Testen entwickelt habe, läuft sowohl auf Chrome als auch auf dem Samsung Browser einwandfrei.
    Meine letzte Hoffnung waren die Beispiele von https://github.com/mdn/pwa-examples, aber auch die laufen 1zu1 übernommen mit dem Firefox nicht und mit Chrome und Samsung auf Anhieb.


    Gibt es irgend etwas, dass ich beim Firefox anders machen muss, als bei den anderen.
    Installieren versuche ich die Seite über "Seite" und "Seitenverknüpfung hinzufügen". Das Haus-Symbol in der Leiste erscheint nicht. Bei öffentlichen Seiten wie Twitter o.ä. klappt all dies auch im Firefox.


    Vielen lieben Dank

  • Ich habe es lösen können, bin aber dabei auf ein weiteres Problem gestoßen.


    Die Lösung meines Problems war, dass die https Verbindung wegen einer noch nicht fertig eingerichteten Domain und damit einem Unterschied der im Zertifikat genannten Domain und der wirklichen Domain des Servers zwar funktionierte, aber von Firefox als unsicher eingestuft wurde.


    Nachdem wir das behoben haben und im Firefox das Schloss grün geworden ist, läuft alles.


    Chrome und der Samsung Browser haben sich daran überigens nicht gestört...


    Für das zweite Problem (SEC_ERROR_UNKNOWN_ISSUER) mache ich ein neues Thema auf!


    Viele Grüße