Beiträge von Karbon

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    quem jucket?

    Wir befinden uns in einem Browser-Forum. Medizinische Fragen dürften hier deplatziert sein...


    ==================================


    Inzwischen arbeite ich mit Firefox 78. Da die kosmetischen Animationen nun tatsächlich deaktiviert werden können, nutze ich alle themenrelevanten Button, s. Screenshots.


    Zitat

    Wenn das Bibliothekssymbol ausgeblendet ist, kommt die Meldung immer. Wenn ich das Bibliothekssymbol einblende kommt statt der recht auffälligen Meldung eine kurze Animation: Blaues Sternchen plumpst in das Bibliothekssymbol

    Hier unterbleibt die recht auffällige Meldung nicht, obwohl der Zähler die 3 überschritten hat. Was habe ich übersehen? Wird eine weitere Einstelllung benötigt?


    Ach ja, Firefox Portabler bzw der Starter arbeitet gänzlich ohne profiles.ini - steht aber auch so im verlinkten Beitrag. Es gibt nur ein Profil.

    moin, das klappt hier nicht. Ist die profiles.ini in user-path-firefox nicht vorhanden, wird sie auto-platziert. Lokale Seiten starten dann wieder im angesicherten Modus.

    Muss ggf. eine Bedingung erfüllt werden, damit es ohne profiles.ini funktioniert?

    *köstliche Knobelkur* :D


    "..\roaming\mozilla\firefox\profiles.ini" zu editieren erlöste mich vom Öffnen im abgesicherten Modus.

    Allerdings waren nun die lokal geöffnete Datei und der (per Verknüpfung / Tatstakombi) geöffnete Fuchs verschiedene Instanzen.


    Eine D:\FirefoxPortablePath\profiles.ini musste ich explizit gleich der o.g. profiles.ini anlegen.

    Nun habe ich wieder ein problemloses Verhalten wie zu Zeiten, als ich noch keine portableapps genutzt hatte.


    -- Irritierend ist da für mich nur, dass mein Anliegen, nichts mit dem User-Bereich in der Bootpartition zu tun zu haben, nicht funktioniert. Das ist für mich unerwartet. Denn wer mit dem USB-Stick portable unterwegs ist, hinterlässt auf genutzten Systemen eben doch User-Spuren.


    Danke Andreas, die Aufgabe zeigte sich elegant, reproduzierbar lösbar.

    Lokale Files wie .url, .htm, .html sowie URLs, die aus e-mails geöffnet werden, öffnen im abgesichten Modus.

    Alerdings, wenn die Standardbrowser-Instanz bereits normal geöffnet war, öffneten auch lokale URLs normal.

    78.0.2 hält sich nicht an die "ur"-bekannte Regelung. Er öffnet lokales stets im abgesichten Modus.

    about:profiles, hier ist nur 1 Profil eingetragen und aktiv.

    Alles zeigt sich normal, keine Extension macht Probs. Auch private Fenster öffnen normal.

    Was mag die Ursache des Problems sein?

    Lesezeichen sichern, wiederherstellen klappt.

    Nun habe ich in einem Browser weitere Lesezeichen gesammelt und möchte z.B. nur eine Auswahl übertragen. Oder ich möchte alles übertragen, am Ziel aber nicht löschen lassen sondern ergänzen. Die Warnung, dass alle Lesezeichen gelöscht werden, kommt auch, wenn ich z.B. in "Weitere Lesezeichen" gesammelt habe und am Ziel dto. nach dem am Ziel leeren "Weitere ..." übertragen möchte. (Sync würde nicht nützen, da die Browser verschiedene Aufgaben haben.)


    Ansich würde ich hier nicht pauschal im Hintergrund arbeiten lassen sondern beim sichern und wiederherstellen selektiv arbeiten. Ist das möglich? Konnte ich

    womöglich nur die richtigen Hilfeseiten nicht finden?

    Dank dir sehr, das ist der gesuchte Eintrag. Dank dir auch für den Eintrag in about:config. Freigeschaltet hatte ich die Chrome-Dateien bereits. Ich war allerdings überrascht, denn ich hatte ein bestehendes Profil zum FF70 kopiert und gewählt. Es ist wirksam, FF70 hielt sich dennoch für jungfräulich. ;)


    Viele Grüße

    Karbon

    Hmm. Der in der Falschen Rubrik angelegte Thread wurde nicht gelöscht, sondern der nun richtig angelegte Thread wurde geschlossen. Das ganze von mir hier gesagte ist nicht mehr zeitgemäß. Ich lösche es und beginne mit dem aktiellen Ist-Zustand:

    ____________________________________________


    Habe einen aktuell neuen Fuchs 68.0.1 (64-Bit) portable sehr minimalistisch ohne Extensions usw. angelegt:


    Neues Profil, in chrome nur userChrome.css und userConfig.css angelegt.

    Dazu die Grundeinstellungen wie Startseite, Suche, Tabverhalten...,

    Habe das frische Profil als Standard gewählt.

    Die Menüleiste lasse ich anzeigen, habe ansonsten nichts geänder. Das Bookmark-Symbol steht am vorgesehen Platz.


    about:config

    geändert: toolkit.cosmeticAnimations.enabled false


    browser.bookmarks.editDialog.confirmationHintShowCount 5

    Count soll ansich max bis 3 hochzählen, danach nicht höher zählen. Es wird weiter gezählt.


    Beim Platzieren von Bookmarks erscheint eine Meldung. Genau die soll aber ab Count = 3 nicht mehr erscheinen.

    Test: Weglassen der userChrome.css. Das Browserverhalten zeigt, FF sucht sich kein anderes Profil.

    Die Meldung beim Bookmarken erscheint unabwendbar weiterhin.

    Die userChrome.css nutze ich nun wieder.


    Oh ja, ich bin ratlos. Welchen (nun kaum noch möglichen) Fehler könnte ich eingebaut haben?

    Aus der WIN 7 Prof 64bit Umgebung wird der Stop von Count ja wohl nicht verhindert werden, bzw. die Meldung wird vom System sicher nicht forciert werden? Kennt jemand den Fehler oder hat eine Idee?

    Habe einen aktuell neuen Fuchs 68.0.1 (64-Bit) portable sehr minimalistisch ohne Extensions usw. angelegt:


    Neues Profil, in chrome nur userChrome.css und userConfig.css angelegt.

    Dazu die Grundeinstellungen wie Startseite, Suche, Tabverhalten...,

    Habe das frische Profil als Standard gewählt.

    Die Menüleiste lasse ich anzeigen, habe ansonsten nichts geänder. Das Bookmark-Symbol steht am vorgesehen Platz.


    about:config

    geändert: toolkit.cosmeticAnimations.enabled false


    browser.bookmarks.editDialog.confirmationHintShowCount 5

    Count soll ansich max bis 3 hochzählen, danach nicht höher zählen. Es wird weiter gezählt.


    Beim Platzieren von Bookmarks erscheint eine Meldung. Genau die soll aber ab Count = 3 nicht mehr erscheinen.

    Test: Weglassen der userChrome.css. Das Browserverhalten zeigt, FF sucht sich kein anderes Profil.

    Die Meldung beim Bookmarken erscheint unabwendbar weiterhin.

    Die userChrome.css nutze ich nun wieder.


    Oh ja, ich bin ratlos. Welchen (nun kaum noch möglichen) Fehler könnte ich eingebaut haben?

    Aus der WIN 7 Prof 64bit Umgebung wird der Stop von Count ja wohl nicht verhindert werden, bzw. die Meldung wird vom System sicher nicht forciert werden? Kennt jemand den Fehler oder hat eine Idee?

    Ja genau. Ampeln zeigen beileibe nicht nur grün. Wer außer den geschulten Leuten kann bei der blindengerechten Ampel die klackernden Signale den Signalbedeutungen zuordnen? Nun stell mal nur die drei wichtigen fußgängerseitigen Signale durch Animationen dar...


    Analog zum Beispiel können Button via Animation keine Zuordnungen darstellen, die jeder kennt. Animationen heischen Aufmerksamkeit. Ansonsten? Außer ihrer sehr lästigen Aufdringlichkeit tun sie definitiv nichts. Und... was mag z.B. wohl ich über die Personen diverser Button-Animateure denken?


    Man will mir (ollem Elch) via eine für mich absolut unnötige Meldung ein Lernpensum aufdoctrinieren? --- Ich meinde das ernst.


    Mein Fokus sprach und spricht von Meldungen, die ich dringlich entsorgen möchte. Auch bei weiteren Usern tritt der Fehler auf, ein User hat sich gemeldet. - Da offenbar nicht erkundet wurde, wie der Fuchs möglicherweise auf noch belassene userChrome.css Einträge reagieren mag, wird nur die Möglichkeit des neu angelegten Profils bleiben... (man gönnt sich ja sonst nix.)

    Dank. Da spezifisch keine Idee existiert, bleibt nichts anderes übrig.

    Ich habe nicht die geringste Ahnung, von was für einem Experiment du sprichst und wo es angeblich ein Risiko welcher Art auch immer geben soll.

    Nun, genau deshalb habe ich die Frage gestellt. Für die genannten Ideen sehe ich dankbar aus. :)


    Zitat

    Diese Aussage ergibt überhaupt keinen Sinn. Ganz im Gegenteil ist das Anzeigen von Meldungen, wenn etwas funktioniert, sogar ein extrem geläufiges UX Pattern.

    So mag es zunächst mal (teilweise) programmiererseitig aussehen. Z.B. WIN XP war für die extreme, nicht wegkonfigurierbare Meldungen-Häufigkeit sehr breitbandig verschrien.

    Zitat

    Das hat mit "Antilogik" wirklich nicht das Geringste zu tun. Du siehst die Logik nur nicht. Was damit zusammenhängen könnte, dass du die Animationen abgeschaltet hast. Würdest du die Animationen zum Test mal aktivieren, sollte die Logik für dich auch offensichtlich sein.

    Nun, ich orientiere mich absolut anders. Eine statische und eine rumhüpfende grüne Ampel haben für mich exakte den gleichen Signalwert = grün. - In der Tat, die Straße mit den hüpfenden Ampeln werde ich stets strikt meiden.

    Unangenehm bleibt unangenehm. In allen Lebensbereichen wird unangenehmes gemieden. ... Kann der Punkt überhaupt diskussionsfähig sein? Definitiv alles, was lebt, verhält sich nach dem exakt gleichen Schema.

    Zitat

    Der Button ist Teil der Animation. Die Animation symbolisiert exakt das, was die Meldung in Worten sagt. Beides ist nicht notwendig, aber wird die ersten drei Male dennoch zusammen angezeigt, um einen Lerneffekt bereitzustellen. Gibt es den Button nicht, dann kann es auch die Animation nicht mehr geben. Und dann wird die Meldung immer angezeigt. Wie ich bereits erklärte: Als Kompensation für die fehlende Animation. Man muss es nicht mögen, aber dass es eine Logik dahinter gibt, lässt sich nicht verneinen.

    S.o., ich kann nicht zustimmen. Die Farbe grün ist im Beispiel das wichtige Signal. Die statische oder die hüpfende Ampel schafft unabhängig vom Signalwert etwas anderes ohne spezifische Aussage.

    Probiere es getrost aus, es ist. Zum Sachverhalt gibt es ganz einfach diverse Orientierungen, Gewohnheiten.

    Zitat

    Erneut habe ich keine Ahnung, wovon du sprichst. Aber ganz ehrlich, mittlerweile ist das hier auf ein Niveau abgedriftet, bei dem ich keine Lust mehr habe. Ich bin raus. Ich habe sowieso schon alles gesagt, was es zur Implementierung in Firefox zu wissen gibt.

    Dank für die Hilfe. Niveau? Ich versuchte, auf von dir gestellte Fragen zu antworten. - Ich erkläre jedenfalls nicht, dass die Fragen kein Niveau gehabt hätten. Wir orientieren uns absolut verschieden. Das ist es.

    Da das in Firefox 66 implementiert wurde, ist das dementsprechend in Firefox ESR 68 auch vorhanden.

    Dank dir für die Info. Das bringt also nix, obendrein verlangt der ESR nach anderer Konfiguration. - Ansich bleibt nur der Traum, dass für den Seamonkey einige interessante Extensions realisiert werden.


    -- Na ja, ich als begeisterter Purist werde "diverses" sicher nie kapieren. Z.B. hier, ich benötige keinen Bibliothek-Button. Die geöffnete Seite soll gebookmarkt werden, ich bediene Strg+D + warten / editieren / Enter. Wieso sollte ich bei solider, bewährter Routine eine Meldung oder gar eine Animation benötigen?


    User sind sehr verschieden. Ergo werden in einer fernen, vielleicht tatsächlich einst realisiert werdenden Zukunft optional verschiedene Wege ermöglicht. Bis dahin... man erkennt uva. hier am fast absolut verspielten Fach-Forum, dass eine akzeptable Zukunft in sehr weiter Ferne liegt.

    Wenn ich nur einen Anhaltspunkt hätte, wo, wonach suchen Sinn macht. Nachdem Extensions nicht infrage kommen... ich mag für jede Idee dankbar aussehen. :) --- Muss mal schauen, im ESR wird das ja wohl auch implementiert sein/werden? Im Seamonkey bookmarken, im FF arbeiten wäre jedenfalls eine umständliche Lösung. :o

    Habe jetzt den Bibliotheksbutton platziert. Bisher zeigt es (zum Glück) keine Animation. Kein Unterschied, die Meldung kommt.

    Hatte die userChrome.css schon mal durchgeschaut auf ggf. nicht mehr kompatible Altlasten. Habe seitdem reichlich Lesezeichen gesetzt, die Meldung kam nicht. - Finde insgesamt keinen Anhaltspunkt, keine Idee, was der Auslöser der Meldung sein könnte.


    userChrome.txt

    Danke @Sören. Also ist hier etwas defekt. Der Wert von browser.bookmarks.editDialog.confirmationHintShowCount war 4. Dann habe ich auf verschiedene Werte editiert und frische Bookmarks angelegt. 0, 5, 444... Count zählt weiter, die Meldung erscheint.


    Besteht ein Bookmark bereits, erscheint die Meldung nicht, sondern der Dialog öffnet zum Editieren. Das macht Sinn.


    Bei frischen Bookmarks erscheint die Meldung stets, unabhängig davon, ob ich den Dialog öffnen lasse oder nicht. Was muss ich tun, damit die Meldung nicht mehr erscheint?